]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
42aeb5b84910e0e9551f686cebc46e2eb0477410
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.10.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/grc.txt
90 %doc doc/internal.txt
91 %doc doc/newvers.txt
92 %doc samples
93 %doc src/ld65/cfg/*.cfg
94
95
96
97 ###############################################################################
98 #                             Apple ][ subpackage                             #
99 ###############################################################################
100
101 %package apple2
102 Requires: %{name} = %{version}
103 Copyright: Freeware
104 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
105 Group: Development/Languages
106
107 %description apple2
108 This package contains the header files and libraries needed to write
109 programs for the Apple ][ using the cc65 crosscompiler.
110
111 %files apple2
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
113 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
114 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
115 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117
118
119
120 ###############################################################################
121 #                            Apple //e subpackage                             #
122 ###############################################################################
123
124 %package apple2enh
125 Requires: %{name} = %{version}
126 Copyright: Freeware
127 Summary: Apple //e specific libraries and headers for the cc65 compiler.
128 Group: Development/Languages
129
130 %description apple2enh
131 This package contains the header files and libraries needed to write
132 programs for the Apple //e using the cc65 crosscompiler.
133
134 %files apple2enh
135 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.o
137 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
138 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
139 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
140
141
142
143 ###############################################################################
144 #                              Atari subpackage                               #
145 ###############################################################################
146
147 %package atari
148 Requires: %{name} = %{version}
149 Copyright: Freeware
150 Summary: Atari specific libraries and headers for the cc65 compiler.
151 Group: Development/Languages
152
153 %description atari
154 This package contains the header files and libraries needed to write
155 programs for the 8 bit Atari machines using the cc65 crosscompiler.
156
157 %files atari
158 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
159 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
160 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
161
162
163
164 ###############################################################################
165 #                            Oric Atmos subpackage                            #
166 ###############################################################################
167
168 %package atmos
169 Requires: %{name} = %{version}
170 Copyright: Freeware
171 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
172 Group: Development/Languages
173
174 %description atmos
175 This package contains the header files and libraries needed to write
176 programs for the Oric Atmos using the cc65 crosscompiler.
177
178 %files atmos
179 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
180 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
181 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
182
183
184
185 ###############################################################################
186 #                               C128 subpackage                               #
187 ###############################################################################
188
189 %package c128
190 Requires: %{name} = %{version}
191 Copyright: Freeware
192 Summary: C128 specific libraries and headers for the cc65 compiler.
193 Group: Development/Languages
194
195 %description c128
196 This package contains the header files and libraries needed to write
197 programs for the Commodore C128 using the cc65 crosscompiler.
198
199 %files c128
200 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
201 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
202 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
203 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
204 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
205 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
206 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
207
208
209
210 ###############################################################################
211 #                                C16 subpackage                               #
212 ###############################################################################
213
214 %package c16
215 Requires: %{name} = %{version}
216 Copyright: Freeware
217 Summary: C16/116 specific libraries and headers for the cc65 compiler.
218 Group: Development/Languages
219
220 %description c16
221 This package contains the header files and libraries needed to write
222 programs for the Commodore C16/116 using the cc65 crosscompiler.
223
224 %files c16
225 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
226 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
227 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
228 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
229
230
231
232 ###############################################################################
233 #                               C64 subpackage                                #
234 ###############################################################################
235
236 %package c64
237 Requires: %{name} = %{version}
238 Copyright: Freeware
239 Summary: C64 specific libraries and headers for the cc65 compiler.
240 Group: Development/Languages
241
242 %description c64
243 This package contains the header files and libraries needed to write
244 programs for the Commodore C64 using the cc65 crosscompiler.
245
246 %files c64
247 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
248 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
249 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
250 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
251 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
252 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
253 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
254
255
256
257 ###############################################################################
258 #                              CBM510 subpackage                              #
259 ###############################################################################
260
261 %package cbm510
262 Requires: %{name} = %{version}
263 Copyright: Freeware
264 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
265 Group: Development/Languages
266
267 %description cbm510
268 This package contains the header files and libraries needed to write
269 programs for the Commodore CBM 510 (aka P500) using the cc65
270 crosscompiler.
271
272 %files cbm510
273 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
274 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
275 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
276 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
277 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
278
279
280
281 ###############################################################################
282 #                              CBM610 subpackage                              #
283 ###############################################################################
284
285 %package cbm610
286 Requires: %{name} = %{version}
287 Copyright: Freeware
288 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
289 Group: Development/Languages
290
291 %description cbm610
292 This package contains the header files and libraries needed to write
293 programs for the Commodore PET-II (CBM600/700) family of computers using
294 the cc65 crosscompiler.
295
296 %files cbm610
297 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
298 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
299 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
300 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
301
302
303
304 ###############################################################################
305 #                               GEOS subpackage                               #
306 ###############################################################################
307
308 %package geos
309 Requires: %{name} = %{version}
310 Copyright: Freeware
311 Summary: GEOS specific libraries and headers for the cc65 compiler.
312 Group: Development/Languages
313
314 %description geos
315 This package contains the header files and libraries needed to write
316 GEOS programs for the C64/C128 using the cc65 crosscompiler.
317
318 %files geos
319 %attr(755,root,root)            /usr/bin/grc
320 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
321 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
322 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
323 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
324 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
325 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
326 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
327
328
329
330 ###############################################################################
331 #                               Lynx subpackage                               #
332 ###############################################################################
333
334 %package lynx
335 Requires: %{name} = %{version}
336 Copyright: Freeware
337 Summary: Lynx specific libraries and headers for the cc65 compiler.
338 Group: Development/Languages
339
340 %description lynx
341 This package contains the header files and libraries needed to write
342 programs for the Lynx Game Console using the cc65 crosscompiler.
343
344 %files lynx
345 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
346 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.o
347 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
348 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
349
350
351
352 ###############################################################################
353 #                               NES subpackage                                #
354 ###############################################################################
355
356 %package nes
357 Requires: %{name} = %{version}
358 Copyright: Freeware
359 Summary: NES specific libraries and headers for the cc65 compiler.
360 Group: Development/Languages
361
362 %description nes
363 This package contains the header files and libraries needed to write
364 programs for the Nintendo Entertainment System using the cc65
365 crosscompiler.
366
367 %files nes
368 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
369 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
370 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
371
372
373
374 ###############################################################################
375 #                               PET subpackage                                #
376 ###############################################################################
377
378 %package pet
379 Requires: %{name} = %{version}
380 Copyright: Freeware
381 Summary: PET specific libraries and headers for the cc65 compiler.
382 Group: Development/Languages
383
384 %description pet
385 This package contains the header files and libraries needed to write
386 programs for the Commodore PET family of computers using the cc65
387 crosscompiler.
388
389 %files pet
390 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
391 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
392 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
393
394
395
396 ###############################################################################
397 #                              Plus/4 subpackage                              #
398 ###############################################################################
399
400 %package plus4
401 Requires: %{name} = %{version}
402 Copyright: Freeware
403 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
404 Group: Development/Languages
405
406 %description plus4
407 This package contains the header files and libraries needed to write
408 programs for the Commodore Plus/4 and C16/116 using the cc65
409 crosscompiler.
410
411 %files plus4
412 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
413 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
414 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
415 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
416
417
418
419 ###############################################################################
420 #                           Supervision subpackage                            #
421 ###############################################################################
422
423 %package supervision
424 Requires: %{name} = %{version}
425 Copyright: Freeware
426 Summary: Supervision specific libraries and headers for the cc65 compiler.
427 Group: Development/Languages
428
429 %description supervision
430 This package contains the header files and libraries needed to write
431 programs for the Supervision Game console using the cc65 crosscompiler.
432
433 %files supervision
434 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
435 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
436
437
438
439 ###############################################################################
440 #                              VIC20 subpackage                               #
441 ###############################################################################
442
443 %package vic20
444 Requires: %{name} = %{version}
445 Copyright: Freeware
446 Summary: VIC20 specific libraries and headers for the cc65 compiler.
447 Group: Development/Languages
448
449 %description vic20
450 This package contains the header files and libraries needed to write
451 programs for the Commodore VIC20 using the cc65 crosscompiler.
452
453 %files vic20
454 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
455 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
456 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
457
458
459
460 ###############################################################################
461 #                                    Build                                    #
462 ###############################################################################
463
464
465
466 %prep
467 %setup -q
468
469
470 %build
471 # Binaries
472 make -C src -f make/gcc.mak
473 # Libraries
474 make -C libsrc -s zap all
475 # Documentation
476 make -C doc html
477
478
479 %install
480 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
481
482 # Binaries
483 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
492 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
493 # Libraries and includes
494 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
495 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
496 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
497 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
498 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
499 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
500 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
501 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
502 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
503
504 # Drivers
505 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
506 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
507 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
508 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
509 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
510
511
512 %clean
513 rm -rf $RPM_BUILD_ROOT
514
515
516
517 %changelog
518 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
519 - Changelog is now in CVS