]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
8b091fe486ac1a1def9e7824918909ba7fa7bdc1
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
113 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
114 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
115
116
117
118 ###############################################################################
119 #                              Atari subpackage                               #
120 ###############################################################################
121
122 %package atari
123 Requires: %{name} = %{version}
124 Copyright: Freeware
125 Summary: Atari specific libraries and headers for the cc65 compiler.
126 Group: Development/Languages
127
128 %description atari
129 This package contains the header files and libraries needed to write
130 programs for the 8 bit Atari machines using the cc65 crosscompiler.
131
132 %files atari
133 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
134 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
135 %attr(644,root,root)            /usr/lib/cc65/joy/atari-*.joy
136
137
138
139 ###############################################################################
140 #                            Oric Atmos subpackage                            #
141 ###############################################################################
142
143 %package atmos
144 Requires: %{name} = %{version}
145 Copyright: Freeware
146 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
147 Group: Development/Languages
148
149 %description atmos
150 This package contains the header files and libraries needed to write
151 programs for the Oric Atmos using the cc65 crosscompiler.
152
153 %files atmos
154 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
155 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
156
157
158
159 ###############################################################################
160 #                               C128 subpackage                               #
161 ###############################################################################
162
163 %package c128
164 Requires: %{name} = %{version}
165 Copyright: Freeware
166 Summary: C128 specific libraries and headers for the cc65 compiler.
167 Group: Development/Languages
168
169 %description c128
170 This package contains the header files and libraries needed to write
171 programs for the Commodore C128 using the cc65 crosscompiler.
172
173 %files c128
174 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
175 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
176 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
177 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
178 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
179 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
180
181
182
183 ###############################################################################
184 #                                C16 subpackage                               #
185 ###############################################################################
186
187 %package c16
188 Requires: %{name} = %{version}
189 Copyright: Freeware
190 Summary: C16/116 specific libraries and headers for the cc65 compiler.
191 Group: Development/Languages
192
193 %description c16
194 This package contains the header files and libraries needed to write
195 programs for the Commodore C16/116 using the cc65 crosscompiler.
196
197 %files c16
198 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
199 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
200 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
201 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
202
203
204
205 ###############################################################################
206 #                               C64 subpackage                                #
207 ###############################################################################
208
209 %package c64
210 Requires: %{name} = %{version}
211 Copyright: Freeware
212 Summary: C64 specific libraries and headers for the cc65 compiler.
213 Group: Development/Languages
214
215 %description c64
216 This package contains the header files and libraries needed to write
217 programs for the Commodore C64 using the cc65 crosscompiler.
218
219 %files c64
220 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
221 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
222 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
223 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
224 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
225 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
226
227
228
229 ###############################################################################
230 #                              CBM510 subpackage                              #
231 ###############################################################################
232
233 %package cbm510
234 Requires: %{name} = %{version}
235 Copyright: Freeware
236 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
237 Group: Development/Languages
238
239 %description cbm510
240 This package contains the header files and libraries needed to write
241 programs for the Commodore CBM 510 (aka P500) using the cc65
242 crosscompiler.
243
244 %files cbm510
245 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
246 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
247 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
248 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
249 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
250
251
252
253 ###############################################################################
254 #                              CBM610 subpackage                              #
255 ###############################################################################
256
257 %package cbm610
258 Requires: %{name} = %{version}
259 Copyright: Freeware
260 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
261 Group: Development/Languages
262
263 %description cbm610
264 This package contains the header files and libraries needed to write
265 programs for the Commodore PET-II (CBM600/700) family of computers using
266 the cc65 crosscompiler.
267
268 %files cbm610
269 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
270 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
271 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
272 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
273
274
275
276 ###############################################################################
277 #                               GEOS subpackage                               #
278 ###############################################################################
279
280 %package geos
281 Requires: %{name} = %{version}
282 Copyright: Freeware
283 Summary: GEOS specific libraries and headers for the cc65 compiler.
284 Group: Development/Languages
285
286 %description geos
287 This package contains the header files and libraries needed to write
288 GEOS programs for the C64/C128 using the cc65 crosscompiler.
289
290 %files geos
291 %attr(755,root,root)            /usr/bin/grc
292 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
293 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
294 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
295 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
296 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
297 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
298 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
299
300
301
302 ###############################################################################
303 #                               NES subpackage                                #
304 ###############################################################################
305
306 %package nes
307 Requires: %{name} = %{version}
308 Copyright: Freeware
309 Summary: NES specific libraries and headers for the cc65 compiler.
310 Group: Development/Languages
311
312 %description nes
313 This package contains the header files and libraries needed to write
314 programs for the Nintendo Entertainment System using the cc65
315 crosscompiler.
316
317 %files nes
318 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
319 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
320
321
322
323 ###############################################################################
324 #                               PET subpackage                                #
325 ###############################################################################
326
327 %package pet
328 Requires: %{name} = %{version}
329 Copyright: Freeware
330 Summary: PET specific libraries and headers for the cc65 compiler.
331 Group: Development/Languages
332
333 %description pet
334 This package contains the header files and libraries needed to write
335 programs for the Commodore PET family of computers using the cc65
336 crosscompiler.
337
338 %files pet
339 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
340 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
341
342
343
344 ###############################################################################
345 #                              Plus/4 subpackage                              #
346 ###############################################################################
347
348 %package plus4
349 Requires: %{name} = %{version}
350 Copyright: Freeware
351 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
352 Group: Development/Languages
353
354 %description plus4
355 This package contains the header files and libraries needed to write
356 programs for the Commodore Plus/4 and C16/116 using the cc65
357 crosscompiler.
358
359 %files plus4
360 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
361 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
362 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
363 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
364
365
366
367 ###############################################################################
368 #                           Supervision subpackage                            #
369 ###############################################################################
370
371 %package supervision
372 Requires: %{name} = %{version}
373 Copyright: Freeware
374 Summary: Supervision specific libraries and headers for the cc65 compiler.
375 Group: Development/Languages
376
377 %description supervision
378 This package contains the header files and libraries needed to write
379 programs for the Supervision Game console using the cc65 crosscompiler.
380
381 %files supervision
382 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
383 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
384
385
386
387 ###############################################################################
388 #                              VIC20 subpackage                               #
389 ###############################################################################
390
391 %package vic20
392 Requires: %{name} = %{version}
393 Copyright: Freeware
394 Summary: VIC20 specific libraries and headers for the cc65 compiler.
395 Group: Development/Languages
396
397 %description vic20
398 This package contains the header files and libraries needed to write
399 programs for the Commodore VIC20 using the cc65 crosscompiler.
400
401 %files vic20
402 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
403 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
404 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
405
406
407
408 ###############################################################################
409 #                                    Build                                    #
410 ###############################################################################
411
412
413
414 %prep
415 %setup -q
416
417
418 %build
419 # Binaries
420 make -C src -f make/gcc.mak
421 # Libraries
422 make -C libsrc -s zap all
423 # Documentation
424 make -C doc html
425
426
427 %install
428 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,ser,tgi}}
429
430 # Binaries
431 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
432 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
433 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
434 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
435 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
436 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
437 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
438 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
439 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
440 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
441 # Libraries and includes
442 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
443 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
444 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
445 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
446 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
447 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
448 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
449 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
450
451 # Drivers
452 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
453 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
454 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
455 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
456
457
458 %clean
459 rm -rf $RPM_BUILD_ROOT
460
461
462
463 %changelog
464 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
465 - Changelog is now in CVS