]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
ecda795962e2a75eee52e1c29abd78babb4ff685
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.13.0
15 Version: %{version}
16 Release: 1
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
23 %ifos linux
24 BuildRequires: perl
25 BuildRequires: sgml-tools
26 %endif
27 BuildRoot: /var/tmp/%{name}-%{version}
28
29 %description
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the target platform
34 packages in addition to the main package.
35
36 %files
37 %defattr(644,root,root,755)
38 %doc announce.txt
39 %doc doc/BUGS
40 %doc doc/CREDITS
41 %doc doc/readme.1st
42 %attr(755,root,root)            /usr/bin/ar65
43 %attr(755,root,root)            /usr/bin/ca65
44 %attr(755,root,root)            /usr/bin/ca65html
45 %attr(755,root,root)            /usr/bin/cc65
46 %attr(755,root,root)            /usr/bin/cl65
47 %attr(755,root,root)            /usr/bin/co65
48 %attr(755,root,root)            /usr/bin/da65
49 %attr(755,root,root)            /usr/bin/ld65
50 %attr(755,root,root)            /usr/bin/od65
51 %attr(755,root,root) %dir       /usr/lib/cc65
52 %attr(755,root,root) %dir       /usr/lib/cc65/cfg
53 %attr(755,root,root) %dir       /usr/lib/cc65/emd
54 %attr(755,root,root) %dir       /usr/lib/cc65/joy
55 %attr(755,root,root) %dir       /usr/lib/cc65/lib
56 %attr(755,root,root) %dir       /usr/lib/cc65/obj
57 %attr(755,root,root) %dir       /usr/lib/cc65/ser
58 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir       /usr/lib/cc65/include
60 %attr(644,root,root)            /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
62 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
64 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
66 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
67 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
68 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
69 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
70 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
71 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
72 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
73
74
75
76 ###############################################################################
77 #                          Documentation subpackage                           #
78 ###############################################################################
79
80 %package doc
81
82 Requires: %{name} = %{version}
83 License: Freeware
84 Summary: Documentation for the cc65 C compiler
85 Group: Development/Languages
86
87 %description doc
88 This package contains the documentation for the cc65 C compiler, mostly
89 in HTML format. Other formats can be generated from the sources.
90
91 %files doc
92 %doc doc/*.html
93 %doc doc/compile.txt
94 %doc doc/internal.txt
95 %doc doc/newvers.txt
96 %doc samples
97
98
99
100 ###############################################################################
101 #                             Apple ][ subpackage                             #
102 ###############################################################################
103
104 %package apple2
105 Requires: %{name} = %{version}
106 License: Freeware
107 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
109
110 %description apple2
111 This package contains the header files and libraries needed to write
112 programs for the Apple ][ using the cc65 crosscompiler.
113
114 %files apple2
115 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
116 %attr(644,root,root)            /usr/lib/cc65/obj/apple2-*.o
117 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
118 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
119 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
120 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
121 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
122 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2-*.cfg
123
124
125
126 ###############################################################################
127 #                            Apple //e subpackage                             #
128 ###############################################################################
129
130 %package apple2enh
131 Requires: %{name} = %{version}
132 License: Freeware
133 Summary: Apple //e specific libraries and headers for the cc65 compiler.
134 Group: Development/Languages
135
136 %description apple2enh
137 This package contains the header files and libraries needed to write
138 programs for the Apple //e using the cc65 crosscompiler.
139
140 %files apple2enh
141 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
142 %attr(644,root,root)            /usr/lib/cc65/obj/apple2enh-*.o
143 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
144 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
145 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
146 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
147 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
148
149
150
151 ###############################################################################
152 #                              Atari subpackage                               #
153 ###############################################################################
154
155 %package atari
156 Requires: %{name} = %{version}
157 License: Freeware
158 Summary: Atari specific libraries and headers for the cc65 compiler.
159 Group: Development/Languages
160
161 %description atari
162 This package contains the header files and libraries needed to write
163 programs for the 8 bit Atari machines using the cc65 crosscompiler.
164
165 %files atari
166 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
167 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
168
169
170
171 ###############################################################################
172 #                            Oric Atmos subpackage                            #
173 ###############################################################################
174
175 %package atmos
176 Requires: %{name} = %{version}
177 License: Freeware
178 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
179 Group: Development/Languages
180
181 %description atmos
182 This package contains the header files and libraries needed to write
183 programs for the Oric Atmos using the cc65 crosscompiler.
184
185 %files atmos
186 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
187 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
188
189
190
191 ###############################################################################
192 #                               C128 subpackage                               #
193 ###############################################################################
194
195 %package c128
196 Requires: %{name} = %{version}
197 License: Freeware
198 Summary: C128 specific libraries and headers for the cc65 compiler.
199 Group: Development/Languages
200
201 %description c128
202 This package contains the header files and libraries needed to write
203 programs for the Commodore C128 using the cc65 crosscompiler.
204
205 %files c128
206 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
207 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
208 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
209 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
210 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
211 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
212
213
214
215 ###############################################################################
216 #                                C16 subpackage                               #
217 ###############################################################################
218
219 %package c16
220 Requires: %{name} = %{version}
221 License: Freeware
222 Summary: C16/116 specific libraries and headers for the cc65 compiler.
223 Group: Development/Languages
224
225 %description c16
226 This package contains the header files and libraries needed to write
227 programs for the Commodore C16/116 using the cc65 crosscompiler.
228
229 %files c16
230 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
231 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
232 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
233
234
235
236 ###############################################################################
237 #                               C64 subpackage                                #
238 ###############################################################################
239
240 %package c64
241 Requires: %{name} = %{version}
242 License: Freeware
243 Summary: C64 specific libraries and headers for the cc65 compiler.
244 Group: Development/Languages
245
246 %description c64
247 This package contains the header files and libraries needed to write
248 programs for the Commodore C64 using the cc65 crosscompiler.
249
250 %files c64
251 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
252 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
253 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
254 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
255 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
256 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
257 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
258
259
260
261 ###############################################################################
262 #                              CBM510 subpackage                              #
263 ###############################################################################
264
265 %package cbm510
266 Requires: %{name} = %{version}
267 License: Freeware
268 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
269 Group: Development/Languages
270
271 %description cbm510
272 This package contains the header files and libraries needed to write
273 programs for the Commodore CBM 510 (aka P500) using the cc65
274 crosscompiler.
275
276 %files cbm510
277 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
278 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
279 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
280 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
281
282
283
284 ###############################################################################
285 #                              CBM610 subpackage                              #
286 ###############################################################################
287
288 %package cbm610
289 Requires: %{name} = %{version}
290 License: Freeware
291 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
292 Group: Development/Languages
293
294 %description cbm610
295 This package contains the header files and libraries needed to write
296 programs for the Commodore PET-II (CBM600/700) family of computers using
297 the cc65 crosscompiler.
298
299 %files cbm610
300 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
301 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
302 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
303
304
305
306 ###############################################################################
307 #                               GEOS subpackage                               #
308 ###############################################################################
309
310 %package geos
311 Requires: %{name} = %{version}
312 License: Freeware
313 Summary: GEOS specific libraries and headers for the cc65 compiler.
314 Group: Development/Languages
315
316 %description geos
317 This package contains the header files and libraries needed to write
318 GEOS programs for the C64/C128 using the cc65 crosscompiler.
319
320 %files geos
321 %attr(755,root,root)            /usr/bin/grc
322 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
323 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
324 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
325 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
326 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
327 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
328
329
330
331 ###############################################################################
332 #                               Lynx subpackage                               #
333 ###############################################################################
334
335 %package lynx
336 Requires: %{name} = %{version}
337 License: Freeware
338 Summary: Lynx specific libraries and headers for the cc65 compiler.
339 Group: Development/Languages
340
341 %description lynx
342 This package contains the header files and libraries needed to write
343 programs for the Lynx Game Console using the cc65 crosscompiler.
344
345 %files lynx
346 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
347 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
348 %attr(644,root,root)            /usr/lib/cc65/ser/lynx-*.ser
349 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
350
351
352
353 ###############################################################################
354 #                               NES subpackage                                #
355 ###############################################################################
356
357 %package nes
358 Requires: %{name} = %{version}
359 License: Freeware
360 Summary: NES specific libraries and headers for the cc65 compiler.
361 Group: Development/Languages
362
363 %description nes
364 This package contains the header files and libraries needed to write
365 programs for the Nintendo Entertainment System using the cc65
366 crosscompiler.
367
368 %files nes
369 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
370 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
371
372
373
374 ###############################################################################
375 #                               PET subpackage                                #
376 ###############################################################################
377
378 %package pet
379 Requires: %{name} = %{version}
380 License: Freeware
381 Summary: PET specific libraries and headers for the cc65 compiler.
382 Group: Development/Languages
383
384 %description pet
385 This package contains the header files and libraries needed to write
386 programs for the Commodore PET family of computers using the cc65
387 crosscompiler.
388
389 %files pet
390 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
391 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
392
393
394
395 ###############################################################################
396 #                              Plus/4 subpackage                              #
397 ###############################################################################
398
399 %package plus4
400 Requires: %{name} = %{version}
401 License: Freeware
402 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
403 Group: Development/Languages
404
405 %description plus4
406 This package contains the header files and libraries needed to write
407 programs for the Commodore Plus/4 and C16/116 using the cc65
408 crosscompiler.
409
410 %files plus4
411 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
412 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
413 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
414
415
416
417 ###############################################################################
418 #                           Supervision subpackage                            #
419 ###############################################################################
420
421 %package supervision
422 Requires: %{name} = %{version}
423 License: Freeware
424 Summary: Supervision specific libraries and headers for the cc65 compiler.
425 Group: Development/Languages
426
427 %description supervision
428 This package contains the header files and libraries needed to write
429 programs for the Supervision Game console using the cc65 crosscompiler.
430
431 %files supervision
432 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
433 %attr(644,root,root)            /usr/lib/cc65/cfg/supervision-*.cfg
434
435
436
437 ###############################################################################
438 #                              VIC20 subpackage                               #
439 ###############################################################################
440
441 %package vic20
442 Requires: %{name} = %{version}
443 License: Freeware
444 Summary: VIC20 specific libraries and headers for the cc65 compiler.
445 Group: Development/Languages
446
447 %description vic20
448 This package contains the header files and libraries needed to write
449 programs for the Commodore VIC20 using the cc65 crosscompiler.
450
451 %files vic20
452 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
453 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
454 %attr(644,root,root)            /usr/lib/cc65/cfg/vic20-*.cfg
455
456
457
458 ###############################################################################
459 #                                    Build                                    #
460 ###############################################################################
461
462
463
464 %prep
465 %setup -q
466
467
468 %build
469 # Binaries
470 make -C src -f make/gcc.mak
471 # Libraries
472 make -C libsrc -s zap all
473 # Documentation
474 make -C doc html
475
476
477 %install
478 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,obj,ser,tgi}}
479
480 # Binaries
481 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
482 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
483 install    -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
491
492 # Libraries and includes
493 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
494 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
495 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
496 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
497 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
498 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
499 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
500 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
501 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
502
503 # Extra object files
504 for extra in libsrc/*-*.o; do
505     install -m 644 ${extra} $RPM_BUILD_ROOT/usr/lib/cc65/obj
506 done
507
508 # Additional linker configurations
509 for config in src/ld65/cfg/*-*.cfg; do
510     install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
511 done
512
513 # Drivers
514 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
515 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
516 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
517 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
518 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
519
520
521 %clean
522 rm -rf $RPM_BUILD_ROOT
523
524
525
526 %changelog
527 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
528 - Changelog is now in CVS