]> git.sur5r.net Git - i3/i3/blobdiff - debian/changelog
Merge branch 'master' into next
[i3/i3] / debian / changelog
index 4eff0f88cbb62ffdf226a6f923ecdf5648891072..e670cd8fdb41f381265ebb0d6b6b135ce345894a 100644 (file)
@@ -1,3 +1,162 @@
+i3-wm (4.1-0) unstable; urgency=low
+
+  * NOT YET RELEASED!
+  * Implement system tray support in i3bar (for NetworkManager, Skype, …)
+  * Implement support for PCRE regular expressions in criteria
+  * Implement a new assign syntax which uses criteria
+  * Sort named workspaces whose name starts with a number accordingly
+  * Warn on duplicate bindings for the same key
+  * Restrict 'resize' command to left/right for horizontal containers, up/down
+    for vertical containers
+  * Implement the GET_MARKS IPC request to get all marks
+  * Implement the new_float config option (border style for floating windows)
+  * Implement passing IPC sockets to i3 (systemd-style socket activation)
+  * Implement the 'move output' command to move containers to a specific output
+  * Bugfix: Preserve marks when restarting
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Sun, 28 Aug 2011 20:17:31 +0200
+
+i3-wm (4.0.2-1) unstable; urgency=low
+
+  * i3-config-wizard: handle mouse button clicks on <win> and <alt> texts
+  * i3-config-wizard: check the modifier mapping to decide whether to use Mod1
+    or Mod4
+  * migrate-config: use \s, be a bit more whitespace tolerant
+  * userguide: s/mod+h/mod+s for stacking
+  * userguide: provide the default colors in the colors example
+  * userguide: document force_focus_wrapping directive
+  * userguide: properly document the resize command
+  * userguide: properly document command chaining and criteria
+  * Bugfix: Correctly bind on multiple keycodes if a symbol has more than one
+  * Bugfix: Allow multiple criteria in 'for_window'
+  * Bugfix: Ensure a minimum size when using the 'resize' command
+  * Bugfix: Start on the first named workspace, not always on '1'
+  * Bugfix: Fix resize command with direction != up for floating windows
+  * Bugfix: Correctly set the _NET_CLIENT_LIST_STACKING hint (chromium tabbar)
+  * Bugfix: 'workspace <next|prev>' now takes all outputs into account
+  * Bugfix: i3-wsbar: make workspace names clickable again
+  * Bugfix: i3-wsbar: correctly handle EOF on stdin
+  * Bugfix: i3-wsbar: display a separator between workspaces of each output
+  * Bugfix: Correctly handle the 'instance' criterion (WM_CLASS)
+  * Bugfix: Use correct format string in load_layout (fixes crash in restart)
+  * Bugfix: Fix border rendering (border lines were "cutting" through)
+  * Bugfix: Raise floating windows immediately when dragging/resizing
+  * Bugfix: Make focus switching work accross outputs again
+  * Bugfix: migration-script: handle resize top/bottom correctly
+  * Bugfix: Fix focus issue when moving containers to workspaces
+  * Bugfix: Warp cursor when changing outputs again
+  * Bugfix: i3bar: fix switching to workspaces with extremely long names
+  * Bugfix: i3bar: fix switching to workspaces "next" and "prev"
+  * Bugfix: i3bar: Correctly allocate pixmap for statuslines which are longer
+    than the screen
+  * Bugfix: i3bar: set statusline = NULL on EOF / SIGCHLD
+  * Bugfix: Correctly initialize the verbose flag
+  * Bugfix: Don’t start with workspace 'next' when the command 'workspace next'
+    is bound in the config file
+  * Bugfix: Set focus to where the mouse pointer is when starting
+  * Bugfix: Don’t change focus when assigned windows start on invisible
+    workspaces
+  * Bugfix: Don’t use absolute paths for exec in the config file
+  * Bugfix: Fix crash when using 'focus mode_toggle' on an empty workspace
+  * Bugfix: Make the 'resize' command work inside tabbed/stacked cons
+  * Bugfix: Correctly place floating windows on their appropriate output
+  * Bugfix: Fix coordinates when moving a floating window to a different output
+  * Bugfix: Correctly keep focus when moving non-leaf windows
+  * Bugfix: Accept '\t' in the set command
+  * Bugfix: Only consider tiling windows when attaching tiling windows to a
+    workspace
+  * Bugfix: Correctly render containers when a split container is focused
+  * Bugfix: Correctly recognize duplicate workspace assignments
+  * Bugfix: Re-enable X11 Eventmask *after* pushing all the X11 changes
+  * Bugfix: Fix focus stealing with assignments of floating windows
+  * Bugfix: Re-implement reconfiguring height of dock windows
+  * Bugfix: IPC: return name_json if available
+  * Bugfix: Make 'floating enable' check for dock windows
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Sun, 28 Aug 2011 19:07:43 +0200
+
+i3-wm (4.0.1-1) unstable; urgency=low
+
+  * Fix the build process of i3bar (Closes: #636274)
+  * Fix the build process on Mac OS X
+  * i3-config-wizard: also start i3bar in the keycode config template
+  * userguide: Remove the obsolete bar.* colors
+  * userguide: Use i3bar instead of dzen2 in the 'exec' example
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Mon, 01 Aug 2011 23:31:06 +0200
+
+i3-wm (4.0-1) unstable; urgency=low
+
+  * In addition to the proper flex/bison based parser for the config file
+    introduced in 3.δ, we now also have a flex/bison parser for commands. What
+    this means is that we can have more human-readable, beautiful command names
+    instead of cryptic commands like 'f' for fullscreen or 'mh' for move left.
+    In fact, the commands for the aforementioned functions *are* 'fullscreen'
+    and 'move left'!
+  * You can now chain commands using ';' (a semicolon). One example for that is
+    'workspace 3 ; exec /usr/bin/urxvt' to switch to a new workspace and open a
+    terminal.
+  * You can specify which windows should be affected by your command by using
+    different criteria. A good example is '[class="Firefox"] kill' to get rid
+    of all Firefox windows.
+  * As the configuration file needs new commands (and a few options are
+    obsolete), you need to change it. To make this process a little bit easier
+    for you, this release comes with the script i3-migrate-config-to-v4. Just
+    run it on your current config file and it will spit out a v4 config file to
+    stdout. To make things even better, i3 automatically detects v3 config files
+    and calls that script, so you never end up with a non-working config :).
+  * Similarly to the criteria when using commands, we now have a 'for_window'
+    configuration directive, which lets you automatically apply certain commands
+    to certain windows. Use it to set border styles per window, for example with
+    'for_window [class="XTerm"] border 1pixel'.
+  * Since dock clients (like dzen2) are now part of the layout tree (as opposed
+    to a custom data structure as before), it was easy to implement top and
+    bottom dock areas. Programs which properly specify the dock hint get placed
+    on the edge of the screen they request. i3bar has the -dtop and -dbottom
+    parameters, for example.
+  * The internal workspace bar is obsolete. Use i3bar instead.
+  * Resizing now works between all windows!
+  * Fullscreen now works for everything!
+  * Floating now works for everything!
+  * Your layout is now preserved when doing an inplace restart.
+  * When you have an error in your config file, a new program called i3-nagbar
+    will tell you so. It offers you two buttons: One to view the error in your
+    $PAGER and one to edit your config in your $EDITOR.
+  * The default config used key symbols (like 'bind Mod1+f fullscreen') instead
+    of key codes. If you use a non-qwerty layout, the program i3-config-wizard
+    can create a key symbol based config file based on your current layout. You
+    can also chose between Windows (Mod4) and Alt (Mod1) as your default
+    modifier. i3-config-wizard will automatically be started as long as you
+    don’t have a configuration file for i3.
+  * Custom X cursor themes are now supported.
+  * The RandR backend now respects the primary output.
+  * A wrong 'font' configuration in your config file will no longer make i3
+    exit. Instead, it will fall back to a different font and tell you about the
+    error in its log.
+  * The default split direction (whether a new window gets placed right next to
+    the current one or below the current one) is now automatically set to
+    horizontal if you have a monitor that is wider than high or vertical if you
+    a monitor which is higher than wide. This works great with rotated monitors.
+  * Sockets and temporary files are now placed in XDG_RUNTIME_DIR, if set (this
+    is used on systemd based systems).
+  * Tools like i3bar, i3-msg etc. use the I3_SOCKET_PATH property which is set
+    to the X11 root window, so you don’t have to configure your socket path
+    anywhere.
+  * The kill command kills single windows by default now. To kill a whole
+    application, use 'kill client'.
+  * IPC: Commands can now have custom replies. When the parser encounters an
+    error, a proper error reply is sent.
+  * There is now an 'exec_always' configuration directive which works like
+    'exec' but will also be run when restarting.
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Sun, 31 Jul 2011 22:34:26 +0200
+
+i3-wm (3.e-bf1-3) unstable; urgency=low
+
+  * include keyboard-layer{1,2}.png in docs (Closes: #595295)
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Wed, 03 Nov 2010 20:32:42 +0100
+
 i3-wm (3.e-bf1-2) unstable; urgency=low
 
   * debian: call dh_installwm to register as alternative for x-window-manager