]> git.sur5r.net Git - i3/i3/blobdiff - debian/changelog
Merge branch 'master' into next
[i3/i3] / debian / changelog
index 81cc2ccc1434e04c54b3b92b47e337303083fe41..e670cd8fdb41f381265ebb0d6b6b135ce345894a 100644 (file)
@@ -1,6 +1,32 @@
-i3-wm (4.0.2-0) unstable; urgency=low
+i3-wm (4.1-0) unstable; urgency=low
 
   * NOT YET RELEASED!
+  * Implement system tray support in i3bar (for NetworkManager, Skype, …)
+  * Implement support for PCRE regular expressions in criteria
+  * Implement a new assign syntax which uses criteria
+  * Sort named workspaces whose name starts with a number accordingly
+  * Warn on duplicate bindings for the same key
+  * Restrict 'resize' command to left/right for horizontal containers, up/down
+    for vertical containers
+  * Implement the GET_MARKS IPC request to get all marks
+  * Implement the new_float config option (border style for floating windows)
+  * Implement passing IPC sockets to i3 (systemd-style socket activation)
+  * Implement the 'move output' command to move containers to a specific output
+  * Bugfix: Preserve marks when restarting
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Sun, 28 Aug 2011 20:17:31 +0200
+
+i3-wm (4.0.2-1) unstable; urgency=low
+
+  * i3-config-wizard: handle mouse button clicks on <win> and <alt> texts
+  * i3-config-wizard: check the modifier mapping to decide whether to use Mod1
+    or Mod4
+  * migrate-config: use \s, be a bit more whitespace tolerant
+  * userguide: s/mod+h/mod+s for stacking
+  * userguide: provide the default colors in the colors example
+  * userguide: document force_focus_wrapping directive
+  * userguide: properly document the resize command
+  * userguide: properly document command chaining and criteria
   * Bugfix: Correctly bind on multiple keycodes if a symbol has more than one
   * Bugfix: Allow multiple criteria in 'for_window'
   * Bugfix: Ensure a minimum size when using the 'resize' command
@@ -21,6 +47,9 @@ i3-wm (4.0.2-0) unstable; urgency=low
   * Bugfix: Warp cursor when changing outputs again
   * Bugfix: i3bar: fix switching to workspaces with extremely long names
   * Bugfix: i3bar: fix switching to workspaces "next" and "prev"
+  * Bugfix: i3bar: Correctly allocate pixmap for statuslines which are longer
+    than the screen
+  * Bugfix: i3bar: set statusline = NULL on EOF / SIGCHLD
   * Bugfix: Correctly initialize the verbose flag
   * Bugfix: Don’t start with workspace 'next' when the command 'workspace next'
     is bound in the config file
@@ -31,8 +60,20 @@ i3-wm (4.0.2-0) unstable; urgency=low
   * Bugfix: Fix crash when using 'focus mode_toggle' on an empty workspace
   * Bugfix: Make the 'resize' command work inside tabbed/stacked cons
   * Bugfix: Correctly place floating windows on their appropriate output
-
- -- Michael Stapelberg <michael@stapelberg.de>  Sun, 07 Aug 2011 18:13:29 +0200
+  * Bugfix: Fix coordinates when moving a floating window to a different output
+  * Bugfix: Correctly keep focus when moving non-leaf windows
+  * Bugfix: Accept '\t' in the set command
+  * Bugfix: Only consider tiling windows when attaching tiling windows to a
+    workspace
+  * Bugfix: Correctly render containers when a split container is focused
+  * Bugfix: Correctly recognize duplicate workspace assignments
+  * Bugfix: Re-enable X11 Eventmask *after* pushing all the X11 changes
+  * Bugfix: Fix focus stealing with assignments of floating windows
+  * Bugfix: Re-implement reconfiguring height of dock windows
+  * Bugfix: IPC: return name_json if available
+  * Bugfix: Make 'floating enable' check for dock windows
+
+ -- Michael Stapelberg <michael@stapelberg.de>  Sun, 28 Aug 2011 19:07:43 +0200
 
 i3-wm (4.0.1-1) unstable; urgency=low