]> git.sur5r.net Git - i3/i3status/blobdiff - debian/rules
remove debian/, packaging now lives on alioth
[i3/i3status] / debian / rules
diff --git a/debian/rules b/debian/rules
deleted file mode 100755 (executable)
index 2fa8f37..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-arch build-indep
-
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp:
-       dh_testdir
-       $(MAKE)
-       touch $@
-
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp config.status man/*.xml
-       [ ! -f Makefile ] || $(MAKE) distclean
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3status/ install
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install