]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'master' into next
[i3/i3] / debian / rules
index d639398050b026a5301d6e5a63533615abb0264c..19105773ec1f1774d2d34a1bc8a32d965be491ba 100755 (executable)
@@ -1,76 +1,47 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
 
-config.status: configure
-       dh_testdir
-       touch $@
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
+endif
 
-build:
-       dh_testdir
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+build-stamp:
+       dh build
+       touch build-stamp
 
-       # Add here commands to compile the package.
-       $(MAKE)
-       $(MAKE) -C man
-       $(MAKE) -C docs
+clean:
+       dh clean
 
-       touch $@
+install: build install-stamp
+install-stamp:
+       dh install
+       touch install-stamp
 
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build
+binary-arch: install
+       dh binary-arch
 
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) distclean
+binary-indep: install
+       dh binary-indep
 
-       dh_clean 
+binary: binary-arch binary-indep
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/i3-wm
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
-       mkdir -p $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-msg.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-input.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+override_dh_auto_build:
+       $(MAKE)
+       $(MAKE) -C man
+       $(MAKE) -C docs
 
+override_dh_installchangelogs:
+       dh_installchangelogs RELEASE-NOTES-4.5
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+override_dh_install:
+       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
 
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-       dh_installdebconf       
-       dh_installinit
-       dh_installman
-       dh_installwm
-       dh_link
+override_dh_strip:
        dh_strip --dbg-package=i3-wm-dbg
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install