]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge pull request #1512 from mdtipton/unclutter_scroll
[i3/i3] / debian / rules
index e62dd5eec074e09b51bfc3de626a378c4e590489..7036b90d3000bd1edbc0e449dfdb11775f1ac904 100755 (executable)
@@ -1,85 +1,47 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
 
-config.status: configure
-       dh_testdir
-       touch $@
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
+endif
 
 build: build-arch build-indep
-
 build-arch: build-stamp
 build-indep: build-stamp
-
 build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE) TERM_EMU=x-terminal-emulator
-       $(MAKE) -C man
-       $(MAKE) -C docs
+       dh build
+       touch build-stamp
 
-       touch $@
+clean:
+       dh clean
 
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
+install: build install-stamp
+install-stamp:
+       dh install
+       touch install-stamp
 
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) distclean
+binary-arch: install
+       dh binary-arch
 
-       dh_clean 
+binary-indep: install
+       dh binary-indep
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
+binary: binary-arch binary-indep
 
-       # Add here commands to install the package into debian/i3-wm
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
-       mkdir -p $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-msg.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-input.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-nagbar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-config-wizard.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp man/i3-migrate-config-to-v4.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
-       cp i3bar/doc/i3bar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+override_dh_auto_build:
+       $(MAKE)
+       $(MAKE) -C man
+       $(MAKE) -C docs
 
+override_dh_installchangelogs:
+       dh_installchangelogs RELEASE-NOTES-*
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
+override_dh_install:
+       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
 
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-       dh_installdebconf       
-       dh_installinit
-       dh_installman
-       dh_installwm
-       dh_link
+override_dh_strip:
        dh_strip --dbg-package=i3-wm-dbg
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install