]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'pcre' into next
[i3/i3] / debian / rules
index 874c57ec60beabcfb2a625e08a2eb992ef58a286..e62dd5eec074e09b51bfc3de626a378c4e590489 100755 (executable)
@@ -13,19 +13,25 @@ config.status: configure
        dh_testdir
        touch $@
 
-build:
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       $(MAKE) TERM_EMU=x-terminal-emulator
        $(MAKE) -C man
+       $(MAKE) -C docs
 
        touch $@
 
 clean: 
        dh_testdir
        dh_testroot
-       rm -f build
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
        [ ! -f Makefile ] || $(MAKE) distclean
@@ -38,10 +44,16 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/wiipdf
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3/ install
-       mkdir -p $(CURDIR)/debian/i3/usr/share/man/man1
-       cp man/i3.1 $(CURDIR)/debian/i3/usr/share/man/man1
+       # Add here commands to install the package into debian/i3-wm
+       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
+       mkdir -p $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-msg.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-input.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-nagbar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-config-wizard.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-migrate-config-to-v4.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp i3bar/doc/i3bar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
 
 
 # Build architecture-independent files here.
@@ -55,24 +67,14 @@ binary-arch: build install
        dh_installchangelogs 
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
        dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
        dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
+       dh_installwm
        dh_link
-#      dh_strip
+       dh_strip --dbg-package=i3-wm-dbg
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol