]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'pcre' into next
[i3/i3] / debian / rules
index d639398050b026a5301d6e5a63533615abb0264c..e62dd5eec074e09b51bfc3de626a378c4e590489 100755 (executable)
@@ -13,11 +13,16 @@ config.status: configure
        dh_testdir
        touch $@
 
-build:
+build: build-arch build-indep
+
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp:
        dh_testdir
 
        # Add here commands to compile the package.
-       $(MAKE)
+       $(MAKE) TERM_EMU=x-terminal-emulator
        $(MAKE) -C man
        $(MAKE) -C docs
 
@@ -26,7 +31,7 @@ build:
 clean: 
        dh_testdir
        dh_testroot
-       rm -f build
+       rm -f build-stamp
 
        # Add here commands to clean up after the build process.
        [ ! -f Makefile ] || $(MAKE) distclean
@@ -45,6 +50,10 @@ install: build
        cp man/i3.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
        cp man/i3-msg.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
        cp man/i3-input.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-nagbar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-config-wizard.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp man/i3-migrate-config-to-v4.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
+       cp i3bar/doc/i3bar.1 $(CURDIR)/debian/i3-wm/usr/share/man/man1
 
 
 # Build architecture-independent files here.