]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
Implement new 'sticky' command to manually set, remove or toggle the sticky state...
[i3/i3] / parser-specs / commands.spec
index f5fb9884b2513706d4bdd2206976c3989ef19ffd..5e2bfd8f0b0296373c6be9bba040e1f3a469669a 100644 (file)
@@ -29,6 +29,7 @@ state INITIAL:
   'kill' -> KILL
   'open' -> call cmd_open()
   'fullscreen' -> FULLSCREEN
+  'sticky' -> STICKY
   'split' -> SPLIT
   'floating' -> FLOATING
   'mark' -> MARK
@@ -183,6 +184,11 @@ state FULLSCREEN_COMPAT:
   end
       -> call cmd_fullscreen("toggle", "output")
 
+# sticky enable|disable|toggle
+state STICKY:
+  action = 'enable', 'disable', 'toggle'
+      -> call cmd_sticky($action)
+
 # split v|h|vertical|horizontal
 state SPLIT:
   direction = 'horizontal', 'vertical', 'v', 'h'