]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
Bugfix: Correctly parse `move ... workspace *_on_output`
[i3/i3] / parser-specs / commands.spec
index c9b881b3e13d88a9a963cf12536f0f3c97e8b10a..740c83acef13a50e0d32a0b9f55f4934cd6c7acb 100644 (file)
@@ -223,7 +223,7 @@ state RENAME_WORKSPACE_NEW_NAME:
       -> call cmd_rename_workspace($old_name, $new_name)
 
 # move <direction> [<pixels> [px]]
-# move [window|container] [to] workspace [<str>|next|prev|current]
+# move [window|container] [to] workspace [<str>|next|prev|next_on_output|prev_on_output|current]
 # move [window|container] [to] output <str>
 # move [window|container] [to] scratchpad
 # move workspace to [output] <str>
@@ -264,7 +264,7 @@ state MOVE_DIRECTION_PX:
 state MOVE_WORKSPACE:
   'to'
       -> MOVE_WORKSPACE_TO_OUTPUT
-  workspace = 'next', 'prev', 'next_on_output', 'prev_on_output', 'current'
+  workspace = 'next_on_output', 'prev_on_output', 'next', 'prev', 'current'
       -> call cmd_move_con_to_workspace($workspace)
   'back_and_forth'
       -> call cmd_move_con_to_workspace_back_and_forth()