]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
Merge branch 'master' into next
[i3/i3] / parser-specs / commands.spec
index 9ea1c55e593a7dd4422ffe9a4977c285804689b5..b4c9e005bd8ab16583bae3ef2dc8aeab8984f1f9 100644 (file)
@@ -31,6 +31,7 @@ state INITIAL:
   'floating' -> FLOATING
   'mark' -> MARK
   'resize' -> RESIZE
+  'rename' -> RENAME
   'nop' -> NOP
   'scratchpad' -> SCRATCHPAD
   'mode' -> MODE
@@ -65,10 +66,20 @@ state BORDER:
   border_style = 'normal', 'none', '1pixel', 'toggle'
       -> call cmd_border($border_style)
 
-# layout default|stacked|stacking|tabbed
+# layout default|stacked|stacking|tabbed|splitv|splith
+# layout toggle [split|all]
 state LAYOUT:
-  layout_mode = 'default', 'stacked', 'stacking', 'tabbed'
+  layout_mode = 'default', 'stacked', 'stacking', 'tabbed', 'splitv', 'splith'
       -> call cmd_layout($layout_mode)
+  'toggle'
+      -> LAYOUT_TOGGLE
+
+# layout toggle [split|all]
+state LAYOUT_TOGGLE:
+  end
+      -> call cmd_layout_toggle($toggle_mode)
+  toggle_mode = 'split', 'all'
+      -> call cmd_layout_toggle($toggle_mode)
 
 # append_layout <path>
 state APPEND_LAYOUT:
@@ -129,7 +140,7 @@ state FULLSCREEN:
 
 # split v|h|vertical|horizontal
 state SPLIT:
-  direction = 'v', 'h', 'vertical', 'horizontal'
+  direction = 'horizontal', 'vertical', 'v', 'h'
       -> call cmd_split($direction)
 
 # floating enable|disable|toggle
@@ -173,8 +184,23 @@ state RESIZE_TILING_OR:
   end
       -> call cmd_resize($way, $direction, $resize_px, $resize_ppt)
 
+# rename workspace <name> to <name>
+state RENAME:
+  'workspace'
+      -> RENAME_WORKSPACE
+
+state RENAME_WORKSPACE:
+  old_name = word
+      -> RENAME_WORKSPACE_TO
+
+state RENAME_WORKSPACE_TO:
+  'to'
+      ->
+  new_name = string
+      -> call cmd_rename_workspace($old_name, $new_name)
+
 # move <direction> [<pixels> [px]]
-# move [window|container] [to] workspace <str>
+# move [window|container] [to] workspace [<str>|next|prev|current]
 # move [window|container] [to] output <str>
 # move [window|container] [to] scratchpad
 # move workspace to [output] <str>
@@ -215,11 +241,17 @@ state MOVE_DIRECTION_PX:
 state MOVE_WORKSPACE:
   'to'
       -> MOVE_WORKSPACE_TO_OUTPUT
-  workspace = 'next', 'prev', 'next_on_output', 'prev_on_output'
+  workspace = 'next', 'prev', 'next_on_output', 'prev_on_output', 'current'
       -> call cmd_move_con_to_workspace($workspace)
+  'number'
+      -> MOVE_WORKSPACE_NUMBER
   workspace = string
       -> call cmd_move_con_to_workspace_name($workspace)
 
+state MOVE_WORKSPACE_NUMBER:
+  number = string
+      -> call cmd_move_con_to_workspace_number($number)
+
 state MOVE_TO_OUTPUT:
   output = string
       -> call cmd_move_con_to_output($output)