]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
i3bar: compile with yajl < 2
[i3/i3] / parser-specs / commands.spec
index 0fba3e313ed809c07932b97e03b168f6c6a583e8..bbd7ab285e80476280b2eaa12d59690d4cb65f15 100644 (file)
@@ -43,6 +43,7 @@ state CRITERIA:
   ctype = 'id' -> CRITERION
   ctype = 'con_mark' -> CRITERION
   ctype = 'title' -> CRITERION
+  ctype = 'urgent' -> CRITERION
   ']' -> call cmd_criteria_match_windows(); INITIAL
 
 state CRITERION:
@@ -59,12 +60,12 @@ state EXEC:
   command = string
       -> call cmd_exec($nosn, $command)
 
-# border <normal|none|1pixel|toggle>
+# border normal|none|1pixel|toggle
 state BORDER:
   border_style = 'normal', 'none', '1pixel', 'toggle'
       -> call cmd_border($border_style)
 
-# layout <default|stacked|stacking|tabbed>
+# layout default|stacked|stacking|tabbed
 state LAYOUT:
   layout_mode = 'default', 'stacked', 'stacking', 'tabbed'
       -> call cmd_layout($layout_mode)
@@ -105,16 +106,14 @@ state FOCUS_OUTPUT:
   output = string
       -> call cmd_focus_output($output)
 
-# kill window|client
-# kill
+# kill [window|client]
 state KILL:
   kill_mode = 'window', 'client'
       -> call cmd_kill($kill_mode)
   end
       -> call cmd_kill($kill_mode)
 
-# fullscreen global
-# fullscreen
+# fullscreen [global]
 state FULLSCREEN:
   fullscreen_mode = 'global'
       -> call cmd_fullscreen($fullscreen_mode)