]> git.sur5r.net Git - fstl/blobdiff - debian/rules
Upload 0.9.3-1 to unstable
[fstl] / debian / rules
index b78d01a9130dfc0c8b918e5e6908add46fc561f2..7c4b9f1d750ed3797dbf2a0b207cde6aa0e5b06e 100755 (executable)
@@ -1,32 +1,9 @@
 #!/usr/bin/make -f
-# See debhelper(7) (uncomment to enable)
-# output every command that modifies files on the build system.
-#export DH_VERBOSE = 1
-
 export QT_SELECT=qt5
 
-# see FEATURE AREAS in dpkg-buildflags(1)
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
-# see ENVIRONMENT in dpkg-buildflags(1)
-# package maintainers to append CFLAGS
-#export DEB_CFLAGS_MAINT_APPEND  = -Wall -pedantic
-# package maintainers to append LDFLAGS
 export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
 
-
-#DEB_DH_INSTALL_ARGS := --sourcedir=debian/tmp --list-missing
-
-export DEB_QMAKE_ARGS=qt/fstl.pro
-
-export QT_SELECT=qt5
-include /usr/share/dpkg/buildflags.mk
-include /usr/share/cdbs/1/rules/debhelper.mk
-include /usr/share/cdbs/1/class/qmake.mk
-
-
- #dh_make generated override targets
-# This is example for Cmake (See https://bugs.debian.org/641051 )
-#override_dh_auto_configure:
-#      dh_auto_configure -- #  -DCMAKE_LIBRARY_PATH=$(DEB_HOST_MULTIARCH)
-
+%:
+       dh "$@" --sourcedirectory=qt