]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Bump dh compat to 7, simplify debian/rules.
[i3/i3] / debian / rules
index 4ef9801be93a74a2e1ca06731cbc7eb33f3cf5f0..02a8fca65fc60922342f010826ba2104e64069fb 100755 (executable)
@@ -1,76 +1,37 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-config.status: configure
-       dh_testdir
-       touch $@
-
-build: build-arch build-indep
-
-build-arch: build-stamp
-build-indep: build-stamp
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
 
+build: build-stamp
 build-stamp:
-       dh_testdir
+       dh build
+       touch build-stamp
 
-       # Add here commands to compile the package.
-       $(MAKE) TERM_EMU=x-terminal-emulator
-       $(MAKE) -C man
-       $(MAKE) -C docs
+clean:
+       dh clean
 
-       touch $@
+install: build install-stamp
+install-stamp:
+       dh install
+       touch install-stamp
 
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
+binary-arch: install
+       dh binary-arch
 
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) distclean
+binary-indep: install
+       dh binary-indep
 
-       dh_clean 
+binary: binary-arch binary-indep
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
+override_dh_auto_build:
+       $(MAKE) TERM_EMNU=x-terminal-emulator
+       $(MAKE) -C man
+       $(MAKE) -C docs
 
-       # Add here commands to install the package into debian/i3-wm
+override_dh_install:
        $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
 
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-       dh_installdebconf       
-       dh_installinit
-       dh_installman
-       dh_installwm
-       dh_link
+override_dh_strip:
        dh_strip --dbg-package=i3-wm-dbg
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install