]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'release-4.16.1'
[i3/i3] / debian / rules
index 2186810f9e788b4390165b6a33c7a785620c15f6..d5c306867cd6e8f23a243690f6a63c570aa18db3 100755 (executable)
@@ -1,80 +1,25 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export V:=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
-config.status: configure
-       dh_testdir
-       touch $@
+override_dh_installchangelogs:
+       dh_installchangelogs RELEASE-NOTES-*
 
-build:
-       dh_testdir
+override_dh_strip:
+       dh_strip --dbg-package=i3-wm-dbg
 
-       # Add here commands to compile the package.
-       $(MAKE)
+override_dh_auto_test:
+       # TODO: enable tests
 
-       touch $@
+override_dh_auto_configure:
+       # The default is /usr/share/doc/i3
+       dh_auto_configure -- --docdir=/usr/share/doc/i3-wm
 
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build
+override_dh_builddeb:
+       # bintray does not support xz currently.
+       dh_builddeb -- -Zgzip
 
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) distclean
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/wiipdf
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3/ install
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-       dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install 
+%:
+       dh $@ --parallel --builddirectory=build --with=autoreconf