]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'release-4.16.1'
[i3/i3] / debian / rules
index 7036b90d3000bd1edbc0e449dfdb11775f1ac904..d5c306867cd6e8f23a243690f6a63c570aa18db3 100755 (executable)
@@ -1,47 +1,25 @@
 #!/usr/bin/make -f
 # vi: ts=8 sw=8 noet
 
-DPKG_EXPORT_BUILDFLAGS = 1
--include /usr/share/dpkg/buildflags.mk
-
-ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
-    MAKEFLAGS += -j$(NUMJOBS)
-endif
-
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-build-stamp:
-       dh build
-       touch build-stamp
-
-clean:
-       dh clean
-
-install: build install-stamp
-install-stamp:
-       dh install
-       touch install-stamp
-
-binary-arch: install
-       dh binary-arch
-
-binary-indep: install
-       dh binary-indep
-
-binary: binary-arch binary-indep
-
-override_dh_auto_build:
-       $(MAKE)
-       $(MAKE) -C man
-       $(MAKE) -C docs
+export V:=1
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
 override_dh_installchangelogs:
        dh_installchangelogs RELEASE-NOTES-*
 
-override_dh_install:
-       $(MAKE) DESTDIR=$(CURDIR)/debian/i3-wm/ install
-
 override_dh_strip:
        dh_strip --dbg-package=i3-wm-dbg
+
+override_dh_auto_test:
+       # TODO: enable tests
+
+override_dh_auto_configure:
+       # The default is /usr/share/doc/i3
+       dh_auto_configure -- --docdir=/usr/share/doc/i3-wm
+
+override_dh_builddeb:
+       # bintray does not support xz currently.
+       dh_builddeb -- -Zgzip
+
+%:
+       dh $@ --parallel --builddirectory=build --with=autoreconf