]> git.sur5r.net Git - i3/i3/blobdiff - debian/rules
Merge branch 'release-4.16.1'
[i3/i3] / debian / rules
index 843655eec8a9ca959f51ac860ee42d2080de54a1..d5c306867cd6e8f23a243690f6a63c570aa18db3 100755 (executable)
@@ -4,14 +4,22 @@
 export V:=1
 export DEB_BUILD_MAINT_OPTIONS = hardening=+all
 
-override_dh_auto_build:
-       dh_auto_build -- all docs mans
-
 override_dh_installchangelogs:
        dh_installchangelogs RELEASE-NOTES-*
 
 override_dh_strip:
        dh_strip --dbg-package=i3-wm-dbg
 
+override_dh_auto_test:
+       # TODO: enable tests
+
+override_dh_auto_configure:
+       # The default is /usr/share/doc/i3
+       dh_auto_configure -- --docdir=/usr/share/doc/i3-wm
+
+override_dh_builddeb:
+       # bintray does not support xz currently.
+       dh_builddeb -- -Zgzip
+
 %:
-       dh $@ --parallel
+       dh $@ --parallel --builddirectory=build --with=autoreconf