]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
Added command directive 'title_format'.
[i3/i3] / parser-specs / commands.spec
index c3e6e4892ad9b6244c1bc383c87152cbf117da19..c756dd8b0502052d1b6a283acf8e31febd1d9766 100644 (file)
@@ -37,6 +37,7 @@ state INITIAL:
   'rename' -> RENAME
   'nop' -> NOP
   'scratchpad' -> SCRATCHPAD
+  'title_format' -> TITLE_FORMAT
   'mode' -> MODE
   'bar' -> BAR
 
@@ -374,6 +375,10 @@ state SCRATCHPAD:
   'show'
       -> call cmd_scratchpad_show()
 
+state TITLE_FORMAT:
+  format = string
+      -> call cmd_title_format($format)
+
 # bar (hidden_state hide|show|toggle)|(mode dock|hide|invisible|toggle) [<bar_id>]
 state BAR:
   bar_type = 'hidden_state'