]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/commands.spec
added "toggle" option to "split" command
[i3/i3] / parser-specs / commands.spec
index 68a2667f2cda1bf895fcd1bb36f924cb6dbccfd2..e6480a35dca349271c3def7cc39f67f0be266d2b 100644 (file)
@@ -191,9 +191,9 @@ state STICKY:
   action = 'enable', 'disable', 'toggle'
       -> call cmd_sticky($action)
 
-# split v|h|vertical|horizontal
+# split v|h|t|vertical|horizontal|toggle
 state SPLIT:
-  direction = 'horizontal', 'vertical', 'v', 'h'
+  direction = 'horizontal', 'vertical', 'toggle', 'v', 'h', 't'
       -> call cmd_split($direction)
 
 # floating enable|disable|toggle
@@ -308,6 +308,8 @@ state MOVE:
       ->
   'to'
       ->
+  no_auto_back_and_forth = '--no-auto-back-and-forth'
+      ->
   'workspace'
       -> MOVE_WORKSPACE
   'output'
@@ -345,11 +347,11 @@ state MOVE_WORKSPACE:
   'number'
       -> MOVE_WORKSPACE_NUMBER
   workspace = string
-      -> call cmd_move_con_to_workspace_name($workspace)
+      -> call cmd_move_con_to_workspace_name($workspace, $no_auto_back_and_forth)
 
 state MOVE_WORKSPACE_NUMBER:
   number = string
-      -> call cmd_move_con_to_workspace_number($number)
+      -> call cmd_move_con_to_workspace_number($number, $no_auto_back_and_forth)
 
 state MOVE_TO_OUTPUT:
   output = string