]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/config.spec
Allow assign to workspace by number
[i3/i3] / parser-specs / config.spec
index 4aa320bf63a1b822f8c66a3f1c2e8304058d7118..665b046aeeed0701151bc2feccdd430ca26454fc 100644 (file)
@@ -151,8 +151,14 @@ state ASSIGN_WORKSPACE:
       ->
   'workspace'
       ->
+  'number'
+      -> ASSIGN_WORKSPACE_NUMBER
   workspace = string
-      -> call cfg_assign($workspace)
+      -> call cfg_assign($workspace, 0)
+
+state ASSIGN_WORKSPACE_NUMBER:
+  number = string
+      -> call cfg_assign($number, 1)
 
 # no_focus <criteria>
 state NO_FOCUS: