]> git.sur5r.net Git - i3/i3/blobdiff - parser-specs/config.spec
Merge pull request #2995 from orestisf1993/dump-asy-basename
[i3/i3] / parser-specs / config.spec
index 3a10bbc1c14df330da67ccebe489cfbd9e61d235..c31567a64b87d29dc340cd821621f15c2636fb45 100644 (file)
@@ -142,7 +142,7 @@ state FOR_WINDOW_COMMAND:
   command = string
       -> call cfg_for_window($command)
 
-# assign <criteria> [→] workspace
+# assign <criteria> [→] [workspace | output] <name>
 state ASSIGN:
   '['
       -> call cfg_criteria_init(ASSIGN_WORKSPACE); CRITERIA
@@ -150,6 +150,8 @@ state ASSIGN:
 state ASSIGN_WORKSPACE:
   '→'
       ->
+  'output'
+      -> ASSIGN_OUTPUT
   'workspace'
       ->
   'number'
@@ -157,6 +159,10 @@ state ASSIGN_WORKSPACE:
   workspace = string
       -> call cfg_assign($workspace, 0)
 
+state ASSIGN_OUTPUT:
+  output = string
+      -> call cfg_assign_output($output)
+
 state ASSIGN_WORKSPACE_NUMBER:
   number = string
       -> call cfg_assign($number, 1)
@@ -206,7 +212,7 @@ state MOUSE_WARPING:
 
 # focus_wrapping
 state FOCUS_WRAPPING:
-  value = word
+  value = '1', 'yes', 'true', 'on', 'enable', 'active', '0', 'no', 'false', 'off', 'disable', 'inactive', 'force'
       -> call cfg_focus_wrapping($value)
 
 # force_focus_wrapping