]> git.sur5r.net Git - i3/i3lock/blobdiff - debian/rules
debian: update packaging to use dpkg-buildflags, i3lock.manpages
[i3/i3lock] / debian / rules
index fa91b71736abb4815ff884af1628e9f8b5580f47..272908327c41127783c4127ccf2c97735b566d36 100755 (executable)
@@ -1,79 +1,32 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# vi: ts=8 sw=8 noet
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+DPKG_EXPORT_BUILDFLAGS = 1
+-include /usr/share/dpkg/buildflags.mk
 
-config.status: configure
-       dh_testdir
-       touch $@
+build: build-stamp
+build-stamp:
+       dh build
+       touch build-stamp
 
-build:
-       dh_testdir
+clean:
+       dh clean
 
-       # Add here commands to compile the package.
-       $(MAKE)
-
-       touch $@
+install: build install-stamp
+install-stamp:
+       dh install
+       touch install-stamp
 
-clean: 
-       dh_testdir
-       dh_testroot
-       rm -f build
+binary-arch: install
+       dh binary-arch
 
-       # Add here commands to clean up after the build process.
-       [ ! -f Makefile ] || $(MAKE) clean 
+binary-indep: install
+       dh binary-indep
 
-       dh_clean 
+binary: binary-arch binary-indep
 
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
+override_dh_auto_build:
+       $(MAKE)
 
+override_dh_install:
        $(MAKE) DESTDIR=$(CURDIR)/debian/i3lock/ install
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
-#      dh_install
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-       dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-#      dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install