]> git.sur5r.net Git - i3/i3status/blobdiff - debian/rules
Update debian packaging for 2.0
[i3/i3status] / debian / rules
index 07c0fd8a0d9994c648b34a77fc45b51c489a449e..c9c396c885a5bfa2b32180a5ef5c7c733a052875 100755 (executable)
@@ -13,32 +13,23 @@ build: build-stamp
 
 build-stamp:
        dh_testdir
-
-       # Add here commands to compile the package.
        $(MAKE)
-
        touch $@
 
 clean: 
        dh_testdir
        dh_testroot
-       rm -f build-stamp config.status
-
-       # Add here commands to clean up after the build process.
+       rm -f build-stamp config.status man/*.xml
        [ ! -f Makefile ] || $(MAKE) distclean
-
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean -k
        dh_installdirs
-
-       # Add here commands to install the package into debian/i3status.
        $(MAKE) DESTDIR=$(CURDIR)/debian/i3status/ install
 
-
 # Build architecture-independent files here.
 binary-indep: build install
 # We have nothing to do by default.
@@ -47,27 +38,14 @@ binary-indep: build install
 binary-arch: build install
        dh_testdir
        dh_testroot
-       dh_installchangelogs 
+       dh_installchangelogs
        dh_installdocs
        dh_installexamples
-#      dh_install
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-       dh_installinit
-#      dh_installcron
-#      dh_installinfo
        dh_installman
        dh_link
        dh_strip
        dh_compress
        dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol