5 %define sysconfdir /etc
12 Group: Applications/Productivity
13 Source: ftp://ar.linux.it/pub/barcode/%name-%{ver}.tar.gz
14 BuildRoot: /var/tmp/%name-%{ver}-root
15 URL: http://gnu.systemy.it/software/barcode
20 The package is meant to solve most needs in barcode creation with a
21 conventional printer. It can create printouts for the conventional
22 product tagging standards: UPC-A, UPC-E, EAN-13, EAN-8, ISBN, as well
23 as a few other formats. Ouput is generated as either Postscript or
24 Encapsulated Postscript (other back-ends may be added if needed).
27 Summary: GNU barcode files for development
28 Group: Development/Libraries
32 The package is meant to solve most needs in barcode creation with a
33 conventional printer. It can create printouts for the conventional
34 product tagging standards: UPC-A, UPC-E, EAN-13, EAN-8, ISBN, as well
35 as a few other formats. Ouput is generated as either Postscript or
36 Encapsulated Postscript (other back-ends may be added if needed).
38 This package contain the C header, the static library and man page
45 ARCH_FLAGS="--host=alpha-redhat-linux"
48 export -n LANG LINGUAS LC_ALL
49 if [ ! -f configure ]; then
50 CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir}
52 CFLAGS="$RPM_OPT_FLAGS" ./configure $ARCH_FLAGS --prefix=%{prefix} --sysconfdir=%{sysconfdir}
56 export -n LANG LINGUAS LC_ALL
58 if [ "$SMP" != "" ]; then
59 (make "MAKE=make -k -j $SMP"; exit 0)
66 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
67 make prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install
70 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
73 %defattr(-, root, root)
75 %doc COPYING ChangeLog INSTALL README TODO doc/*.html doc/*.pdf doc/*.ps
77 %attr(0755,root,root) %{prefix}/bin/barcode
78 %attr(0644,root,root) %{prefix}/info/barcode.info*
79 %attr(0644,root,root) %{prefix}/man/man1/barcode.1*
82 %attr(0644,root,root) %{prefix}/include/barcode.h
83 %attr(0644,root,root) %{prefix}/lib/libbarcode.a
84 %attr(0644,root,root) %{prefix}/man/man3/barcode.3*