]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65-2.5.0.spec
Added RPM spec files
[cc65] / packages / rpm / redhat / cc65-2.5.0.spec
1 #
2 # SPEC file for the cc65 C compiler
3 #
4 # 07/10/99, Ullrich von Bassewitz (uz@musoftware.de)
5 #
6
7 Summary: Crosscompiler/Crossassembler for 6502 systems
8 Name: cc65
9 %define version 2.5.0
10 Version: %{version}
11 Release: 3
12 Copyright: Freeware with exceptions - see docs
13 Group: Development/Languages
14 Source: ftp://ftp.musoftware.de/uz/cc65/cc65-sources-%{version}.tar.gz
15 Vendor: MU Softwareentwicklung
16 Packager: Ullrich von Bassewitz <uz@musoftware.de>
17 %ifos linux
18 BuildRequires: sgml-tools
19 %endif
20 BuildRoot: /var/tmp/%{name}-%{version}
21
22 %description
23 A C crosscompiler for 6502 systems, including a macroassembler that
24 supports 6502, 65SC02 and 65816 CPUs, a linker and an archiver. The
25 package contains the runtime library, a standard C library and runtime
26 support for the C64, the C128, the CBM Plus/4, PET machines, the CBM-II
27 (600/700) series of computers, the Apple ][, and the 8 bit Atari
28 machines.
29
30
31 %prep
32 %setup
33
34
35 %build
36 # Binaries
37 cd src
38 make -f make/gcc.mak
39 cd ..
40 # Libraries
41 cd libsrc
42 make clean apple2lib
43 make clean atarilib
44 make clean c128lib
45 make clean c64lib
46 make clean cbm610lib
47 make clean geoslib
48 make clean petlib
49 make clean plus4lib
50 cd ..
51 # Documentation
52 cd doc
53 sgml2txt geos.sgml
54 cd ..
55
56
57 %install
58
59 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{lib,include/geos,sample}}
60
61 # Binaries
62 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
63 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
64 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
65 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
66 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
67 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
68 # Libraries and includes
69 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
70 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
71 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
72
73
74 %files
75 %defattr(644,root,root,755)
76 %doc announce.txt
77 %doc doc/BUGS
78 %doc doc/CREDITS
79 %doc doc/ar65.txt
80 %doc doc/ca65.txt
81 %doc doc/cc65.txt
82 %doc doc/cl65.txt
83 %doc doc/coding.txt
84 %doc doc/compile.txt
85 %doc doc/debugging.txt
86 %doc doc/geos.txt
87 %doc doc/grc.txt
88 %doc doc/internal.doc
89 %doc doc/intro.txt
90 %doc doc/ld65.txt
91 %doc doc/library.txt
92 %doc doc/newvers.txt
93 %doc doc/readme.1st
94 %doc doc/readme.txt
95 %doc samples
96 %attr(755,root,root)            /usr/bin/ar65
97 %attr(755,root,root)            /usr/bin/ca65
98 %attr(755,root,root)            /usr/bin/cc65
99 %attr(755,root,root)            /usr/bin/cl65
100 %attr(755,root,root)            /usr/bin/grc
101 %attr(755,root,root)            /usr/bin/ld65
102 %attr(755,root,root) %dir       /usr/lib/cc65
103 %attr(755,root,root) %dir       /usr/lib/cc65/lib
104 %attr(755,root,root) %dir       /usr/lib/cc65/include
105 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
106 %attr(644,root,root)            /usr/lib/cc65/lib/*
107 %attr(644,root,root)            /usr/lib/cc65/include/*.h
108 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
109
110 %changelog
111 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
112 The GEOS include files were not installed, remove headegen.sh
113
114 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
115 Update to version 2.5.0 of the compiler package.
116
117 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
118 Update to version 2.4.1 of the compiler package.
119
120 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
121 Update to version 2.4.0 of the compiler package.
122
123 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
124 Update to version 2.3.1 of the compiler package.
125
126 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
127 Update to version 2.3.0 of the compiler package.
128
129 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
130 [2.2.1-2]
131 - changed to allow build as plain user
132 - `samples' are part of documentation, not part of library
133