]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65-2.6.0.spec
Converted the C16/Plus4 joystick code to modules
[cc65] / packages / rpm / redhat / cc65-2.6.0.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 07/10/99, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 Name: cc65
13 %define version 2.6.0
14 Version: %{version}
15 Release: 1
16 Copyright: Freeware with exceptions - see docs
17 Group: Development/Languages
18 Source: ftp://ftp.musoftware.de/uz/cc65/cc65-sources-%{version}.tar.gz
19 Vendor: MU Softwareentwicklung
20 Packager: Ullrich von Bassewitz <uz@musoftware.de>
21 %ifos linux
22 BuildRequires: sgml-tools
23 %endif
24 BuildRoot: /var/tmp/%{name}-%{version}
25
26 %description
27 A C crosscompiler for 6502 systems, including a macroassembler that
28 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
29 other tools. To create programs for one of the supported target
30 machines, you have to install at least one of the library packages.
31
32 %files
33 %defattr(644,root,root,755)
34 %doc announce.txt
35 %doc doc/BUGS
36 %doc doc/CREDITS
37 %doc doc/*.html
38 %doc doc/compile.txt
39 %doc doc/grc.txt
40 %doc doc/internal.txt
41 %doc doc/newvers.txt
42 %doc doc/readme.1st
43 %doc samples
44 %attr(755,root,root)            /usr/bin/ar65
45 %attr(755,root,root)            /usr/bin/ca65
46 %attr(755,root,root)            /usr/bin/ca65html
47 %attr(755,root,root)            /usr/bin/cc65
48 %attr(755,root,root)            /usr/bin/cl65
49 %attr(755,root,root)            /usr/bin/da65
50 %attr(755,root,root)            /usr/bin/ld65
51 %attr(755,root,root) %dir       /usr/lib/cc65
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/include
54 %attr(644,root,root)            /usr/lib/cc65/include/*.h
55
56
57
58 ###############################################################################
59 #                               C64 subpackage                                #
60 ###############################################################################
61
62 %package c64
63 Requires: cc65 = 2.6.0
64 Copyright: Freeware
65 Summary: C64 specific libraries and headers for the cc65 compiler.
66 Group: Development/Languages
67
68 %description c64
69 This package contains the header files and libraries needed to write
70 programs for the Commodore C64 using the cc65 crosscompiler.
71
72 %files c64
73 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
74 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
75 %doc src/ld65/cfg/c64.cfg
76
77
78
79 ###############################################################################
80 #                               C128 subpackage                               #
81 ###############################################################################
82
83 %package c128
84 Requires: cc65 = 2.6.0
85 Copyright: Freeware
86 Summary: C128 specific libraries and headers for the cc65 compiler.
87 Group: Development/Languages
88
89 %description c128
90 This package contains the header files and libraries needed to write
91 programs for the Commodore C128 using the cc65 crosscompiler.
92
93 %files c128
94 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
95 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
96 %doc src/ld65/cfg/c128.cfg
97
98
99
100 ###############################################################################
101 #                              Atari subpackage                               #
102 ###############################################################################
103
104 %package atari
105 Requires: cc65 = 2.6.0
106 Copyright: Freeware
107 Summary: Atari specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
109
110 %description atari
111 This package contains the header files and libraries needed to write
112 programs for the 8 bit Atari machines using the cc65 crosscompiler.
113
114 %files atari
115 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
116 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
117 %doc src/ld65/cfg/atari.cfg
118
119
120
121 ###############################################################################
122 #                              Plus/4 subpackage                              #
123 ###############################################################################
124
125 %package plus4
126 Requires: cc65 = 2.6.0
127 Copyright: Freeware
128 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
129 Group: Development/Languages
130
131 %description plus4
132 This package contains the header files and libraries needed to write
133 programs for the Commodore Plus/4 and C16/116 using the cc65
134 crosscompiler.
135
136 %files plus4
137 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
138 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
139 %doc src/ld65/cfg/plus4.cfg
140
141
142
143 ###############################################################################
144 #                               PET subpackage                                #
145 ###############################################################################
146
147 %package pet
148 Requires: cc65 = 2.6.0
149 Copyright: Freeware
150 Summary: PET specific libraries and headers for the cc65 compiler.
151 Group: Development/Languages
152
153 %description pet
154 This package contains the header files and libraries needed to write
155 programs for the Commodore PET family of computers using the cc65
156 crosscompiler.
157
158 %files pet
159 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
160 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
161 %doc src/ld65/cfg/pet.cfg
162
163
164
165 ###############################################################################
166 #                              CBM610 subpackage                              #
167 ###############################################################################
168
169 %package cbm610
170 Requires: cc65 = 2.6.0
171 Copyright: Freeware
172 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
173 Group: Development/Languages
174
175 %description cbm610
176 This package contains the header files and libraries needed to write
177 programs for the Commodore PET-II (CBM600/700) family of computers using
178 the cc65 crosscompiler.
179
180 %files cbm610
181 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
182 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
183 %doc src/ld65/cfg/cbm610.cfg
184
185
186
187 ###############################################################################
188 #                             Apple ][ subpackage                             #
189 ###############################################################################
190
191 %package apple2
192 Requires: cc65 = 2.6.0
193 Copyright: Freeware
194 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
195 Group: Development/Languages
196
197 %description apple2
198 This package contains the header files and libraries needed to write
199 programs for the Apple ][ using the cc65 crosscompiler.
200
201 %files apple2
202 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
203 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
204 %doc src/ld65/cfg/apple2.cfg
205
206
207
208 ###############################################################################
209 #                               GEOS subpackage                               #
210 ###############################################################################
211
212 %package geos
213 Requires: cc65 = 2.6.0
214 Copyright: Freeware
215 Summary: GEOS specific libraries and headers for the cc65 compiler.
216 Group: Development/Languages
217
218 %description geos
219 This package contains the header files and libraries needed to write
220 GEOS programs for the C64/C128 using the cc65 crosscompiler.
221
222 %files geos
223 %attr(755,root,root)            /usr/bin/grc
224 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
225 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
226 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
227 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
228 %doc src/ld65/cfg/geos.cfg
229
230
231
232 ###############################################################################
233 #                                    Build                                    #
234 ###############################################################################
235
236
237
238 %prep
239 %setup
240
241
242 %build
243 # Binaries
244 cd src
245 make -f make/gcc.mak
246 cd ..
247 # Libraries
248 cd libsrc
249 make zap all
250 cd ..
251 # Documentation
252 cd doc
253 make html
254 cd ..
255
256
257 %install
258 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{lib,include/geos}}
259
260 # Binaries
261 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
262 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
263 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
264 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
265 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
266 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
267 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
268 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
269 # Libraries and includes
270 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
271 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
272 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
273
274
275 %changelog
276 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
277 Update for cc65 2.6.0 and RedHat 7.x
278
279 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
280 The GEOS include files were not installed, remove headegen.sh
281
282 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
283 Update to version 2.5.0 of the compiler package.
284
285 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
286 Update to version 2.4.1 of the compiler package.
287
288 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
289 Update to version 2.4.0 of the compiler package.
290
291 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
292 Update to version 2.3.1 of the compiler package.
293
294 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
295 Update to version 2.3.0 of the compiler package.
296
297 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
298 [2.2.1-2]
299 - changed to allow build as plain user
300 - `samples' are part of documentation, not part of library
301