]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65-2.8.0.spec
Added spec for v 2.8.0
[cc65] / packages / rpm / redhat / cc65-2.8.0.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 Name: cc65
13 %define version 2.8.0
14 Version: %{version}
15 Release: 1
16 Copyright: Freeware with exceptions - see docs
17 Group: Development/Languages
18 Source: ftp://ftp.musoftware.de/uz/cc65/cc65-sources-%{version}.tar.bz2
19 Vendor: MU Softwareentwicklung
20 Packager: Ullrich von Bassewitz <uz@musoftware.de>
21 %ifos linux
22 BuildRequires: perl
23 BuildRequires: sgml-tools
24 %endif
25 BuildRoot: /var/tmp/%{name}-%{version}
26
27 %description
28 A C crosscompiler for 6502 systems, including a macroassembler that
29 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
30 other tools. To create programs for one of the supported target
31 machines, you have to install at least one of the library packages.
32
33 %files
34 %defattr(644,root,root,755)
35 %doc announce.txt
36 %doc doc/BUGS
37 %doc doc/CREDITS
38 %doc doc/*.html
39 %doc doc/compile.txt
40 %doc doc/grc.txt
41 %doc doc/internal.txt
42 %doc doc/newvers.txt
43 %doc doc/readme.1st
44 %doc samples
45 %attr(755,root,root)            /usr/bin/ar65
46 %attr(755,root,root)            /usr/bin/ca65
47 %attr(755,root,root)            /usr/bin/ca65html
48 %attr(755,root,root)            /usr/bin/cc65
49 %attr(755,root,root)            /usr/bin/cl65
50 %attr(755,root,root)            /usr/bin/da65
51 %attr(755,root,root)            /usr/bin/ld65
52 %attr(755,root,root) %dir       /usr/lib/cc65
53 %attr(755,root,root) %dir       /usr/lib/cc65/lib
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56
57
58
59 ###############################################################################
60 #                               C64 subpackage                                #
61 ###############################################################################
62
63 %package c64
64 Requires: cc65 = %{version}
65 Copyright: Freeware
66 Summary: C64 specific libraries and headers for the cc65 compiler.
67 Group: Development/Languages
68
69 %description c64
70 This package contains the header files and libraries needed to write
71 programs for the Commodore C64 using the cc65 crosscompiler.
72
73 %files c64
74 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
75 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
76 %doc src/ld65/cfg/c64.cfg
77
78
79
80 ###############################################################################
81 #                               C128 subpackage                               #
82 ###############################################################################
83
84 %package c128
85 Requires: cc65 = %{version}
86 Copyright: Freeware
87 Summary: C128 specific libraries and headers for the cc65 compiler.
88 Group: Development/Languages
89
90 %description c128
91 This package contains the header files and libraries needed to write
92 programs for the Commodore C128 using the cc65 crosscompiler.
93
94 %files c128
95 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
96 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
97 %doc src/ld65/cfg/c128.cfg
98
99
100
101 ###############################################################################
102 #                              Atari subpackage                               #
103 ###############################################################################
104
105 %package atari
106 Requires: cc65 = %{version}
107 Copyright: Freeware
108 Summary: Atari specific libraries and headers for the cc65 compiler.
109 Group: Development/Languages
110
111 %description atari
112 This package contains the header files and libraries needed to write
113 programs for the 8 bit Atari machines using the cc65 crosscompiler.
114
115 %files atari
116 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
117 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
118 %doc src/ld65/cfg/atari.cfg
119
120
121
122 ###############################################################################
123 #                              Plus/4 subpackage                              #
124 ###############################################################################
125
126 %package plus4
127 Requires: cc65 = %{version}
128 Copyright: Freeware
129 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
130 Group: Development/Languages
131
132 %description plus4
133 This package contains the header files and libraries needed to write
134 programs for the Commodore Plus/4 and C16/116 using the cc65
135 crosscompiler.
136
137 %files plus4
138 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
139 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
140 %doc src/ld65/cfg/plus4.cfg
141
142
143
144 ###############################################################################
145 #                               PET subpackage                                #
146 ###############################################################################
147
148 %package pet
149 Requires: cc65 = %{version}
150 Copyright: Freeware
151 Summary: PET specific libraries and headers for the cc65 compiler.
152 Group: Development/Languages
153
154 %description pet
155 This package contains the header files and libraries needed to write
156 programs for the Commodore PET family of computers using the cc65
157 crosscompiler.
158
159 %files pet
160 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
161 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
162 %doc src/ld65/cfg/pet.cfg
163
164
165
166 ###############################################################################
167 #                              CBM510 subpackage                              #
168 ###############################################################################
169
170 %package cbm510
171 Requires: cc65 = %{version}
172 Copyright: Freeware
173 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
174 Group: Development/Languages
175
176 %description cbm510
177 This package contains the header files and libraries needed to write
178 programs for the Commodore CBM 510 (aka P500) using the cc65
179 crosscompiler.
180
181 %files cbm510
182 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
183 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
184 %doc src/ld65/cfg/cbm510.cfg
185
186
187
188 ###############################################################################
189 #                              CBM610 subpackage                              #
190 ###############################################################################
191
192 %package cbm610
193 Requires: cc65 = %{version}
194 Copyright: Freeware
195 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
196 Group: Development/Languages
197
198 %description cbm610
199 This package contains the header files and libraries needed to write
200 programs for the Commodore PET-II (CBM600/700) family of computers using
201 the cc65 crosscompiler.
202
203 %files cbm610
204 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
205 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
206 %doc src/ld65/cfg/cbm610.cfg
207
208
209
210 ###############################################################################
211 #                             Apple ][ subpackage                             #
212 ###############################################################################
213
214 %package apple2
215 Requires: cc65 = %{version}
216 Copyright: Freeware
217 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
218 Group: Development/Languages
219
220 %description apple2
221 This package contains the header files and libraries needed to write
222 programs for the Apple ][ using the cc65 crosscompiler.
223
224 %files apple2
225 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
226 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
227 %doc src/ld65/cfg/apple2.cfg
228
229
230
231 ###############################################################################
232 #                               GEOS subpackage                               #
233 ###############################################################################
234
235 %package geos
236 Requires: cc65 = %{version}
237 Copyright: Freeware
238 Summary: GEOS specific libraries and headers for the cc65 compiler.
239 Group: Development/Languages
240
241 %description geos
242 This package contains the header files and libraries needed to write
243 GEOS programs for the C64/C128 using the cc65 crosscompiler.
244
245 %files geos
246 %attr(755,root,root)            /usr/bin/grc
247 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
248 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
249 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
250 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
251 %doc src/ld65/cfg/geos.cfg
252
253
254
255 ###############################################################################
256 #                                    Build                                    #
257 ###############################################################################
258
259
260
261 %prep
262 %setup
263
264
265 %build
266 # Binaries
267 cd src
268 make -f make/gcc.mak
269 cd ..
270 # Libraries
271 cd libsrc
272 make zap all
273 cd ..
274 # Documentation
275 cd doc
276 make html
277 cd ..
278
279
280 %install
281 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{lib,include/geos}}
282
283 # Binaries
284 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
285 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
286 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
287 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
288 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
289 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
290 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
291 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
292 # Libraries and includes
293 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
294 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
295 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
296
297
298 %changelog
299 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
300 Update to version 2.8.0 of the compiler package.
301
302 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
303 Update to version 2.7.1 of the compiler package.
304
305 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
306 Update to version 2.7.0 of the compiler package.
307
308 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
309 Update to version 2.6.2 of the compiler package.
310
311 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
312 Update to version 2.6.1 of the compiler package.
313
314 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
315 Update for cc65 2.6.0 and RedHat 7.x
316
317 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
318 The GEOS include files were not installed, remove headegen.sh
319
320 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
321 Update to version 2.5.0 of the compiler package.
322
323 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
324 Update to version 2.4.1 of the compiler package.
325
326 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
327 Update to version 2.4.0 of the compiler package.
328
329 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
330 Update to version 2.3.1 of the compiler package.
331
332 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
333 Update to version 2.3.0 of the compiler package.
334
335 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
336 [2.2.1-2]
337 - changed to allow build as plain user
338 - `samples' are part of documentation, not part of library
339