]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Package the additional linker scripts for the apple.
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.13.0
15 Version: %{version}
16 Release: 1
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
23 %ifos linux
24 BuildRequires: perl
25 BuildRequires: sgml-tools
26 %endif
27 BuildRoot: /var/tmp/%{name}-%{version}
28
29 %description
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the library packages.
34
35 %files
36 %defattr(644,root,root,755)
37 %doc announce.txt
38 %doc doc/BUGS
39 %doc doc/CREDITS
40 %doc doc/readme.1st
41 %attr(755,root,root)            /usr/bin/ar65
42 %attr(755,root,root)            /usr/bin/ca65
43 %attr(755,root,root)            /usr/bin/ca65html
44 %attr(755,root,root)            /usr/bin/cc65
45 %attr(755,root,root)            /usr/bin/cl65
46 %attr(755,root,root)            /usr/bin/co65
47 %attr(755,root,root)            /usr/bin/da65
48 %attr(755,root,root)            /usr/bin/ld65
49 %attr(755,root,root)            /usr/bin/od65
50 %attr(755,root,root) %dir       /usr/lib/cc65
51 %attr(755,root,root) %dir       /usr/lib/cc65/emd
52 %attr(755,root,root) %dir       /usr/lib/cc65/joy
53 %attr(755,root,root) %dir       /usr/lib/cc65/lib
54 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
55 %attr(755,root,root) %dir       /usr/lib/cc65/include
56 %attr(644,root,root)            /usr/lib/cc65/include/*.h
57 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
58 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
59 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
60 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
62 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
64 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
66 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
67 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
68 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
69
70
71
72 ###############################################################################
73 #                          Documentation subpackage                           #
74 ###############################################################################
75
76 %package doc
77
78 Requires: %{name} = %{version}
79 License: Freeware
80 Summary: Documentation for the cc65 C compiler
81 Group: Development/Languages
82
83 %description doc
84 This package contains the documentation for the cc65 C compiler, mostly
85 in HTML format. Other formats can be generated from the sources.
86
87 %files doc
88 %doc doc/*.html
89 %doc doc/compile.txt
90 %doc doc/internal.txt
91 %doc doc/newvers.txt
92 %doc samples
93 %doc src/ld65/cfg/*.cfg
94
95
96
97 ###############################################################################
98 #                             Apple ][ subpackage                             #
99 ###############################################################################
100
101 %package apple2
102 Requires: %{name} = %{version}
103 License: Freeware
104 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
105 Group: Development/Languages
106
107 %description apple2
108 This package contains the header files and libraries needed to write
109 programs for the Apple ][ using the cc65 crosscompiler.
110
111 %files apple2
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
113 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
114 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
115 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
116 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
117 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
118 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2-*.cfg
119
120
121
122 ###############################################################################
123 #                            Apple //e subpackage                             #
124 ###############################################################################
125
126 %package apple2enh
127 Requires: %{name} = %{version}
128 License: Freeware
129 Summary: Apple //e specific libraries and headers for the cc65 compiler.
130 Group: Development/Languages
131
132 %description apple2enh
133 This package contains the header files and libraries needed to write
134 programs for the Apple //e using the cc65 crosscompiler.
135
136 %files apple2enh
137 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
138 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
139 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
140 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
141 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
142 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
143
144
145
146 ###############################################################################
147 #                              Atari subpackage                               #
148 ###############################################################################
149
150 %package atari
151 Requires: %{name} = %{version}
152 License: Freeware
153 Summary: Atari specific libraries and headers for the cc65 compiler.
154 Group: Development/Languages
155
156 %description atari
157 This package contains the header files and libraries needed to write
158 programs for the 8 bit Atari machines using the cc65 crosscompiler.
159
160 %files atari
161 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
162 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
163
164
165
166 ###############################################################################
167 #                            Oric Atmos subpackage                            #
168 ###############################################################################
169
170 %package atmos
171 Requires: %{name} = %{version}
172 License: Freeware
173 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
174 Group: Development/Languages
175
176 %description atmos
177 This package contains the header files and libraries needed to write
178 programs for the Oric Atmos using the cc65 crosscompiler.
179
180 %files atmos
181 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
182 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
183
184
185
186 ###############################################################################
187 #                               C128 subpackage                               #
188 ###############################################################################
189
190 %package c128
191 Requires: %{name} = %{version}
192 License: Freeware
193 Summary: C128 specific libraries and headers for the cc65 compiler.
194 Group: Development/Languages
195
196 %description c128
197 This package contains the header files and libraries needed to write
198 programs for the Commodore C128 using the cc65 crosscompiler.
199
200 %files c128
201 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
202 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
203 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
204 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
205 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
206 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
207
208
209
210 ###############################################################################
211 #                                C16 subpackage                               #
212 ###############################################################################
213
214 %package c16
215 Requires: %{name} = %{version}
216 License: Freeware
217 Summary: C16/116 specific libraries and headers for the cc65 compiler.
218 Group: Development/Languages
219
220 %description c16
221 This package contains the header files and libraries needed to write
222 programs for the Commodore C16/116 using the cc65 crosscompiler.
223
224 %files c16
225 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
226 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
227 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
228
229
230
231 ###############################################################################
232 #                               C64 subpackage                                #
233 ###############################################################################
234
235 %package c64
236 Requires: %{name} = %{version}
237 License: Freeware
238 Summary: C64 specific libraries and headers for the cc65 compiler.
239 Group: Development/Languages
240
241 %description c64
242 This package contains the header files and libraries needed to write
243 programs for the Commodore C64 using the cc65 crosscompiler.
244
245 %files c64
246 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
247 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
248 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
249 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
250 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
251 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
252 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
253
254
255
256 ###############################################################################
257 #                              CBM510 subpackage                              #
258 ###############################################################################
259
260 %package cbm510
261 Requires: %{name} = %{version}
262 License: Freeware
263 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
264 Group: Development/Languages
265
266 %description cbm510
267 This package contains the header files and libraries needed to write
268 programs for the Commodore CBM 510 (aka P500) using the cc65
269 crosscompiler.
270
271 %files cbm510
272 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
273 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
274 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
275 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
276
277
278
279 ###############################################################################
280 #                              CBM610 subpackage                              #
281 ###############################################################################
282
283 %package cbm610
284 Requires: %{name} = %{version}
285 License: Freeware
286 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
287 Group: Development/Languages
288
289 %description cbm610
290 This package contains the header files and libraries needed to write
291 programs for the Commodore PET-II (CBM600/700) family of computers using
292 the cc65 crosscompiler.
293
294 %files cbm610
295 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
296 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
297 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
298
299
300
301 ###############################################################################
302 #                               GEOS subpackage                               #
303 ###############################################################################
304
305 %package geos
306 Requires: %{name} = %{version}
307 License: Freeware
308 Summary: GEOS specific libraries and headers for the cc65 compiler.
309 Group: Development/Languages
310
311 %description geos
312 This package contains the header files and libraries needed to write
313 GEOS programs for the C64/C128 using the cc65 crosscompiler.
314
315 %files geos
316 %attr(755,root,root)            /usr/bin/grc
317 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
318 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
319 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
320 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
321 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
322 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
323
324
325
326 ###############################################################################
327 #                               Lynx subpackage                               #
328 ###############################################################################
329
330 %package lynx
331 Requires: %{name} = %{version}
332 License: Freeware
333 Summary: Lynx specific libraries and headers for the cc65 compiler.
334 Group: Development/Languages
335
336 %description lynx
337 This package contains the header files and libraries needed to write
338 programs for the Lynx Game Console using the cc65 crosscompiler.
339
340 %files lynx
341 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
342 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
343 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
344
345
346
347 ###############################################################################
348 #                               NES subpackage                                #
349 ###############################################################################
350
351 %package nes
352 Requires: %{name} = %{version}
353 License: Freeware
354 Summary: NES specific libraries and headers for the cc65 compiler.
355 Group: Development/Languages
356
357 %description nes
358 This package contains the header files and libraries needed to write
359 programs for the Nintendo Entertainment System using the cc65
360 crosscompiler.
361
362 %files nes
363 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
364 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
365
366
367
368 ###############################################################################
369 #                               PET subpackage                                #
370 ###############################################################################
371
372 %package pet
373 Requires: %{name} = %{version}
374 License: Freeware
375 Summary: PET specific libraries and headers for the cc65 compiler.
376 Group: Development/Languages
377
378 %description pet
379 This package contains the header files and libraries needed to write
380 programs for the Commodore PET family of computers using the cc65
381 crosscompiler.
382
383 %files pet
384 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
385 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
386
387
388
389 ###############################################################################
390 #                              Plus/4 subpackage                              #
391 ###############################################################################
392
393 %package plus4
394 Requires: %{name} = %{version}
395 License: Freeware
396 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
397 Group: Development/Languages
398
399 %description plus4
400 This package contains the header files and libraries needed to write
401 programs for the Commodore Plus/4 and C16/116 using the cc65
402 crosscompiler.
403
404 %files plus4
405 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
406 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
407 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
408
409
410
411 ###############################################################################
412 #                           Supervision subpackage                            #
413 ###############################################################################
414
415 %package supervision
416 Requires: %{name} = %{version}
417 License: Freeware
418 Summary: Supervision specific libraries and headers for the cc65 compiler.
419 Group: Development/Languages
420
421 %description supervision
422 This package contains the header files and libraries needed to write
423 programs for the Supervision Game console using the cc65 crosscompiler.
424
425 %files supervision
426 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
427 %attr(644,root,root)            /usr/lib/cc65/cfg/supervision-*.cfg
428
429
430
431 ###############################################################################
432 #                              VIC20 subpackage                               #
433 ###############################################################################
434
435 %package vic20
436 Requires: %{name} = %{version}
437 License: Freeware
438 Summary: VIC20 specific libraries and headers for the cc65 compiler.
439 Group: Development/Languages
440
441 %description vic20
442 This package contains the header files and libraries needed to write
443 programs for the Commodore VIC20 using the cc65 crosscompiler.
444
445 %files vic20
446 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
447 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
448
449
450
451 ###############################################################################
452 #                                    Build                                    #
453 ###############################################################################
454
455
456
457 %prep
458 %setup -q
459
460
461 %build
462 # Binaries
463 make -C src -f make/gcc.mak
464 # Libraries
465 make -C libsrc -s zap all
466 # Documentation
467 make -C doc html
468
469
470 %install
471 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
472
473 # Binaries
474 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
475 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
476 install    -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
477 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
478 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
479 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
480 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
481 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
482 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
483 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
484
485 # Libraries and includes
486 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
487 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
488 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
489 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
490 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
491 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
492 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
493 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
494 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
495
496 # Additional linker configurations
497 for config in src/ld65/cfg/*-*.cfg; do
498     install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
499 done
500
501 # Drivers
502 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
503 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
504 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
505 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
506 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
507
508
509 %clean
510 rm -rf $RPM_BUILD_ROOT
511
512
513
514 %changelog
515 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
516 - Changelog is now in CVS