]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Bumped the version number
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.11.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/internal.txt
90 %doc doc/newvers.txt
91 %doc samples
92 %doc src/ld65/cfg/*.cfg
93
94
95
96 ###############################################################################
97 #                             Apple ][ subpackage                             #
98 ###############################################################################
99
100 %package apple2
101 Requires: %{name} = %{version}
102 Copyright: Freeware
103 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
104 Group: Development/Languages
105
106 %description apple2
107 This package contains the header files and libraries needed to write
108 programs for the Apple ][ using the cc65 crosscompiler.
109
110 %files apple2
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
113 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
114 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
115 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117
118
119
120 ###############################################################################
121 #                            Apple //e subpackage                             #
122 ###############################################################################
123
124 %package apple2enh
125 Requires: %{name} = %{version}
126 Copyright: Freeware
127 Summary: Apple //e specific libraries and headers for the cc65 compiler.
128 Group: Development/Languages
129
130 %description apple2enh
131 This package contains the header files and libraries needed to write
132 programs for the Apple //e using the cc65 crosscompiler.
133
134 %files apple2enh
135 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.o
137 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
138 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
139 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
140 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
141
142
143
144 ###############################################################################
145 #                              Atari subpackage                               #
146 ###############################################################################
147
148 %package atari
149 Requires: %{name} = %{version}
150 Copyright: Freeware
151 Summary: Atari specific libraries and headers for the cc65 compiler.
152 Group: Development/Languages
153
154 %description atari
155 This package contains the header files and libraries needed to write
156 programs for the 8 bit Atari machines using the cc65 crosscompiler.
157
158 %files atari
159 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
160 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
161 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
162
163
164
165 ###############################################################################
166 #                            Oric Atmos subpackage                            #
167 ###############################################################################
168
169 %package atmos
170 Requires: %{name} = %{version}
171 Copyright: Freeware
172 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
173 Group: Development/Languages
174
175 %description atmos
176 This package contains the header files and libraries needed to write
177 programs for the Oric Atmos using the cc65 crosscompiler.
178
179 %files atmos
180 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
181 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
182 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
183
184
185
186 ###############################################################################
187 #                               C128 subpackage                               #
188 ###############################################################################
189
190 %package c128
191 Requires: %{name} = %{version}
192 Copyright: Freeware
193 Summary: C128 specific libraries and headers for the cc65 compiler.
194 Group: Development/Languages
195
196 %description c128
197 This package contains the header files and libraries needed to write
198 programs for the Commodore C128 using the cc65 crosscompiler.
199
200 %files c128
201 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
202 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
203 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
204 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
205 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
206 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
207 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
208
209
210
211 ###############################################################################
212 #                                C16 subpackage                               #
213 ###############################################################################
214
215 %package c16
216 Requires: %{name} = %{version}
217 Copyright: Freeware
218 Summary: C16/116 specific libraries and headers for the cc65 compiler.
219 Group: Development/Languages
220
221 %description c16
222 This package contains the header files and libraries needed to write
223 programs for the Commodore C16/116 using the cc65 crosscompiler.
224
225 %files c16
226 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
227 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
228 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
229 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
230
231
232
233 ###############################################################################
234 #                               C64 subpackage                                #
235 ###############################################################################
236
237 %package c64
238 Requires: %{name} = %{version}
239 Copyright: Freeware
240 Summary: C64 specific libraries and headers for the cc65 compiler.
241 Group: Development/Languages
242
243 %description c64
244 This package contains the header files and libraries needed to write
245 programs for the Commodore C64 using the cc65 crosscompiler.
246
247 %files c64
248 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
249 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
250 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
251 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
252 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
253 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
254 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
255
256
257
258 ###############################################################################
259 #                              CBM510 subpackage                              #
260 ###############################################################################
261
262 %package cbm510
263 Requires: %{name} = %{version}
264 Copyright: Freeware
265 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
266 Group: Development/Languages
267
268 %description cbm510
269 This package contains the header files and libraries needed to write
270 programs for the Commodore CBM 510 (aka P500) using the cc65
271 crosscompiler.
272
273 %files cbm510
274 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
275 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
276 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
277 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
278 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
279
280
281
282 ###############################################################################
283 #                              CBM610 subpackage                              #
284 ###############################################################################
285
286 %package cbm610
287 Requires: %{name} = %{version}
288 Copyright: Freeware
289 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
290 Group: Development/Languages
291
292 %description cbm610
293 This package contains the header files and libraries needed to write
294 programs for the Commodore PET-II (CBM600/700) family of computers using
295 the cc65 crosscompiler.
296
297 %files cbm610
298 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
299 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
300 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
301 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
302
303
304
305 ###############################################################################
306 #                               GEOS subpackage                               #
307 ###############################################################################
308
309 %package geos
310 Requires: %{name} = %{version}
311 Copyright: Freeware
312 Summary: GEOS specific libraries and headers for the cc65 compiler.
313 Group: Development/Languages
314
315 %description geos
316 This package contains the header files and libraries needed to write
317 GEOS programs for the C64/C128 using the cc65 crosscompiler.
318
319 %files geos
320 %attr(755,root,root)            /usr/bin/grc
321 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
322 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
323 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
324 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
325 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
326 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
327 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
328
329
330
331 ###############################################################################
332 #                               Lynx subpackage                               #
333 ###############################################################################
334
335 %package lynx
336 Requires: %{name} = %{version}
337 Copyright: Freeware
338 Summary: Lynx specific libraries and headers for the cc65 compiler.
339 Group: Development/Languages
340
341 %description lynx
342 This package contains the header files and libraries needed to write
343 programs for the Lynx Game Console using the cc65 crosscompiler.
344
345 %files lynx
346 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
347 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.o
348 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
349 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
350
351
352
353 ###############################################################################
354 #                               NES subpackage                                #
355 ###############################################################################
356
357 %package nes
358 Requires: %{name} = %{version}
359 Copyright: Freeware
360 Summary: NES specific libraries and headers for the cc65 compiler.
361 Group: Development/Languages
362
363 %description nes
364 This package contains the header files and libraries needed to write
365 programs for the Nintendo Entertainment System using the cc65
366 crosscompiler.
367
368 %files nes
369 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
370 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
371 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
372
373
374
375 ###############################################################################
376 #                               PET subpackage                                #
377 ###############################################################################
378
379 %package pet
380 Requires: %{name} = %{version}
381 Copyright: Freeware
382 Summary: PET specific libraries and headers for the cc65 compiler.
383 Group: Development/Languages
384
385 %description pet
386 This package contains the header files and libraries needed to write
387 programs for the Commodore PET family of computers using the cc65
388 crosscompiler.
389
390 %files pet
391 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
392 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
393 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
394
395
396
397 ###############################################################################
398 #                              Plus/4 subpackage                              #
399 ###############################################################################
400
401 %package plus4
402 Requires: %{name} = %{version}
403 Copyright: Freeware
404 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
405 Group: Development/Languages
406
407 %description plus4
408 This package contains the header files and libraries needed to write
409 programs for the Commodore Plus/4 and C16/116 using the cc65
410 crosscompiler.
411
412 %files plus4
413 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
414 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
415 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
416 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
417
418
419
420 ###############################################################################
421 #                           Supervision subpackage                            #
422 ###############################################################################
423
424 %package supervision
425 Requires: %{name} = %{version}
426 Copyright: Freeware
427 Summary: Supervision specific libraries and headers for the cc65 compiler.
428 Group: Development/Languages
429
430 %description supervision
431 This package contains the header files and libraries needed to write
432 programs for the Supervision Game console using the cc65 crosscompiler.
433
434 %files supervision
435 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
436 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
437
438
439
440 ###############################################################################
441 #                              VIC20 subpackage                               #
442 ###############################################################################
443
444 %package vic20
445 Requires: %{name} = %{version}
446 Copyright: Freeware
447 Summary: VIC20 specific libraries and headers for the cc65 compiler.
448 Group: Development/Languages
449
450 %description vic20
451 This package contains the header files and libraries needed to write
452 programs for the Commodore VIC20 using the cc65 crosscompiler.
453
454 %files vic20
455 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
456 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
457 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
458
459
460
461 ###############################################################################
462 #                                    Build                                    #
463 ###############################################################################
464
465
466
467 %prep
468 %setup -q
469
470
471 %build
472 # Binaries
473 make -C src -f make/gcc.mak
474 # Libraries
475 make -C libsrc -s zap all
476 # Documentation
477 make -C doc html
478
479
480 %install
481 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
482
483 # Binaries
484 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
492 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
493 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
494 # Libraries and includes
495 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
496 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
497 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
498 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
499 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
500 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
501 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
502 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
503 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
504
505 # Drivers
506 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
507 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
508 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
509 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
510 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
511
512
513 %clean
514 rm -rf $RPM_BUILD_ROOT
515
516
517
518 %changelog
519 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
520 - Changelog is now in CVS