]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Package additional linker configs for the apple2enh
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.13.0
15 Version: %{version}
16 Release: 1
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
23 %ifos linux
24 BuildRequires: perl
25 BuildRequires: sgml-tools
26 %endif
27 BuildRoot: /var/tmp/%{name}-%{version}
28
29 %description
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the target platform
34 packages in addition to the main package.
35
36 %files
37 %defattr(644,root,root,755)
38 %doc announce.txt
39 %doc doc/BUGS
40 %doc doc/CREDITS
41 %doc doc/readme.1st
42 %attr(755,root,root)            /usr/bin/ar65
43 %attr(755,root,root)            /usr/bin/ca65
44 %attr(755,root,root)            /usr/bin/ca65html
45 %attr(755,root,root)            /usr/bin/cc65
46 %attr(755,root,root)            /usr/bin/cl65
47 %attr(755,root,root)            /usr/bin/co65
48 %attr(755,root,root)            /usr/bin/da65
49 %attr(755,root,root)            /usr/bin/ld65
50 %attr(755,root,root)            /usr/bin/od65
51 %attr(755,root,root) %dir       /usr/lib/cc65
52 %attr(755,root,root) %dir       /usr/lib/cc65/cfg
53 %attr(755,root,root) %dir       /usr/lib/cc65/emd
54 %attr(755,root,root) %dir       /usr/lib/cc65/joy
55 %attr(755,root,root) %dir       /usr/lib/cc65/lib
56 %attr(755,root,root) %dir       /usr/lib/cc65/obj
57 %attr(755,root,root) %dir       /usr/lib/cc65/ser
58 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir       /usr/lib/cc65/include
60 %attr(644,root,root)            /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
62 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
64 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
66 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
67 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
68 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
69 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
70 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
71 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
72 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
73
74
75
76 ###############################################################################
77 #                          Documentation subpackage                           #
78 ###############################################################################
79
80 %package doc
81
82 Requires: %{name} = %{version}
83 License: Freeware
84 Summary: Documentation for the cc65 C compiler
85 Group: Development/Languages
86
87 %description doc
88 This package contains the documentation for the cc65 C compiler, mostly
89 in HTML format. Other formats can be generated from the sources.
90
91 %files doc
92 %doc doc/*.html
93 %doc doc/compile.txt
94 %doc doc/internal.txt
95 %doc doc/newvers.txt
96 %doc samples
97
98
99
100 ###############################################################################
101 #                             Apple ][ subpackage                             #
102 ###############################################################################
103
104 %package apple2
105 Requires: %{name} = %{version}
106 License: Freeware
107 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
109
110 %description apple2
111 This package contains the header files and libraries needed to write
112 programs for the Apple ][ using the cc65 crosscompiler.
113
114 %files apple2
115 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
116 %attr(644,root,root)            /usr/lib/cc65/obj/apple2-*.o
117 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
118 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
119 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
120 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
121 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
122 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2-*.cfg
123
124
125
126 ###############################################################################
127 #                            Apple //e subpackage                             #
128 ###############################################################################
129
130 %package apple2enh
131 Requires: %{name} = %{version}
132 License: Freeware
133 Summary: Apple //e specific libraries and headers for the cc65 compiler.
134 Group: Development/Languages
135
136 %description apple2enh
137 This package contains the header files and libraries needed to write
138 programs for the Apple //e using the cc65 crosscompiler.
139
140 %files apple2enh
141 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
142 %attr(644,root,root)            /usr/lib/cc65/obj/apple2enh-*.o
143 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
144 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
145 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
146 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
147 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
148 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2enh-*.cfg
149
150
151
152 ###############################################################################
153 #                              Atari subpackage                               #
154 ###############################################################################
155
156 %package atari
157 Requires: %{name} = %{version}
158 License: Freeware
159 Summary: Atari specific libraries and headers for the cc65 compiler.
160 Group: Development/Languages
161
162 %description atari
163 This package contains the header files and libraries needed to write
164 programs for the 8 bit Atari machines using the cc65 crosscompiler.
165
166 %files atari
167 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
168 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
169
170
171
172 ###############################################################################
173 #                            Oric Atmos subpackage                            #
174 ###############################################################################
175
176 %package atmos
177 Requires: %{name} = %{version}
178 License: Freeware
179 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
180 Group: Development/Languages
181
182 %description atmos
183 This package contains the header files and libraries needed to write
184 programs for the Oric Atmos using the cc65 crosscompiler.
185
186 %files atmos
187 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
188 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
189
190
191
192 ###############################################################################
193 #                               C128 subpackage                               #
194 ###############################################################################
195
196 %package c128
197 Requires: %{name} = %{version}
198 License: Freeware
199 Summary: C128 specific libraries and headers for the cc65 compiler.
200 Group: Development/Languages
201
202 %description c128
203 This package contains the header files and libraries needed to write
204 programs for the Commodore C128 using the cc65 crosscompiler.
205
206 %files c128
207 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
208 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
209 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
210 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
211 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
212 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
213
214
215
216 ###############################################################################
217 #                                C16 subpackage                               #
218 ###############################################################################
219
220 %package c16
221 Requires: %{name} = %{version}
222 License: Freeware
223 Summary: C16/116 specific libraries and headers for the cc65 compiler.
224 Group: Development/Languages
225
226 %description c16
227 This package contains the header files and libraries needed to write
228 programs for the Commodore C16/116 using the cc65 crosscompiler.
229
230 %files c16
231 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
232 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
233 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
234
235
236
237 ###############################################################################
238 #                               C64 subpackage                                #
239 ###############################################################################
240
241 %package c64
242 Requires: %{name} = %{version}
243 License: Freeware
244 Summary: C64 specific libraries and headers for the cc65 compiler.
245 Group: Development/Languages
246
247 %description c64
248 This package contains the header files and libraries needed to write
249 programs for the Commodore C64 using the cc65 crosscompiler.
250
251 %files c64
252 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
253 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
254 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
255 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
256 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
257 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
258 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
259
260
261
262 ###############################################################################
263 #                              CBM510 subpackage                              #
264 ###############################################################################
265
266 %package cbm510
267 Requires: %{name} = %{version}
268 License: Freeware
269 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
270 Group: Development/Languages
271
272 %description cbm510
273 This package contains the header files and libraries needed to write
274 programs for the Commodore CBM 510 (aka P500) using the cc65
275 crosscompiler.
276
277 %files cbm510
278 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
279 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
280 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
281 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
282
283
284
285 ###############################################################################
286 #                              CBM610 subpackage                              #
287 ###############################################################################
288
289 %package cbm610
290 Requires: %{name} = %{version}
291 License: Freeware
292 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
293 Group: Development/Languages
294
295 %description cbm610
296 This package contains the header files and libraries needed to write
297 programs for the Commodore PET-II (CBM600/700) family of computers using
298 the cc65 crosscompiler.
299
300 %files cbm610
301 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
302 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
303 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
304
305
306
307 ###############################################################################
308 #                               GEOS subpackage                               #
309 ###############################################################################
310
311 %package geos
312 Requires: %{name} = %{version}
313 License: Freeware
314 Summary: GEOS specific libraries and headers for the cc65 compiler.
315 Group: Development/Languages
316
317 %description geos
318 This package contains the header files and libraries needed to write
319 GEOS programs for the C64/C128 using the cc65 crosscompiler.
320
321 %files geos
322 %attr(755,root,root)            /usr/bin/grc
323 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
324 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
325 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
326 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
327 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
328 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
329
330
331
332 ###############################################################################
333 #                               Lynx subpackage                               #
334 ###############################################################################
335
336 %package lynx
337 Requires: %{name} = %{version}
338 License: Freeware
339 Summary: Lynx specific libraries and headers for the cc65 compiler.
340 Group: Development/Languages
341
342 %description lynx
343 This package contains the header files and libraries needed to write
344 programs for the Lynx Game Console using the cc65 crosscompiler.
345
346 %files lynx
347 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
348 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
349 %attr(644,root,root)            /usr/lib/cc65/ser/lynx-*.ser
350 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
351
352
353
354 ###############################################################################
355 #                               NES subpackage                                #
356 ###############################################################################
357
358 %package nes
359 Requires: %{name} = %{version}
360 License: Freeware
361 Summary: NES specific libraries and headers for the cc65 compiler.
362 Group: Development/Languages
363
364 %description nes
365 This package contains the header files and libraries needed to write
366 programs for the Nintendo Entertainment System using the cc65
367 crosscompiler.
368
369 %files nes
370 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
371 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
372
373
374
375 ###############################################################################
376 #                               PET subpackage                                #
377 ###############################################################################
378
379 %package pet
380 Requires: %{name} = %{version}
381 License: Freeware
382 Summary: PET specific libraries and headers for the cc65 compiler.
383 Group: Development/Languages
384
385 %description pet
386 This package contains the header files and libraries needed to write
387 programs for the Commodore PET family of computers using the cc65
388 crosscompiler.
389
390 %files pet
391 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
392 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
393
394
395
396 ###############################################################################
397 #                              Plus/4 subpackage                              #
398 ###############################################################################
399
400 %package plus4
401 Requires: %{name} = %{version}
402 License: Freeware
403 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
404 Group: Development/Languages
405
406 %description plus4
407 This package contains the header files and libraries needed to write
408 programs for the Commodore Plus/4 and C16/116 using the cc65
409 crosscompiler.
410
411 %files plus4
412 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
413 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
414 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
415
416
417
418 ###############################################################################
419 #                           Supervision subpackage                            #
420 ###############################################################################
421
422 %package supervision
423 Requires: %{name} = %{version}
424 License: Freeware
425 Summary: Supervision specific libraries and headers for the cc65 compiler.
426 Group: Development/Languages
427
428 %description supervision
429 This package contains the header files and libraries needed to write
430 programs for the Supervision Game console using the cc65 crosscompiler.
431
432 %files supervision
433 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
434 %attr(644,root,root)            /usr/lib/cc65/cfg/supervision-*.cfg
435
436
437
438 ###############################################################################
439 #                              VIC20 subpackage                               #
440 ###############################################################################
441
442 %package vic20
443 Requires: %{name} = %{version}
444 License: Freeware
445 Summary: VIC20 specific libraries and headers for the cc65 compiler.
446 Group: Development/Languages
447
448 %description vic20
449 This package contains the header files and libraries needed to write
450 programs for the Commodore VIC20 using the cc65 crosscompiler.
451
452 %files vic20
453 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
454 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
455 %attr(644,root,root)            /usr/lib/cc65/cfg/vic20-*.cfg
456
457
458
459 ###############################################################################
460 #                                    Build                                    #
461 ###############################################################################
462
463
464
465 %prep
466 %setup -q
467
468
469 %build
470 # Binaries
471 make -C src -f make/gcc.mak
472 # Libraries
473 make -C libsrc -s zap all
474 # Documentation
475 make -C doc html
476
477
478 %install
479 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,obj,ser,tgi}}
480
481 # Binaries
482 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
483 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
484 install    -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
492
493 # Libraries and includes
494 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
495 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
496 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
497 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
498 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
499 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
500 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
501 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
502 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
503
504 # Extra object files
505 for extra in libsrc/*-*.o; do
506     install -m 644 ${extra} $RPM_BUILD_ROOT/usr/lib/cc65/obj
507 done
508
509 # Additional linker configurations
510 for config in src/ld65/cfg/*-*.cfg; do
511     install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
512 done
513
514 # Drivers
515 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
516 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
517 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
518 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
519 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
520
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525
526
527 %changelog
528 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
529 - Changelog is now in CVS