]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Create a separate doc subpackage
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
57 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
58 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
59 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
60 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
61
62
63
64 ###############################################################################
65 #                          Documentation subpackage                           #
66 ###############################################################################
67
68 %package doc
69
70 Requires: %{name} = %{version}
71 Copyright: Freeware
72 Summary: Documentation for the cc65 C compiler
73 Group: Development/Languages
74
75 %description doc
76 This package contains the documentation for the cc65 C compiler, mostly
77 in HTML format. Other formats can be generated from the sources.
78
79 %files doc
80 %doc doc/*.html
81 %doc doc/compile.txt
82 %doc doc/grc.txt
83 %doc doc/internal.txt
84 %doc doc/newvers.txt
85 %doc samples
86 %doc src/ld65/cfg/*.cfg
87
88
89
90 ###############################################################################
91 #                             Apple ][ subpackage                             #
92 ###############################################################################
93
94 %package apple2
95 Requires: %{name} = %{version}
96 Copyright: Freeware
97 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
98 Group: Development/Languages
99
100 %description apple2
101 This package contains the header files and libraries needed to write
102 programs for the Apple ][ using the cc65 crosscompiler.
103
104 %files apple2
105 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
106 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
107 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
108
109
110
111 ###############################################################################
112 #                              Atari subpackage                               #
113 ###############################################################################
114
115 %package atari
116 Requires: %{name} = %{version}
117 Copyright: Freeware
118 Summary: Atari specific libraries and headers for the cc65 compiler.
119 Group: Development/Languages
120
121 %description atari
122 This package contains the header files and libraries needed to write
123 programs for the 8 bit Atari machines using the cc65 crosscompiler.
124
125 %files atari
126 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
127 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
128
129
130
131 ###############################################################################
132 #                            Oric Atmos subpackage                            #
133 ###############################################################################
134
135 %package atmos
136 Requires: %{name} = %{version}
137 Copyright: Freeware
138 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
139 Group: Development/Languages
140
141 %description atmos
142 This package contains the header files and libraries needed to write
143 programs for the Oric Atmos using the cc65 crosscompiler.
144
145 %files atmos
146 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
147 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
148
149
150
151 ###############################################################################
152 #                               C128 subpackage                               #
153 ###############################################################################
154
155 %package c128
156 Requires: %{name} = %{version}
157 Copyright: Freeware
158 Summary: C128 specific libraries and headers for the cc65 compiler.
159 Group: Development/Languages
160
161 %description c128
162 This package contains the header files and libraries needed to write
163 programs for the Commodore C128 using the cc65 crosscompiler.
164
165 %files c128
166 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
167 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
168 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
169 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
170 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
171
172
173
174 ###############################################################################
175 #                                C16 subpackage                               #
176 ###############################################################################
177
178 %package c16
179 Requires: %{name} = %{version}
180 Copyright: Freeware
181 Summary: C16/116 specific libraries and headers for the cc65 compiler.
182 Group: Development/Languages
183
184 %description c16
185 This package contains the header files and libraries needed to write
186 programs for the Commodore C16/116 using the cc65 crosscompiler.
187
188 %files c16
189 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
190 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
191 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
192
193
194
195 ###############################################################################
196 #                               C64 subpackage                                #
197 ###############################################################################
198
199 %package c64
200 Requires: %{name} = %{version}
201 Copyright: Freeware
202 Summary: C64 specific libraries and headers for the cc65 compiler.
203 Group: Development/Languages
204
205 %description c64
206 This package contains the header files and libraries needed to write
207 programs for the Commodore C64 using the cc65 crosscompiler.
208
209 %files c64
210 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
211 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
212 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
213 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
214 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
215
216
217
218 ###############################################################################
219 #                              CBM510 subpackage                              #
220 ###############################################################################
221
222 %package cbm510
223 Requires: %{name} = %{version}
224 Copyright: Freeware
225 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
226 Group: Development/Languages
227
228 %description cbm510
229 This package contains the header files and libraries needed to write
230 programs for the Commodore CBM 510 (aka P500) using the cc65
231 crosscompiler.
232
233 %files cbm510
234 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
235 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
236
237
238
239 ###############################################################################
240 #                              CBM610 subpackage                              #
241 ###############################################################################
242
243 %package cbm610
244 Requires: %{name} = %{version}
245 Copyright: Freeware
246 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
247 Group: Development/Languages
248
249 %description cbm610
250 This package contains the header files and libraries needed to write
251 programs for the Commodore PET-II (CBM600/700) family of computers using
252 the cc65 crosscompiler.
253
254 %files cbm610
255 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
256 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
257
258
259
260 ###############################################################################
261 #                               GEOS subpackage                               #
262 ###############################################################################
263
264 %package geos
265 Requires: %{name} = %{version}
266 Copyright: Freeware
267 Summary: GEOS specific libraries and headers for the cc65 compiler.
268 Group: Development/Languages
269
270 %description geos
271 This package contains the header files and libraries needed to write
272 GEOS programs for the C64/C128 using the cc65 crosscompiler.
273
274 %files geos
275 %attr(755,root,root)            /usr/bin/grc
276 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
277 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
278 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
279 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
280
281
282
283 ###############################################################################
284 #                               NES subpackage                                #
285 ###############################################################################
286
287 %package nes
288 Requires: %{name} = %{version}
289 Copyright: Freeware
290 Summary: NES specific libraries and headers for the cc65 compiler.
291 Group: Development/Languages
292
293 %description nes
294 This package contains the header files and libraries needed to write
295 programs for the Nintendo Entertainment System using the cc65
296 crosscompiler.
297
298 %files nes
299 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
300 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
301
302
303
304 ###############################################################################
305 #                               PET subpackage                                #
306 ###############################################################################
307
308 %package pet
309 Requires: %{name} = %{version}
310 Copyright: Freeware
311 Summary: PET specific libraries and headers for the cc65 compiler.
312 Group: Development/Languages
313
314 %description pet
315 This package contains the header files and libraries needed to write
316 programs for the Commodore PET family of computers using the cc65
317 crosscompiler.
318
319 %files pet
320 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
321 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
322
323
324
325 ###############################################################################
326 #                              Plus/4 subpackage                              #
327 ###############################################################################
328
329 %package plus4
330 Requires: %{name} = %{version}
331 Copyright: Freeware
332 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
333 Group: Development/Languages
334
335 %description plus4
336 This package contains the header files and libraries needed to write
337 programs for the Commodore Plus/4 and C16/116 using the cc65
338 crosscompiler.
339
340 %files plus4
341 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
342 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
343 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
344
345
346
347 ###############################################################################
348 #                           Supervision subpackage                            #
349 ###############################################################################
350
351 %package supervision
352 Requires: %{name} = %{version}
353 Copyright: Freeware
354 Summary: Supervision specific libraries and headers for the cc65 compiler.
355 Group: Development/Languages
356
357 %description supervision
358 This package contains the header files and libraries needed to write
359 programs for the Supervision Game console using the cc65 crosscompiler.
360
361 %files supervision
362 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
363 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
364
365
366
367 ###############################################################################
368 #                              VIC20 subpackage                               #
369 ###############################################################################
370
371 %package vic20
372 Requires: %{name} = %{version}
373 Copyright: Freeware
374 Summary: VIC20 specific libraries and headers for the cc65 compiler.
375 Group: Development/Languages
376
377 %description vic20
378 This package contains the header files and libraries needed to write
379 programs for the Commodore VIC20 using the cc65 crosscompiler.
380
381 %files vic20
382 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
383 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
384 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
385
386
387
388 ###############################################################################
389 #                                    Build                                    #
390 ###############################################################################
391
392
393
394 %prep
395 %setup -q
396
397
398 %build
399 # Binaries
400 make -C src -f make/gcc.mak
401 # Libraries
402 make -C libsrc -s zap all
403 # Documentation
404 make -C doc html
405
406
407 %install
408 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,tgi}}
409
410 # Binaries
411 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
412 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
413 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
414 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
415 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
416 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
417 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
418 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
419 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
420 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
421 # Libraries and includes
422 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
423 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
424 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
425 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
426 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
427 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
428 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
429 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
430
431 # Drivers
432 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
433 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
434 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
435
436
437 %clean
438 rm -rf $RPM_BUILD_ROOT
439
440
441
442 %changelog
443 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
444 - Move documentation into a separate doc package.
445
446 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
447 - Added the Supervision subpackage.
448
449 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
450 - Better cleanup.
451
452 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
453 - Added subdirectories of include/
454
455 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
456 - The Apple ][ has a joystick driver.
457 - Added the NES subpackage.
458
459 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
460 Added a subpackage for the Oric Atmos.
461
462 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
463 Added the object file conversion utility co65.
464
465 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
466 Updated the version number.
467
468 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
469 Changed location of TGI drivers, added EM drivers.
470
471 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
472 Added the C16 subpackage.
473
474 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
475 Added TGI stuff.
476
477 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
478 Update to version 2.8.0 of the compiler package.
479
480 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
481 Update to version 2.7.1 of the compiler package.
482
483 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
484 Update to version 2.7.0 of the compiler package.
485
486 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
487 Update to version 2.6.2 of the compiler package.
488
489 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
490 Update to version 2.6.1 of the compiler package.
491
492 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
493 Update for cc65 2.6.0 and RedHat 7.x
494
495 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
496 The GEOS include files were not installed, remove headegen.sh
497
498 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
499 Update to version 2.5.0 of the compiler package.
500
501 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
502 Update to version 2.4.1 of the compiler package.
503
504 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
505 Update to version 2.4.0 of the compiler package.
506
507 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
508 Update to version 2.3.1 of the compiler package.
509
510 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
511 Update to version 2.3.0 of the compiler package.
512
513 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
514 [2.2.1-2]
515 - changed to allow build as plain user
516 - `samples' are part of documentation, not part of library
517