]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Add the apple extra files to the apple2 rpm package.
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.13.0
15 Version: %{version}
16 Release: 1
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
23 %ifos linux
24 BuildRequires: perl
25 BuildRequires: sgml-tools
26 %endif
27 BuildRoot: /var/tmp/%{name}-%{version}
28
29 %description
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the target platform
34 packages in addition to the main package.
35
36 %files
37 %defattr(644,root,root,755)
38 %doc announce.txt
39 %doc doc/BUGS
40 %doc doc/CREDITS
41 %doc doc/readme.1st
42 %attr(755,root,root)            /usr/bin/ar65
43 %attr(755,root,root)            /usr/bin/ca65
44 %attr(755,root,root)            /usr/bin/ca65html
45 %attr(755,root,root)            /usr/bin/cc65
46 %attr(755,root,root)            /usr/bin/cl65
47 %attr(755,root,root)            /usr/bin/co65
48 %attr(755,root,root)            /usr/bin/da65
49 %attr(755,root,root)            /usr/bin/ld65
50 %attr(755,root,root)            /usr/bin/od65
51 %attr(755,root,root) %dir       /usr/lib/cc65
52 %attr(755,root,root) %dir       /usr/lib/cc65/cfg
53 %attr(755,root,root) %dir       /usr/lib/cc65/emd
54 %attr(755,root,root) %dir       /usr/lib/cc65/joy
55 %attr(755,root,root) %dir       /usr/lib/cc65/lib
56 %attr(755,root,root) %dir       /usr/lib/cc65/obj
57 %attr(755,root,root) %dir       /usr/lib/cc65/ser
58 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir       /usr/lib/cc65/include
60 %attr(644,root,root)            /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
62 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
64 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
66 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
67 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
68 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
69 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
70 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
71 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
72 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
73
74
75
76 ###############################################################################
77 #                          Documentation subpackage                           #
78 ###############################################################################
79
80 %package doc
81
82 Requires: %{name} = %{version}
83 License: Freeware
84 Summary: Documentation for the cc65 C compiler
85 Group: Development/Languages
86
87 %description doc
88 This package contains the documentation for the cc65 C compiler, mostly
89 in HTML format. Other formats can be generated from the sources.
90
91 %files doc
92 %doc doc/*.html
93 %doc doc/compile.txt
94 %doc doc/internal.txt
95 %doc doc/newvers.txt
96 %doc samples
97
98
99
100 ###############################################################################
101 #                             Apple ][ subpackage                             #
102 ###############################################################################
103
104 %package apple2
105 Requires: %{name} = %{version}
106 License: Freeware
107 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
109
110 %description apple2
111 This package contains the header files and libraries needed to write
112 programs for the Apple ][ using the cc65 crosscompiler.
113
114 %files apple2
115 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
116 %attr(644,root,root)            /usr/lib/cc65/obj/apple2-*.o
117 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
118 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
119 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
120 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
121 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
122 %attr(644,root,root)            /usr/lib/cc65/cfg/apple2-*.cfg
123
124
125
126 ###############################################################################
127 #                            Apple //e subpackage                             #
128 ###############################################################################
129
130 %package apple2enh
131 Requires: %{name} = %{version}
132 License: Freeware
133 Summary: Apple //e specific libraries and headers for the cc65 compiler.
134 Group: Development/Languages
135
136 %description apple2enh
137 This package contains the header files and libraries needed to write
138 programs for the Apple //e using the cc65 crosscompiler.
139
140 %files apple2enh
141 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
142 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
143 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
144 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
145 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
146 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
147
148
149
150 ###############################################################################
151 #                              Atari subpackage                               #
152 ###############################################################################
153
154 %package atari
155 Requires: %{name} = %{version}
156 License: Freeware
157 Summary: Atari specific libraries and headers for the cc65 compiler.
158 Group: Development/Languages
159
160 %description atari
161 This package contains the header files and libraries needed to write
162 programs for the 8 bit Atari machines using the cc65 crosscompiler.
163
164 %files atari
165 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
166 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
167
168
169
170 ###############################################################################
171 #                            Oric Atmos subpackage                            #
172 ###############################################################################
173
174 %package atmos
175 Requires: %{name} = %{version}
176 License: Freeware
177 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
178 Group: Development/Languages
179
180 %description atmos
181 This package contains the header files and libraries needed to write
182 programs for the Oric Atmos using the cc65 crosscompiler.
183
184 %files atmos
185 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
186 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
187
188
189
190 ###############################################################################
191 #                               C128 subpackage                               #
192 ###############################################################################
193
194 %package c128
195 Requires: %{name} = %{version}
196 License: Freeware
197 Summary: C128 specific libraries and headers for the cc65 compiler.
198 Group: Development/Languages
199
200 %description c128
201 This package contains the header files and libraries needed to write
202 programs for the Commodore C128 using the cc65 crosscompiler.
203
204 %files c128
205 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
206 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
207 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
208 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
209 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
210 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
211
212
213
214 ###############################################################################
215 #                                C16 subpackage                               #
216 ###############################################################################
217
218 %package c16
219 Requires: %{name} = %{version}
220 License: Freeware
221 Summary: C16/116 specific libraries and headers for the cc65 compiler.
222 Group: Development/Languages
223
224 %description c16
225 This package contains the header files and libraries needed to write
226 programs for the Commodore C16/116 using the cc65 crosscompiler.
227
228 %files c16
229 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
230 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
231 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
232
233
234
235 ###############################################################################
236 #                               C64 subpackage                                #
237 ###############################################################################
238
239 %package c64
240 Requires: %{name} = %{version}
241 License: Freeware
242 Summary: C64 specific libraries and headers for the cc65 compiler.
243 Group: Development/Languages
244
245 %description c64
246 This package contains the header files and libraries needed to write
247 programs for the Commodore C64 using the cc65 crosscompiler.
248
249 %files c64
250 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
251 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
252 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
253 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
254 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
255 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
256 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
257
258
259
260 ###############################################################################
261 #                              CBM510 subpackage                              #
262 ###############################################################################
263
264 %package cbm510
265 Requires: %{name} = %{version}
266 License: Freeware
267 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
268 Group: Development/Languages
269
270 %description cbm510
271 This package contains the header files and libraries needed to write
272 programs for the Commodore CBM 510 (aka P500) using the cc65
273 crosscompiler.
274
275 %files cbm510
276 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
277 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
278 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
279 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
280
281
282
283 ###############################################################################
284 #                              CBM610 subpackage                              #
285 ###############################################################################
286
287 %package cbm610
288 Requires: %{name} = %{version}
289 License: Freeware
290 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
291 Group: Development/Languages
292
293 %description cbm610
294 This package contains the header files and libraries needed to write
295 programs for the Commodore PET-II (CBM600/700) family of computers using
296 the cc65 crosscompiler.
297
298 %files cbm610
299 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
300 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
301 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
302
303
304
305 ###############################################################################
306 #                               GEOS subpackage                               #
307 ###############################################################################
308
309 %package geos
310 Requires: %{name} = %{version}
311 License: Freeware
312 Summary: GEOS specific libraries and headers for the cc65 compiler.
313 Group: Development/Languages
314
315 %description geos
316 This package contains the header files and libraries needed to write
317 GEOS programs for the C64/C128 using the cc65 crosscompiler.
318
319 %files geos
320 %attr(755,root,root)            /usr/bin/grc
321 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
322 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
323 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
324 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
325 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
326 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
327
328
329
330 ###############################################################################
331 #                               Lynx subpackage                               #
332 ###############################################################################
333
334 %package lynx
335 Requires: %{name} = %{version}
336 License: Freeware
337 Summary: Lynx specific libraries and headers for the cc65 compiler.
338 Group: Development/Languages
339
340 %description lynx
341 This package contains the header files and libraries needed to write
342 programs for the Lynx Game Console using the cc65 crosscompiler.
343
344 %files lynx
345 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
346 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
347 %attr(644,root,root)            /usr/lib/cc65/ser/lynx-*.ser
348 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
349
350
351
352 ###############################################################################
353 #                               NES subpackage                                #
354 ###############################################################################
355
356 %package nes
357 Requires: %{name} = %{version}
358 License: Freeware
359 Summary: NES specific libraries and headers for the cc65 compiler.
360 Group: Development/Languages
361
362 %description nes
363 This package contains the header files and libraries needed to write
364 programs for the Nintendo Entertainment System using the cc65
365 crosscompiler.
366
367 %files nes
368 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
369 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
370
371
372
373 ###############################################################################
374 #                               PET subpackage                                #
375 ###############################################################################
376
377 %package pet
378 Requires: %{name} = %{version}
379 License: Freeware
380 Summary: PET specific libraries and headers for the cc65 compiler.
381 Group: Development/Languages
382
383 %description pet
384 This package contains the header files and libraries needed to write
385 programs for the Commodore PET family of computers using the cc65
386 crosscompiler.
387
388 %files pet
389 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
390 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
391
392
393
394 ###############################################################################
395 #                              Plus/4 subpackage                              #
396 ###############################################################################
397
398 %package plus4
399 Requires: %{name} = %{version}
400 License: Freeware
401 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
402 Group: Development/Languages
403
404 %description plus4
405 This package contains the header files and libraries needed to write
406 programs for the Commodore Plus/4 and C16/116 using the cc65
407 crosscompiler.
408
409 %files plus4
410 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
411 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
412 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
413
414
415
416 ###############################################################################
417 #                           Supervision subpackage                            #
418 ###############################################################################
419
420 %package supervision
421 Requires: %{name} = %{version}
422 License: Freeware
423 Summary: Supervision specific libraries and headers for the cc65 compiler.
424 Group: Development/Languages
425
426 %description supervision
427 This package contains the header files and libraries needed to write
428 programs for the Supervision Game console using the cc65 crosscompiler.
429
430 %files supervision
431 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
432 %attr(644,root,root)            /usr/lib/cc65/cfg/supervision-*.cfg
433
434
435
436 ###############################################################################
437 #                              VIC20 subpackage                               #
438 ###############################################################################
439
440 %package vic20
441 Requires: %{name} = %{version}
442 License: Freeware
443 Summary: VIC20 specific libraries and headers for the cc65 compiler.
444 Group: Development/Languages
445
446 %description vic20
447 This package contains the header files and libraries needed to write
448 programs for the Commodore VIC20 using the cc65 crosscompiler.
449
450 %files vic20
451 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
452 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
453 %attr(644,root,root)            /usr/lib/cc65/cfg/vic20-*.cfg
454
455
456
457 ###############################################################################
458 #                                    Build                                    #
459 ###############################################################################
460
461
462
463 %prep
464 %setup -q
465
466
467 %build
468 # Binaries
469 make -C src -f make/gcc.mak
470 # Libraries
471 make -C libsrc -s zap all
472 # Documentation
473 make -C doc html
474
475
476 %install
477 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,obj,ser,tgi}}
478
479 # Binaries
480 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
481 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
482 install    -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
483 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
490
491 # Libraries and includes
492 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
493 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
494 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
495 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
496 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
497 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
498 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
499 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
500 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
501
502 # Extra object files
503 for extra in libsrc/*-*.o; do
504     install -m 644 ${extra} $RPM_BUILD_ROOT/usr/lib/cc65/obj
505 done
506
507 # Additional linker configurations
508 for config in src/ld65/cfg/*-*.cfg; do
509     install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
510 done
511
512 # Drivers
513 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
514 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
515 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
516 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
517 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
518
519
520 %clean
521 rm -rf $RPM_BUILD_ROOT
522
523
524
525 %changelog
526 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
527 - Changelog is now in CVS