]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Renamed the apple2 tgi drivers
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
113 %attr(644,root,root)            /usr/lib/cc65/tgi/a2-*.tgi
114
115
116
117 ###############################################################################
118 #                              Atari subpackage                               #
119 ###############################################################################
120
121 %package atari
122 Requires: %{name} = %{version}
123 Copyright: Freeware
124 Summary: Atari specific libraries and headers for the cc65 compiler.
125 Group: Development/Languages
126
127 %description atari
128 This package contains the header files and libraries needed to write
129 programs for the 8 bit Atari machines using the cc65 crosscompiler.
130
131 %files atari
132 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
133 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
134
135
136
137 ###############################################################################
138 #                            Oric Atmos subpackage                            #
139 ###############################################################################
140
141 %package atmos
142 Requires: %{name} = %{version}
143 Copyright: Freeware
144 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
145 Group: Development/Languages
146
147 %description atmos
148 This package contains the header files and libraries needed to write
149 programs for the Oric Atmos using the cc65 crosscompiler.
150
151 %files atmos
152 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
153 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
154
155
156
157 ###############################################################################
158 #                               C128 subpackage                               #
159 ###############################################################################
160
161 %package c128
162 Requires: %{name} = %{version}
163 Copyright: Freeware
164 Summary: C128 specific libraries and headers for the cc65 compiler.
165 Group: Development/Languages
166
167 %description c128
168 This package contains the header files and libraries needed to write
169 programs for the Commodore C128 using the cc65 crosscompiler.
170
171 %files c128
172 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
173 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
174 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
175 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
176 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
177
178
179
180 ###############################################################################
181 #                                C16 subpackage                               #
182 ###############################################################################
183
184 %package c16
185 Requires: %{name} = %{version}
186 Copyright: Freeware
187 Summary: C16/116 specific libraries and headers for the cc65 compiler.
188 Group: Development/Languages
189
190 %description c16
191 This package contains the header files and libraries needed to write
192 programs for the Commodore C16/116 using the cc65 crosscompiler.
193
194 %files c16
195 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
196 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
197 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
198
199
200
201 ###############################################################################
202 #                               C64 subpackage                                #
203 ###############################################################################
204
205 %package c64
206 Requires: %{name} = %{version}
207 Copyright: Freeware
208 Summary: C64 specific libraries and headers for the cc65 compiler.
209 Group: Development/Languages
210
211 %description c64
212 This package contains the header files and libraries needed to write
213 programs for the Commodore C64 using the cc65 crosscompiler.
214
215 %files c64
216 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
217 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
218 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
219 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
220 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
221
222
223
224 ###############################################################################
225 #                              CBM510 subpackage                              #
226 ###############################################################################
227
228 %package cbm510
229 Requires: %{name} = %{version}
230 Copyright: Freeware
231 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
232 Group: Development/Languages
233
234 %description cbm510
235 This package contains the header files and libraries needed to write
236 programs for the Commodore CBM 510 (aka P500) using the cc65
237 crosscompiler.
238
239 %files cbm510
240 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
241 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
242 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
243 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
244
245
246
247 ###############################################################################
248 #                              CBM610 subpackage                              #
249 ###############################################################################
250
251 %package cbm610
252 Requires: %{name} = %{version}
253 Copyright: Freeware
254 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
255 Group: Development/Languages
256
257 %description cbm610
258 This package contains the header files and libraries needed to write
259 programs for the Commodore PET-II (CBM600/700) family of computers using
260 the cc65 crosscompiler.
261
262 %files cbm610
263 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
264 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
265 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
266
267
268
269 ###############################################################################
270 #                               GEOS subpackage                               #
271 ###############################################################################
272
273 %package geos
274 Requires: %{name} = %{version}
275 Copyright: Freeware
276 Summary: GEOS specific libraries and headers for the cc65 compiler.
277 Group: Development/Languages
278
279 %description geos
280 This package contains the header files and libraries needed to write
281 GEOS programs for the C64/C128 using the cc65 crosscompiler.
282
283 %files geos
284 %attr(755,root,root)            /usr/bin/grc
285 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
286 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
287 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
288 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
289 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
290 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
291 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
292
293
294
295 ###############################################################################
296 #                               NES subpackage                                #
297 ###############################################################################
298
299 %package nes
300 Requires: %{name} = %{version}
301 Copyright: Freeware
302 Summary: NES specific libraries and headers for the cc65 compiler.
303 Group: Development/Languages
304
305 %description nes
306 This package contains the header files and libraries needed to write
307 programs for the Nintendo Entertainment System using the cc65
308 crosscompiler.
309
310 %files nes
311 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
312 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
313
314
315
316 ###############################################################################
317 #                               PET subpackage                                #
318 ###############################################################################
319
320 %package pet
321 Requires: %{name} = %{version}
322 Copyright: Freeware
323 Summary: PET specific libraries and headers for the cc65 compiler.
324 Group: Development/Languages
325
326 %description pet
327 This package contains the header files and libraries needed to write
328 programs for the Commodore PET family of computers using the cc65
329 crosscompiler.
330
331 %files pet
332 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
333 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
334
335
336
337 ###############################################################################
338 #                              Plus/4 subpackage                              #
339 ###############################################################################
340
341 %package plus4
342 Requires: %{name} = %{version}
343 Copyright: Freeware
344 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
345 Group: Development/Languages
346
347 %description plus4
348 This package contains the header files and libraries needed to write
349 programs for the Commodore Plus/4 and C16/116 using the cc65
350 crosscompiler.
351
352 %files plus4
353 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
354 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
355 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
356
357
358
359 ###############################################################################
360 #                           Supervision subpackage                            #
361 ###############################################################################
362
363 %package supervision
364 Requires: %{name} = %{version}
365 Copyright: Freeware
366 Summary: Supervision specific libraries and headers for the cc65 compiler.
367 Group: Development/Languages
368
369 %description supervision
370 This package contains the header files and libraries needed to write
371 programs for the Supervision Game console using the cc65 crosscompiler.
372
373 %files supervision
374 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
375 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
376
377
378
379 ###############################################################################
380 #                              VIC20 subpackage                               #
381 ###############################################################################
382
383 %package vic20
384 Requires: %{name} = %{version}
385 Copyright: Freeware
386 Summary: VIC20 specific libraries and headers for the cc65 compiler.
387 Group: Development/Languages
388
389 %description vic20
390 This package contains the header files and libraries needed to write
391 programs for the Commodore VIC20 using the cc65 crosscompiler.
392
393 %files vic20
394 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
395 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
396 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
397
398
399
400 ###############################################################################
401 #                                    Build                                    #
402 ###############################################################################
403
404
405
406 %prep
407 %setup -q
408
409
410 %build
411 # Binaries
412 make -C src -f make/gcc.mak
413 # Libraries
414 make -C libsrc -s zap all
415 # Documentation
416 make -C doc html
417
418
419 %install
420 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,tgi}}
421
422 # Binaries
423 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
424 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
425 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
426 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
427 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
428 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
429 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
430 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
431 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
432 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
433 # Libraries and includes
434 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
435 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
436 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
437 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
438 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
439 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
440 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
441 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
442
443 # Drivers
444 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
445 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
446 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
447
448
449 %clean
450 rm -rf $RPM_BUILD_ROOT
451
452
453
454 %changelog
455 * Sun Nov 02 2003 Ullrich von Bassewitz <uz@cc65.org>
456 - Added missing files after upgrade to rpm 4.2
457
458 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
459 - Move documentation into a separate doc package.
460
461 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
462 - Added the Supervision subpackage.
463
464 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
465 - Better cleanup.
466
467 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
468 - Added subdirectories of include/
469
470 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
471 - The Apple ][ has a joystick driver.
472 - Added the NES subpackage.
473
474 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
475 Added a subpackage for the Oric Atmos.
476
477 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
478 Added the object file conversion utility co65.
479
480 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
481 Updated the version number.
482
483 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
484 Changed location of TGI drivers, added EM drivers.
485
486 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
487 Added the C16 subpackage.
488
489 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
490 Added TGI stuff.
491
492 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
493 Update to version 2.8.0 of the compiler package.
494
495 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
496 Update to version 2.7.1 of the compiler package.
497
498 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
499 Update to version 2.7.0 of the compiler package.
500
501 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
502 Update to version 2.6.2 of the compiler package.
503
504 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
505 Update to version 2.6.1 of the compiler package.
506
507 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
508 Update for cc65 2.6.0 and RedHat 7.x
509
510 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
511 The GEOS include files were not installed, remove headegen.sh
512
513 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
514 Update to version 2.5.0 of the compiler package.
515
516 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
517 Update to version 2.4.1 of the compiler package.
518
519 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
520 Update to version 2.4.0 of the compiler package.
521
522 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
523 Update to version 2.3.1 of the compiler package.
524
525 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
526 Update to version 2.3.0 of the compiler package.
527
528 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
529 [2.2.1-2]
530 - changed to allow build as plain user
531 - `samples' are part of documentation, not part of library
532