]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
New mouse directory
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi  
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/grc.txt
90 %doc doc/internal.txt
91 %doc doc/newvers.txt
92 %doc samples
93 %doc src/ld65/cfg/*.cfg
94
95
96
97 ###############################################################################
98 #                             Apple ][ subpackage                             #
99 ###############################################################################
100
101 %package apple2
102 Requires: %{name} = %{version}
103 Copyright: Freeware
104 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
105 Group: Development/Languages
106
107 %description apple2
108 This package contains the header files and libraries needed to write
109 programs for the Apple ][ using the cc65 crosscompiler.
110
111 %files apple2
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
113 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
114 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
115 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117
118
119
120 ###############################################################################
121 #                              Atari subpackage                               #
122 ###############################################################################
123
124 %package atari
125 Requires: %{name} = %{version}
126 Copyright: Freeware
127 Summary: Atari specific libraries and headers for the cc65 compiler.
128 Group: Development/Languages
129
130 %description atari
131 This package contains the header files and libraries needed to write
132 programs for the 8 bit Atari machines using the cc65 crosscompiler.
133
134 %files atari
135 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
136 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
137 %attr(644,root,root)            /usr/lib/cc65/joy/atari-*.joy
138
139
140
141 ###############################################################################
142 #                            Oric Atmos subpackage                            #
143 ###############################################################################
144
145 %package atmos
146 Requires: %{name} = %{version}
147 Copyright: Freeware
148 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
149 Group: Development/Languages
150
151 %description atmos
152 This package contains the header files and libraries needed to write
153 programs for the Oric Atmos using the cc65 crosscompiler.
154
155 %files atmos
156 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
157 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
158
159
160
161 ###############################################################################
162 #                               C128 subpackage                               #
163 ###############################################################################
164
165 %package c128
166 Requires: %{name} = %{version}
167 Copyright: Freeware
168 Summary: C128 specific libraries and headers for the cc65 compiler.
169 Group: Development/Languages
170
171 %description c128
172 This package contains the header files and libraries needed to write
173 programs for the Commodore C128 using the cc65 crosscompiler.
174
175 %files c128
176 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
177 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
178 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
179 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
180 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
181 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
182
183
184
185 ###############################################################################
186 #                                C16 subpackage                               #
187 ###############################################################################
188
189 %package c16
190 Requires: %{name} = %{version}
191 Copyright: Freeware
192 Summary: C16/116 specific libraries and headers for the cc65 compiler.
193 Group: Development/Languages
194
195 %description c16
196 This package contains the header files and libraries needed to write
197 programs for the Commodore C16/116 using the cc65 crosscompiler.
198
199 %files c16
200 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
201 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
202 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
203 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
204
205
206
207 ###############################################################################
208 #                               C64 subpackage                                #
209 ###############################################################################
210
211 %package c64
212 Requires: %{name} = %{version}
213 Copyright: Freeware
214 Summary: C64 specific libraries and headers for the cc65 compiler.
215 Group: Development/Languages
216
217 %description c64
218 This package contains the header files and libraries needed to write
219 programs for the Commodore C64 using the cc65 crosscompiler.
220
221 %files c64
222 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
223 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
224 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
225 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
226 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
227 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
228
229
230
231 ###############################################################################
232 #                              CBM510 subpackage                              #
233 ###############################################################################
234
235 %package cbm510
236 Requires: %{name} = %{version}
237 Copyright: Freeware
238 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
239 Group: Development/Languages
240
241 %description cbm510
242 This package contains the header files and libraries needed to write
243 programs for the Commodore CBM 510 (aka P500) using the cc65
244 crosscompiler.
245
246 %files cbm510
247 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
248 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
249 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
250 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
251 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
252
253
254
255 ###############################################################################
256 #                              CBM610 subpackage                              #
257 ###############################################################################
258
259 %package cbm610
260 Requires: %{name} = %{version}
261 Copyright: Freeware
262 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
263 Group: Development/Languages
264
265 %description cbm610
266 This package contains the header files and libraries needed to write
267 programs for the Commodore PET-II (CBM600/700) family of computers using
268 the cc65 crosscompiler.
269
270 %files cbm610
271 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
272 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
273 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
274 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
275
276
277
278 ###############################################################################
279 #                               GEOS subpackage                               #
280 ###############################################################################
281
282 %package geos
283 Requires: %{name} = %{version}
284 Copyright: Freeware
285 Summary: GEOS specific libraries and headers for the cc65 compiler.
286 Group: Development/Languages
287
288 %description geos
289 This package contains the header files and libraries needed to write
290 GEOS programs for the C64/C128 using the cc65 crosscompiler.
291
292 %files geos
293 %attr(755,root,root)            /usr/bin/grc
294 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
295 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
296 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
297 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
298 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
299 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
300 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
301
302
303
304 ###############################################################################
305 #                               NES subpackage                                #
306 ###############################################################################
307
308 %package nes
309 Requires: %{name} = %{version}
310 Copyright: Freeware
311 Summary: NES specific libraries and headers for the cc65 compiler.
312 Group: Development/Languages
313
314 %description nes
315 This package contains the header files and libraries needed to write
316 programs for the Nintendo Entertainment System using the cc65
317 crosscompiler.
318
319 %files nes
320 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
321 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
322
323
324
325 ###############################################################################
326 #                               PET subpackage                                #
327 ###############################################################################
328
329 %package pet
330 Requires: %{name} = %{version}
331 Copyright: Freeware
332 Summary: PET specific libraries and headers for the cc65 compiler.
333 Group: Development/Languages
334
335 %description pet
336 This package contains the header files and libraries needed to write
337 programs for the Commodore PET family of computers using the cc65
338 crosscompiler.
339
340 %files pet
341 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
342 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
343
344
345
346 ###############################################################################
347 #                              Plus/4 subpackage                              #
348 ###############################################################################
349
350 %package plus4
351 Requires: %{name} = %{version}
352 Copyright: Freeware
353 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
354 Group: Development/Languages
355
356 %description plus4
357 This package contains the header files and libraries needed to write
358 programs for the Commodore Plus/4 and C16/116 using the cc65
359 crosscompiler.
360
361 %files plus4
362 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
363 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
364 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
365 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
366
367
368
369 ###############################################################################
370 #                           Supervision subpackage                            #
371 ###############################################################################
372
373 %package supervision
374 Requires: %{name} = %{version}
375 Copyright: Freeware
376 Summary: Supervision specific libraries and headers for the cc65 compiler.
377 Group: Development/Languages
378
379 %description supervision
380 This package contains the header files and libraries needed to write
381 programs for the Supervision Game console using the cc65 crosscompiler.
382
383 %files supervision
384 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
385 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
386
387
388
389 ###############################################################################
390 #                              VIC20 subpackage                               #
391 ###############################################################################
392
393 %package vic20
394 Requires: %{name} = %{version}
395 Copyright: Freeware
396 Summary: VIC20 specific libraries and headers for the cc65 compiler.
397 Group: Development/Languages
398
399 %description vic20
400 This package contains the header files and libraries needed to write
401 programs for the Commodore VIC20 using the cc65 crosscompiler.
402
403 %files vic20
404 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
405 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
406 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
407
408
409
410 ###############################################################################
411 #                                    Build                                    #
412 ###############################################################################
413
414
415
416 %prep
417 %setup -q
418
419
420 %build
421 # Binaries
422 make -C src -f make/gcc.mak
423 # Libraries
424 make -C libsrc -s zap all
425 # Documentation
426 make -C doc html
427
428
429 %install
430 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
431
432 # Binaries
433 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
434 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
435 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
436 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
437 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
438 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
439 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
440 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
441 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
442 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
443 # Libraries and includes
444 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
445 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
446 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
447 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
448 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
449 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
450 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
451 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
452 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
453
454 # Drivers
455 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
456 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
457 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
458 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
459
460
461 %clean
462 rm -rf $RPM_BUILD_ROOT
463
464
465
466 %changelog
467 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
468 - Changelog is now in CVS