2 # SPEC file for the cc65 C compiler and RedHat 7.x
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
7 ###############################################################################
9 ###############################################################################
11 Summary: Crosscompiler/Crossassembler for 6502 systems
14 %define version 2.13.0
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
25 BuildRequires: sgml-tools
27 BuildRoot: /var/tmp/%{name}-%{version}
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the target platform
34 packages in addition to the main package.
37 %defattr(644,root,root,755)
42 %attr(755,root,root) /usr/bin/ar65
43 %attr(755,root,root) /usr/bin/ca65
44 %attr(755,root,root) /usr/bin/ca65html
45 %attr(755,root,root) /usr/bin/cc65
46 %attr(755,root,root) /usr/bin/cl65
47 %attr(755,root,root) /usr/bin/co65
48 %attr(755,root,root) /usr/bin/da65
49 %attr(755,root,root) /usr/bin/ld65
50 %attr(755,root,root) /usr/bin/od65
51 %attr(755,root,root) %dir /usr/lib/cc65
52 %attr(755,root,root) %dir /usr/lib/cc65/cfg
53 %attr(755,root,root) %dir /usr/lib/cc65/emd
54 %attr(755,root,root) %dir /usr/lib/cc65/joy
55 %attr(755,root,root) %dir /usr/lib/cc65/lib
56 %attr(755,root,root) %dir /usr/lib/cc65/obj
57 %attr(755,root,root) %dir /usr/lib/cc65/ser
58 %attr(755,root,root) %dir /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir /usr/lib/cc65/include
60 %attr(644,root,root) /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir /usr/lib/cc65/include/em
62 %attr(644,root,root) /usr/lib/cc65/include/em/*.h
63 %attr(755,root,root) %dir /usr/lib/cc65/include/joystick
64 %attr(644,root,root) /usr/lib/cc65/include/joystick/*.h
65 %attr(755,root,root) %dir /usr/lib/cc65/include/mouse
66 %attr(644,root,root) /usr/lib/cc65/include/mouse/*.h
67 %attr(755,root,root) %dir /usr/lib/cc65/include/sys
68 %attr(644,root,root) /usr/lib/cc65/include/sys/*.h
69 %attr(755,root,root) %dir /usr/lib/cc65/include/tgi
70 %attr(644,root,root) /usr/lib/cc65/include/tgi/*.h
71 %attr(755,root,root) %dir /usr/lib/cc65/asminc
72 %attr(644,root,root) /usr/lib/cc65/asminc/*.inc
76 ###############################################################################
77 # Documentation subpackage #
78 ###############################################################################
82 Requires: %{name} = %{version}
84 Summary: Documentation for the cc65 C compiler
85 Group: Development/Languages
88 This package contains the documentation for the cc65 C compiler, mostly
89 in HTML format. Other formats can be generated from the sources.
100 ###############################################################################
101 # Apple ][ subpackage #
102 ###############################################################################
105 Requires: %{name} = %{version}
107 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
111 This package contains the header files and libraries needed to write
112 programs for the Apple ][ using the cc65 crosscompiler.
115 %attr(644,root,root) /usr/lib/cc65/lib/apple2.lib
116 %attr(644,root,root) /usr/lib/cc65/obj/apple2-*.o
117 %attr(644,root,root) /usr/lib/cc65/emd/a2.*.emd
118 %attr(644,root,root) /usr/lib/cc65/joy/a2.*.joy
119 %attr(644,root,root) /usr/lib/cc65/mou/a2.*.mou
120 %attr(644,root,root) /usr/lib/cc65/ser/a2.*.ser
121 %attr(644,root,root) /usr/lib/cc65/tgi/a2.*.tgi
122 %attr(644,root,root) /usr/lib/cc65/cfg/apple2-*.cfg
126 ###############################################################################
127 # Apple //e subpackage #
128 ###############################################################################
131 Requires: %{name} = %{version}
133 Summary: Apple //e specific libraries and headers for the cc65 compiler.
134 Group: Development/Languages
136 %description apple2enh
137 This package contains the header files and libraries needed to write
138 programs for the Apple //e using the cc65 crosscompiler.
141 %attr(644,root,root) /usr/lib/cc65/lib/apple2enh.lib
142 %attr(644,root,root) /usr/lib/cc65/emd/a2e.*.emd
143 %attr(644,root,root) /usr/lib/cc65/joy/a2e.*.joy
144 %attr(644,root,root) /usr/lib/cc65/mou/a2e.*.mou
145 %attr(644,root,root) /usr/lib/cc65/ser/a2e.*.ser
146 %attr(644,root,root) /usr/lib/cc65/tgi/a2e.*.tgi
150 ###############################################################################
152 ###############################################################################
155 Requires: %{name} = %{version}
157 Summary: Atari specific libraries and headers for the cc65 compiler.
158 Group: Development/Languages
161 This package contains the header files and libraries needed to write
162 programs for the 8 bit Atari machines using the cc65 crosscompiler.
165 %attr(644,root,root) /usr/lib/cc65/lib/atari.lib
166 %attr(644,root,root) /usr/lib/cc65/joy/atari*.joy
170 ###############################################################################
171 # Oric Atmos subpackage #
172 ###############################################################################
175 Requires: %{name} = %{version}
177 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
178 Group: Development/Languages
181 This package contains the header files and libraries needed to write
182 programs for the Oric Atmos using the cc65 crosscompiler.
185 %attr(644,root,root) /usr/lib/cc65/lib/atmos.lib
186 %attr(644,root,root) /usr/lib/cc65/tgi/atmos-*.tgi
190 ###############################################################################
192 ###############################################################################
195 Requires: %{name} = %{version}
197 Summary: C128 specific libraries and headers for the cc65 compiler.
198 Group: Development/Languages
201 This package contains the header files and libraries needed to write
202 programs for the Commodore C128 using the cc65 crosscompiler.
205 %attr(644,root,root) /usr/lib/cc65/lib/c128.lib
206 %attr(644,root,root) /usr/lib/cc65/emd/c128-*.emd
207 %attr(644,root,root) /usr/lib/cc65/joy/c128-*.joy
208 %attr(644,root,root) /usr/lib/cc65/mou/c128-*.mou
209 %attr(644,root,root) /usr/lib/cc65/ser/c128-*.ser
210 %attr(644,root,root) /usr/lib/cc65/tgi/c128-*.tgi
214 ###############################################################################
216 ###############################################################################
219 Requires: %{name} = %{version}
221 Summary: C16/116 specific libraries and headers for the cc65 compiler.
222 Group: Development/Languages
225 This package contains the header files and libraries needed to write
226 programs for the Commodore C16/116 using the cc65 crosscompiler.
229 %attr(644,root,root) /usr/lib/cc65/lib/c16.lib
230 %attr(644,root,root) /usr/lib/cc65/emd/c16-*.emd
231 %attr(644,root,root) /usr/lib/cc65/joy/c16-*.joy
235 ###############################################################################
237 ###############################################################################
240 Requires: %{name} = %{version}
242 Summary: C64 specific libraries and headers for the cc65 compiler.
243 Group: Development/Languages
246 This package contains the header files and libraries needed to write
247 programs for the Commodore C64 using the cc65 crosscompiler.
250 %attr(644,root,root) /usr/lib/cc65/lib/c64.lib
251 %attr(644,root,root) /usr/lib/cc65/emd/dtv-*.emd
252 %attr(644,root,root) /usr/lib/cc65/emd/c64-*.emd
253 %attr(644,root,root) /usr/lib/cc65/joy/c64-*.joy
254 %attr(644,root,root) /usr/lib/cc65/mou/c64-*.mou
255 %attr(644,root,root) /usr/lib/cc65/ser/c64-*.ser
256 %attr(644,root,root) /usr/lib/cc65/tgi/c64-*.tgi
260 ###############################################################################
261 # CBM510 subpackage #
262 ###############################################################################
265 Requires: %{name} = %{version}
267 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
268 Group: Development/Languages
271 This package contains the header files and libraries needed to write
272 programs for the Commodore CBM 510 (aka P500) using the cc65
276 %attr(644,root,root) /usr/lib/cc65/lib/cbm510.lib
277 %attr(644,root,root) /usr/lib/cc65/emd/cbm510-*.emd
278 %attr(644,root,root) /usr/lib/cc65/joy/cbm510-*.joy
279 %attr(644,root,root) /usr/lib/cc65/ser/cbm510-*.ser
283 ###############################################################################
284 # CBM610 subpackage #
285 ###############################################################################
288 Requires: %{name} = %{version}
290 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
291 Group: Development/Languages
294 This package contains the header files and libraries needed to write
295 programs for the Commodore PET-II (CBM600/700) family of computers using
296 the cc65 crosscompiler.
299 %attr(644,root,root) /usr/lib/cc65/lib/cbm610.lib
300 %attr(644,root,root) /usr/lib/cc65/emd/cbm610-*.emd
301 %attr(644,root,root) /usr/lib/cc65/ser/cbm610-*.ser
305 ###############################################################################
307 ###############################################################################
310 Requires: %{name} = %{version}
312 Summary: GEOS specific libraries and headers for the cc65 compiler.
313 Group: Development/Languages
316 This package contains the header files and libraries needed to write
317 GEOS programs for the C64/C128 using the cc65 crosscompiler.
320 %attr(755,root,root) /usr/bin/grc
321 %attr(644,root,root) /usr/lib/cc65/lib/geos.lib
322 %attr(755,root,root) %dir /usr/lib/cc65/include/geos
323 %attr(644,root,root) /usr/lib/cc65/include/geos/*.h
324 %attr(644,root,root) /usr/lib/cc65/emd/geos-*.emd
325 %attr(644,root,root) /usr/lib/cc65/joy/geos-*.joy
326 %attr(644,root,root) /usr/lib/cc65/tgi/geos-*.tgi
330 ###############################################################################
332 ###############################################################################
335 Requires: %{name} = %{version}
337 Summary: Lynx specific libraries and headers for the cc65 compiler.
338 Group: Development/Languages
341 This package contains the header files and libraries needed to write
342 programs for the Lynx Game Console using the cc65 crosscompiler.
345 %attr(644,root,root) /usr/lib/cc65/lib/lynx.lib
346 %attr(644,root,root) /usr/lib/cc65/joy/lynx-*.joy
347 %attr(644,root,root) /usr/lib/cc65/ser/lynx-*.ser
348 %attr(644,root,root) /usr/lib/cc65/tgi/lynx-*.tgi
352 ###############################################################################
354 ###############################################################################
357 Requires: %{name} = %{version}
359 Summary: NES specific libraries and headers for the cc65 compiler.
360 Group: Development/Languages
363 This package contains the header files and libraries needed to write
364 programs for the Nintendo Entertainment System using the cc65
368 %attr(644,root,root) /usr/lib/cc65/lib/nes.lib
369 %attr(644,root,root) /usr/lib/cc65/joy/nes-*.joy
373 ###############################################################################
375 ###############################################################################
378 Requires: %{name} = %{version}
380 Summary: PET specific libraries and headers for the cc65 compiler.
381 Group: Development/Languages
384 This package contains the header files and libraries needed to write
385 programs for the Commodore PET family of computers using the cc65
389 %attr(644,root,root) /usr/lib/cc65/lib/pet.lib
390 %attr(644,root,root) /usr/lib/cc65/joy/pet-*.joy
394 ###############################################################################
395 # Plus/4 subpackage #
396 ###############################################################################
399 Requires: %{name} = %{version}
401 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
402 Group: Development/Languages
405 This package contains the header files and libraries needed to write
406 programs for the Commodore Plus/4 and C16/116 using the cc65
410 %attr(644,root,root) /usr/lib/cc65/lib/plus4.lib
411 %attr(644,root,root) /usr/lib/cc65/joy/plus4-*.joy
412 %attr(644,root,root) /usr/lib/cc65/ser/plus4-*.ser
416 ###############################################################################
417 # Supervision subpackage #
418 ###############################################################################
421 Requires: %{name} = %{version}
423 Summary: Supervision specific libraries and headers for the cc65 compiler.
424 Group: Development/Languages
426 %description supervision
427 This package contains the header files and libraries needed to write
428 programs for the Supervision Game console using the cc65 crosscompiler.
431 %attr(644,root,root) /usr/lib/cc65/lib/supervision.lib
432 %attr(644,root,root) /usr/lib/cc65/cfg/supervision-*.cfg
436 ###############################################################################
438 ###############################################################################
441 Requires: %{name} = %{version}
443 Summary: VIC20 specific libraries and headers for the cc65 compiler.
444 Group: Development/Languages
447 This package contains the header files and libraries needed to write
448 programs for the Commodore VIC20 using the cc65 crosscompiler.
451 %attr(644,root,root) /usr/lib/cc65/lib/vic20.lib
452 %attr(644,root,root) /usr/lib/cc65/joy/vic20-*.joy
453 %attr(644,root,root) /usr/lib/cc65/cfg/vic20-*.cfg
457 ###############################################################################
459 ###############################################################################
469 make -C src -f make/gcc.mak
471 make -C libsrc -s zap all
477 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,obj,ser,tgi}}
480 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
481 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
482 install -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
483 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
485 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
491 # Libraries and includes
492 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
493 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
494 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
495 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
496 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
497 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
498 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
499 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
500 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
503 for extra in libsrc/*-*.o; do
504 install -m 644 ${extra} $RPM_BUILD_ROOT/usr/lib/cc65/obj
507 # Additional linker configurations
508 for config in src/ld65/cfg/*-*.cfg; do
509 install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
513 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
514 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
515 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
516 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
517 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
521 rm -rf $RPM_BUILD_ROOT
526 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
527 - Changelog is now in CVS