]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Fixed a copy&paste error
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.11.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/internal.txt
90 %doc doc/newvers.txt
91 %doc samples
92 %doc src/ld65/cfg/*.cfg
93
94
95
96 ###############################################################################
97 #                             Apple ][ subpackage                             #
98 ###############################################################################
99
100 %package apple2
101 Requires: %{name} = %{version}
102 Copyright: Freeware
103 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
104 Group: Development/Languages
105
106 %description apple2
107 This package contains the header files and libraries needed to write
108 programs for the Apple ][ using the cc65 crosscompiler.
109
110 %files apple2
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
113 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
114 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
115 %attr(644,root,root)            /usr/lib/cc65/mou/a2.*.mou
116 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
117 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
118
119
120
121 ###############################################################################
122 #                            Apple //e subpackage                             #
123 ###############################################################################
124
125 %package apple2enh
126 Requires: %{name} = %{version}
127 Copyright: Freeware
128 Summary: Apple //e specific libraries and headers for the cc65 compiler.
129 Group: Development/Languages
130
131 %description apple2enh
132 This package contains the header files and libraries needed to write
133 programs for the Apple //e using the cc65 crosscompiler.
134
135 %files apple2enh
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
137 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.o
138 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
139 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
140 %attr(644,root,root)            /usr/lib/cc65/mou/a2e.*.mou
141 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
142 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
143
144
145
146 ###############################################################################
147 #                              Atari subpackage                               #
148 ###############################################################################
149
150 %package atari
151 Requires: %{name} = %{version}
152 Copyright: Freeware
153 Summary: Atari specific libraries and headers for the cc65 compiler.
154 Group: Development/Languages
155
156 %description atari
157 This package contains the header files and libraries needed to write
158 programs for the 8 bit Atari machines using the cc65 crosscompiler.
159
160 %files atari
161 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
162 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
163 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
164
165
166
167 ###############################################################################
168 #                            Oric Atmos subpackage                            #
169 ###############################################################################
170
171 %package atmos
172 Requires: %{name} = %{version}
173 Copyright: Freeware
174 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
175 Group: Development/Languages
176
177 %description atmos
178 This package contains the header files and libraries needed to write
179 programs for the Oric Atmos using the cc65 crosscompiler.
180
181 %files atmos
182 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
183 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
184 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
185
186
187
188 ###############################################################################
189 #                               C128 subpackage                               #
190 ###############################################################################
191
192 %package c128
193 Requires: %{name} = %{version}
194 Copyright: Freeware
195 Summary: C128 specific libraries and headers for the cc65 compiler.
196 Group: Development/Languages
197
198 %description c128
199 This package contains the header files and libraries needed to write
200 programs for the Commodore C128 using the cc65 crosscompiler.
201
202 %files c128
203 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
204 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
205 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
206 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
207 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
208 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
209 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
210
211
212
213 ###############################################################################
214 #                                C16 subpackage                               #
215 ###############################################################################
216
217 %package c16
218 Requires: %{name} = %{version}
219 Copyright: Freeware
220 Summary: C16/116 specific libraries and headers for the cc65 compiler.
221 Group: Development/Languages
222
223 %description c16
224 This package contains the header files and libraries needed to write
225 programs for the Commodore C16/116 using the cc65 crosscompiler.
226
227 %files c16
228 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
229 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
230 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
231 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
232
233
234
235 ###############################################################################
236 #                               C64 subpackage                                #
237 ###############################################################################
238
239 %package c64
240 Requires: %{name} = %{version}
241 Copyright: Freeware
242 Summary: C64 specific libraries and headers for the cc65 compiler.
243 Group: Development/Languages
244
245 %description c64
246 This package contains the header files and libraries needed to write
247 programs for the Commodore C64 using the cc65 crosscompiler.
248
249 %files c64
250 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
251 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
252 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
253 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
254 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
255 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
256 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
257 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
258
259
260
261 ###############################################################################
262 #                              CBM510 subpackage                              #
263 ###############################################################################
264
265 %package cbm510
266 Requires: %{name} = %{version}
267 Copyright: Freeware
268 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
269 Group: Development/Languages
270
271 %description cbm510
272 This package contains the header files and libraries needed to write
273 programs for the Commodore CBM 510 (aka P500) using the cc65
274 crosscompiler.
275
276 %files cbm510
277 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
278 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
279 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
280 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
281 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
282
283
284
285 ###############################################################################
286 #                              CBM610 subpackage                              #
287 ###############################################################################
288
289 %package cbm610
290 Requires: %{name} = %{version}
291 Copyright: Freeware
292 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
293 Group: Development/Languages
294
295 %description cbm610
296 This package contains the header files and libraries needed to write
297 programs for the Commodore PET-II (CBM600/700) family of computers using
298 the cc65 crosscompiler.
299
300 %files cbm610
301 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
302 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
303 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
304 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
305
306
307
308 ###############################################################################
309 #                               GEOS subpackage                               #
310 ###############################################################################
311
312 %package geos
313 Requires: %{name} = %{version}
314 Copyright: Freeware
315 Summary: GEOS specific libraries and headers for the cc65 compiler.
316 Group: Development/Languages
317
318 %description geos
319 This package contains the header files and libraries needed to write
320 GEOS programs for the C64/C128 using the cc65 crosscompiler.
321
322 %files geos
323 %attr(755,root,root)            /usr/bin/grc
324 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
325 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
326 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
327 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
328 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
329 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
330 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
331
332
333
334 ###############################################################################
335 #                               Lynx subpackage                               #
336 ###############################################################################
337
338 %package lynx
339 Requires: %{name} = %{version}
340 Copyright: Freeware
341 Summary: Lynx specific libraries and headers for the cc65 compiler.
342 Group: Development/Languages
343
344 %description lynx
345 This package contains the header files and libraries needed to write
346 programs for the Lynx Game Console using the cc65 crosscompiler.
347
348 %files lynx
349 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
350 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.o
351 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
352 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
353
354
355
356 ###############################################################################
357 #                               NES subpackage                                #
358 ###############################################################################
359
360 %package nes
361 Requires: %{name} = %{version}
362 Copyright: Freeware
363 Summary: NES specific libraries and headers for the cc65 compiler.
364 Group: Development/Languages
365
366 %description nes
367 This package contains the header files and libraries needed to write
368 programs for the Nintendo Entertainment System using the cc65
369 crosscompiler.
370
371 %files nes
372 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
373 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
374 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
375
376
377
378 ###############################################################################
379 #                               PET subpackage                                #
380 ###############################################################################
381
382 %package pet
383 Requires: %{name} = %{version}
384 Copyright: Freeware
385 Summary: PET specific libraries and headers for the cc65 compiler.
386 Group: Development/Languages
387
388 %description pet
389 This package contains the header files and libraries needed to write
390 programs for the Commodore PET family of computers using the cc65
391 crosscompiler.
392
393 %files pet
394 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
395 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
396 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
397
398
399
400 ###############################################################################
401 #                              Plus/4 subpackage                              #
402 ###############################################################################
403
404 %package plus4
405 Requires: %{name} = %{version}
406 Copyright: Freeware
407 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
408 Group: Development/Languages
409
410 %description plus4
411 This package contains the header files and libraries needed to write
412 programs for the Commodore Plus/4 and C16/116 using the cc65
413 crosscompiler.
414
415 %files plus4
416 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
417 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
418 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
419 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
420
421
422
423 ###############################################################################
424 #                           Supervision subpackage                            #
425 ###############################################################################
426
427 %package supervision
428 Requires: %{name} = %{version}
429 Copyright: Freeware
430 Summary: Supervision specific libraries and headers for the cc65 compiler.
431 Group: Development/Languages
432
433 %description supervision
434 This package contains the header files and libraries needed to write
435 programs for the Supervision Game console using the cc65 crosscompiler.
436
437 %files supervision
438 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
439 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
440
441
442
443 ###############################################################################
444 #                              VIC20 subpackage                               #
445 ###############################################################################
446
447 %package vic20
448 Requires: %{name} = %{version}
449 Copyright: Freeware
450 Summary: VIC20 specific libraries and headers for the cc65 compiler.
451 Group: Development/Languages
452
453 %description vic20
454 This package contains the header files and libraries needed to write
455 programs for the Commodore VIC20 using the cc65 crosscompiler.
456
457 %files vic20
458 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
459 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
460 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
461
462
463
464 ###############################################################################
465 #                                    Build                                    #
466 ###############################################################################
467
468
469
470 %prep
471 %setup -q
472
473
474 %build
475 # Binaries
476 make -C src -f make/gcc.mak
477 # Libraries
478 make -C libsrc -s zap all
479 # Documentation
480 make -C doc html
481
482
483 %install
484 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
485
486 # Binaries
487 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
492 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
493 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
494 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
495 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
496 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
497 # Libraries and includes
498 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
499 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
500 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
501 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
502 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
503 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
504 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
505 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
506 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
507
508 # Drivers
509 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
510 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
511 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
512 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
513 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
514
515
516 %clean
517 rm -rf $RPM_BUILD_ROOT
518
519
520
521 %changelog
522 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
523 - Changelog is now in CVS