]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
More joystick drivers
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/da65
52 %attr(755,root,root)            /usr/bin/ld65
53 %attr(755,root,root)            /usr/bin/od65
54 %attr(755,root,root) %dir       /usr/lib/cc65
55 %attr(755,root,root) %dir       /usr/lib/cc65/emd
56 %attr(755,root,root) %dir       /usr/lib/cc65/joy
57 %attr(755,root,root) %dir       /usr/lib/cc65/lib
58 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir       /usr/lib/cc65/include
60 %attr(644,root,root)            /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
62 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
64 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
65
66
67
68 ###############################################################################
69 #                              VIC20 subpackage                               #
70 ###############################################################################
71
72 %package vic20
73 Requires: %{name} = %{version}
74 Copyright: Freeware
75 Summary: VIC20 specific libraries and headers for the cc65 compiler.
76 Group: Development/Languages
77
78 %description vic20
79 This package contains the header files and libraries needed to write
80 programs for the Commodore VIC20 using the cc65 crosscompiler.
81
82 %files vic20
83 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
84 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
85 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
86 %doc src/ld65/cfg/vic20.cfg
87
88
89
90 ###############################################################################
91 #                                C16 subpackage                               #
92 ###############################################################################
93
94 %package c16
95 Requires: %{name} = %{version}
96 Copyright: Freeware
97 Summary: C16/116 specific libraries and headers for the cc65 compiler.
98 Group: Development/Languages
99
100 %description c16
101 This package contains the header files and libraries needed to write
102 programs for the Commodore C16/116 using the cc65 crosscompiler.
103
104 %files c16
105 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
106 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
107 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
108 %doc src/ld65/cfg/c16.cfg
109
110
111
112 ###############################################################################
113 #                               C64 subpackage                                #
114 ###############################################################################
115
116 %package c64
117 Requires: %{name} = %{version}
118 Copyright: Freeware
119 Summary: C64 specific libraries and headers for the cc65 compiler.
120 Group: Development/Languages
121
122 %description c64
123 This package contains the header files and libraries needed to write
124 programs for the Commodore C64 using the cc65 crosscompiler.
125
126 %files c64
127 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
128 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
129 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
130 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
131 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
132 %doc src/ld65/cfg/c64.cfg
133
134
135
136 ###############################################################################
137 #                               C128 subpackage                               #
138 ###############################################################################
139
140 %package c128
141 Requires: %{name} = %{version}
142 Copyright: Freeware
143 Summary: C128 specific libraries and headers for the cc65 compiler.
144 Group: Development/Languages
145
146 %description c128
147 This package contains the header files and libraries needed to write
148 programs for the Commodore C128 using the cc65 crosscompiler.
149
150 %files c128
151 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
152 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
153 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
154 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
155 %doc src/ld65/cfg/c128.cfg
156
157
158
159 ###############################################################################
160 #                              Atari subpackage                               #
161 ###############################################################################
162
163 %package atari
164 Requires: %{name} = %{version}
165 Copyright: Freeware
166 Summary: Atari specific libraries and headers for the cc65 compiler.
167 Group: Development/Languages
168
169 %description atari
170 This package contains the header files and libraries needed to write
171 programs for the 8 bit Atari machines using the cc65 crosscompiler.
172
173 %files atari
174 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
175 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
176 %doc src/ld65/cfg/atari.cfg
177
178
179
180 ###############################################################################
181 #                              Plus/4 subpackage                              #
182 ###############################################################################
183
184 %package plus4
185 Requires: %{name} = %{version}
186 Copyright: Freeware
187 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
188 Group: Development/Languages
189
190 %description plus4
191 This package contains the header files and libraries needed to write
192 programs for the Commodore Plus/4 and C16/116 using the cc65
193 crosscompiler.
194
195 %files plus4
196 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
197 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
198 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
199 %doc src/ld65/cfg/plus4.cfg
200
201
202
203 ###############################################################################
204 #                               PET subpackage                                #
205 ###############################################################################
206
207 %package pet
208 Requires: %{name} = %{version}
209 Copyright: Freeware
210 Summary: PET specific libraries and headers for the cc65 compiler.
211 Group: Development/Languages
212
213 %description pet
214 This package contains the header files and libraries needed to write
215 programs for the Commodore PET family of computers using the cc65
216 crosscompiler.
217
218 %files pet
219 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
220 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
221 %doc src/ld65/cfg/pet.cfg
222
223
224
225 ###############################################################################
226 #                              CBM510 subpackage                              #
227 ###############################################################################
228
229 %package cbm510
230 Requires: %{name} = %{version}
231 Copyright: Freeware
232 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
233 Group: Development/Languages
234
235 %description cbm510
236 This package contains the header files and libraries needed to write
237 programs for the Commodore CBM 510 (aka P500) using the cc65
238 crosscompiler.
239
240 %files cbm510
241 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
242 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
243 %doc src/ld65/cfg/cbm510.cfg
244
245
246
247 ###############################################################################
248 #                              CBM610 subpackage                              #
249 ###############################################################################
250
251 %package cbm610
252 Requires: %{name} = %{version}
253 Copyright: Freeware
254 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
255 Group: Development/Languages
256
257 %description cbm610
258 This package contains the header files and libraries needed to write
259 programs for the Commodore PET-II (CBM600/700) family of computers using
260 the cc65 crosscompiler.
261
262 %files cbm610
263 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
264 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
265 %doc src/ld65/cfg/cbm610.cfg
266
267
268
269 ###############################################################################
270 #                             Apple ][ subpackage                             #
271 ###############################################################################
272
273 %package apple2
274 Requires: %{name} = %{version}
275 Copyright: Freeware
276 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
277 Group: Development/Languages
278
279 %description apple2
280 This package contains the header files and libraries needed to write
281 programs for the Apple ][ using the cc65 crosscompiler.
282
283 %files apple2
284 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
285 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
286 %doc src/ld65/cfg/apple2.cfg
287
288
289
290 ###############################################################################
291 #                               GEOS subpackage                               #
292 ###############################################################################
293
294 %package geos
295 Requires: %{name} = %{version}
296 Copyright: Freeware
297 Summary: GEOS specific libraries and headers for the cc65 compiler.
298 Group: Development/Languages
299
300 %description geos
301 This package contains the header files and libraries needed to write
302 GEOS programs for the C64/C128 using the cc65 crosscompiler.
303
304 %files geos
305 %attr(755,root,root)            /usr/bin/grc
306 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
307 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
308 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
309 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
310 %doc src/ld65/cfg/geos.cfg
311
312
313
314 ###############################################################################
315 #                                    Build                                    #
316 ###############################################################################
317
318
319
320 %prep
321 %setup
322
323
324 %build
325 # Binaries
326 cd src
327 make -f make/gcc.mak
328 cd ..
329 # Libraries
330 cd libsrc
331 make -s zap all
332 cd ..
333 # Documentation
334 cd doc
335 make html
336 cd ..
337
338
339 %install
340 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{geos,tgi},joy,lib,tgi}}
341
342 # Binaries
343 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
344 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
345 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
346 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
347 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
348 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
349 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
350 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
351 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
352 # Libraries and includes
353 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
354 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
355 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
356 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
357 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
358
359 # Drivers
360 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
361 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
362 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
363
364
365
366 %changelog
367 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
368 Updated the version number.
369
370 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>   
371 Changed location of TGI drivers, added EM drivers.
372
373 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
374 Added the C16 subpackage.
375
376 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
377 Added TGI stuff.
378
379 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
380 Update to version 2.8.0 of the compiler package.
381
382 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
383 Update to version 2.7.1 of the compiler package.
384
385 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
386 Update to version 2.7.0 of the compiler package.
387
388 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
389 Update to version 2.6.2 of the compiler package.
390
391 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
392 Update to version 2.6.1 of the compiler package.
393
394 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
395 Update for cc65 2.6.0 and RedHat 7.x
396
397 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
398 The GEOS include files were not installed, remove headegen.sh
399
400 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
401 Update to version 2.5.0 of the compiler package.
402
403 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
404 Update to version 2.4.1 of the compiler package.
405
406 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
407 Update to version 2.4.0 of the compiler package.
408
409 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
410 Update to version 2.3.1 of the compiler package.
411
412 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
413 Update to version 2.3.0 of the compiler package.
414
415 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
416 [2.2.1-2]
417 - changed to allow build as plain user
418 - `samples' are part of documentation, not part of library
419