]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Atari joystick driver filename fix
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.10.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/grc.txt
90 %doc doc/internal.txt
91 %doc doc/newvers.txt
92 %doc samples
93 %doc src/ld65/cfg/*.cfg
94
95
96
97 ###############################################################################
98 #                             Apple ][ subpackage                             #
99 ###############################################################################
100
101 %package apple2
102 Requires: %{name} = %{version}
103 Copyright: Freeware
104 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
105 Group: Development/Languages
106
107 %description apple2
108 This package contains the header files and libraries needed to write
109 programs for the Apple ][ using the cc65 crosscompiler.
110
111 %files apple2
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
113 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
114 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
115 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117
118
119
120 ###############################################################################
121 #                            Apple //e subpackage                             #
122 ###############################################################################
123
124 %package apple2enh
125 Requires: %{name} = %{version}
126 Copyright: Freeware
127 Summary: Apple //e specific libraries and headers for the cc65 compiler.
128 Group: Development/Languages
129
130 %description apple2enh
131 This package contains the header files and libraries needed to write
132 programs for the Apple //e using the cc65 crosscompiler.
133
134 %files apple2enh
135 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.o
137 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
138 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
139 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
140
141
142
143 ###############################################################################
144 #                              Atari subpackage                               #
145 ###############################################################################
146
147 %package atari
148 Requires: %{name} = %{version}
149 Copyright: Freeware
150 Summary: Atari specific libraries and headers for the cc65 compiler.
151 Group: Development/Languages
152
153 %description atari
154 This package contains the header files and libraries needed to write
155 programs for the 8 bit Atari machines using the cc65 crosscompiler.
156
157 %files atari
158 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
159 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
160 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
161
162
163
164 ###############################################################################
165 #                            Oric Atmos subpackage                            #
166 ###############################################################################
167
168 %package atmos
169 Requires: %{name} = %{version}
170 Copyright: Freeware
171 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
172 Group: Development/Languages
173
174 %description atmos
175 This package contains the header files and libraries needed to write
176 programs for the Oric Atmos using the cc65 crosscompiler.
177
178 %files atmos
179 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
180 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
181
182
183
184 ###############################################################################
185 #                               C128 subpackage                               #
186 ###############################################################################
187
188 %package c128
189 Requires: %{name} = %{version}
190 Copyright: Freeware
191 Summary: C128 specific libraries and headers for the cc65 compiler.
192 Group: Development/Languages
193
194 %description c128
195 This package contains the header files and libraries needed to write
196 programs for the Commodore C128 using the cc65 crosscompiler.
197
198 %files c128
199 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
200 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
201 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
202 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
203 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
204 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
205 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
206
207
208
209 ###############################################################################
210 #                                C16 subpackage                               #
211 ###############################################################################
212
213 %package c16
214 Requires: %{name} = %{version}
215 Copyright: Freeware
216 Summary: C16/116 specific libraries and headers for the cc65 compiler.
217 Group: Development/Languages
218
219 %description c16
220 This package contains the header files and libraries needed to write
221 programs for the Commodore C16/116 using the cc65 crosscompiler.
222
223 %files c16
224 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
225 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
226 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
227 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
228
229
230
231 ###############################################################################
232 #                               C64 subpackage                                #
233 ###############################################################################
234
235 %package c64
236 Requires: %{name} = %{version}
237 Copyright: Freeware
238 Summary: C64 specific libraries and headers for the cc65 compiler.
239 Group: Development/Languages
240
241 %description c64
242 This package contains the header files and libraries needed to write
243 programs for the Commodore C64 using the cc65 crosscompiler.
244
245 %files c64
246 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
247 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
248 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
249 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
250 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
251 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
252 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
253
254
255
256 ###############################################################################
257 #                              CBM510 subpackage                              #
258 ###############################################################################
259
260 %package cbm510
261 Requires: %{name} = %{version}
262 Copyright: Freeware
263 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
264 Group: Development/Languages
265
266 %description cbm510
267 This package contains the header files and libraries needed to write
268 programs for the Commodore CBM 510 (aka P500) using the cc65
269 crosscompiler.
270
271 %files cbm510
272 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
273 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
274 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
275 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
276 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
277
278
279
280 ###############################################################################
281 #                              CBM610 subpackage                              #
282 ###############################################################################
283
284 %package cbm610
285 Requires: %{name} = %{version}
286 Copyright: Freeware
287 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
288 Group: Development/Languages
289
290 %description cbm610
291 This package contains the header files and libraries needed to write
292 programs for the Commodore PET-II (CBM600/700) family of computers using
293 the cc65 crosscompiler.
294
295 %files cbm610
296 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
297 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
298 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
299 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
300
301
302
303 ###############################################################################
304 #                               GEOS subpackage                               #
305 ###############################################################################
306
307 %package geos
308 Requires: %{name} = %{version}
309 Copyright: Freeware
310 Summary: GEOS specific libraries and headers for the cc65 compiler.
311 Group: Development/Languages
312
313 %description geos
314 This package contains the header files and libraries needed to write
315 GEOS programs for the C64/C128 using the cc65 crosscompiler.
316
317 %files geos
318 %attr(755,root,root)            /usr/bin/grc
319 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
320 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
321 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
322 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
323 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
324 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
325 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
326
327
328
329 ###############################################################################
330 #                               NES subpackage                                #
331 ###############################################################################
332
333 %package nes
334 Requires: %{name} = %{version}
335 Copyright: Freeware
336 Summary: NES specific libraries and headers for the cc65 compiler.
337 Group: Development/Languages
338
339 %description nes
340 This package contains the header files and libraries needed to write
341 programs for the Nintendo Entertainment System using the cc65
342 crosscompiler.
343
344 %files nes
345 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
346 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
347
348
349
350 ###############################################################################
351 #                               PET subpackage                                #
352 ###############################################################################
353
354 %package pet
355 Requires: %{name} = %{version}
356 Copyright: Freeware
357 Summary: PET specific libraries and headers for the cc65 compiler.
358 Group: Development/Languages
359
360 %description pet
361 This package contains the header files and libraries needed to write
362 programs for the Commodore PET family of computers using the cc65
363 crosscompiler.
364
365 %files pet
366 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
367 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
368
369
370
371 ###############################################################################
372 #                              Plus/4 subpackage                              #
373 ###############################################################################
374
375 %package plus4
376 Requires: %{name} = %{version}
377 Copyright: Freeware
378 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
379 Group: Development/Languages
380
381 %description plus4
382 This package contains the header files and libraries needed to write
383 programs for the Commodore Plus/4 and C16/116 using the cc65
384 crosscompiler.
385
386 %files plus4
387 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
388 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
389 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
390 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
391
392
393
394 ###############################################################################
395 #                           Supervision subpackage                            #
396 ###############################################################################
397
398 %package supervision
399 Requires: %{name} = %{version}
400 Copyright: Freeware
401 Summary: Supervision specific libraries and headers for the cc65 compiler.
402 Group: Development/Languages
403
404 %description supervision
405 This package contains the header files and libraries needed to write
406 programs for the Supervision Game console using the cc65 crosscompiler.
407
408 %files supervision
409 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
410 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
411
412
413
414 ###############################################################################
415 #                              VIC20 subpackage                               #
416 ###############################################################################
417
418 %package vic20
419 Requires: %{name} = %{version}
420 Copyright: Freeware
421 Summary: VIC20 specific libraries and headers for the cc65 compiler.
422 Group: Development/Languages
423
424 %description vic20
425 This package contains the header files and libraries needed to write
426 programs for the Commodore VIC20 using the cc65 crosscompiler.
427
428 %files vic20
429 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
430 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
431 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
432
433
434
435 ###############################################################################
436 #                                    Build                                    #
437 ###############################################################################
438
439
440
441 %prep
442 %setup -q
443
444
445 %build
446 # Binaries
447 make -C src -f make/gcc.mak
448 # Libraries
449 make -C libsrc -s zap all
450 # Documentation
451 make -C doc html
452
453
454 %install
455 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
456
457 # Binaries
458 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
459 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
460 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
461 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
462 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
463 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
464 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
465 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
466 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
467 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
468 # Libraries and includes
469 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
470 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
471 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
472 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
473 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
474 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
475 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
476 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
477 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
478
479 # Drivers
480 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
481 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
482 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
483 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
484 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
485
486
487 %clean
488 rm -rf $RPM_BUILD_ROOT
489
490
491
492 %changelog
493 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
494 - Changelog is now in CVS