]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added CBM610 serial drivers
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
113 %attr(644,root,root)            /usr/lib/cc65/tgi/a2-*.tgi
114
115
116
117 ###############################################################################
118 #                              Atari subpackage                               #
119 ###############################################################################
120
121 %package atari
122 Requires: %{name} = %{version}
123 Copyright: Freeware
124 Summary: Atari specific libraries and headers for the cc65 compiler.
125 Group: Development/Languages
126
127 %description atari
128 This package contains the header files and libraries needed to write
129 programs for the 8 bit Atari machines using the cc65 crosscompiler.
130
131 %files atari
132 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
133 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
134
135
136
137 ###############################################################################
138 #                            Oric Atmos subpackage                            #
139 ###############################################################################
140
141 %package atmos
142 Requires: %{name} = %{version}
143 Copyright: Freeware
144 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
145 Group: Development/Languages
146
147 %description atmos
148 This package contains the header files and libraries needed to write
149 programs for the Oric Atmos using the cc65 crosscompiler.
150
151 %files atmos
152 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
153 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
154
155
156
157 ###############################################################################
158 #                               C128 subpackage                               #
159 ###############################################################################
160
161 %package c128
162 Requires: %{name} = %{version}
163 Copyright: Freeware
164 Summary: C128 specific libraries and headers for the cc65 compiler.
165 Group: Development/Languages
166
167 %description c128
168 This package contains the header files and libraries needed to write
169 programs for the Commodore C128 using the cc65 crosscompiler.
170
171 %files c128
172 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
173 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
174 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
175 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
176 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
177 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
178
179
180
181 ###############################################################################
182 #                                C16 subpackage                               #
183 ###############################################################################
184
185 %package c16
186 Requires: %{name} = %{version}
187 Copyright: Freeware
188 Summary: C16/116 specific libraries and headers for the cc65 compiler.
189 Group: Development/Languages
190
191 %description c16
192 This package contains the header files and libraries needed to write
193 programs for the Commodore C16/116 using the cc65 crosscompiler.
194
195 %files c16
196 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
197 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
198 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
199 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
200
201
202
203 ###############################################################################
204 #                               C64 subpackage                                #
205 ###############################################################################
206
207 %package c64
208 Requires: %{name} = %{version}
209 Copyright: Freeware
210 Summary: C64 specific libraries and headers for the cc65 compiler.
211 Group: Development/Languages
212
213 %description c64
214 This package contains the header files and libraries needed to write
215 programs for the Commodore C64 using the cc65 crosscompiler.
216
217 %files c64
218 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
219 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
220 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
221 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
222 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
223 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
224
225
226
227 ###############################################################################
228 #                              CBM510 subpackage                              #
229 ###############################################################################
230
231 %package cbm510
232 Requires: %{name} = %{version}
233 Copyright: Freeware
234 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
235 Group: Development/Languages
236
237 %description cbm510
238 This package contains the header files and libraries needed to write
239 programs for the Commodore CBM 510 (aka P500) using the cc65
240 crosscompiler.
241
242 %files cbm510
243 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
244 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
245 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
246 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
247
248
249
250 ###############################################################################
251 #                              CBM610 subpackage                              #
252 ###############################################################################
253
254 %package cbm610
255 Requires: %{name} = %{version}
256 Copyright: Freeware
257 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
258 Group: Development/Languages
259
260 %description cbm610
261 This package contains the header files and libraries needed to write
262 programs for the Commodore PET-II (CBM600/700) family of computers using
263 the cc65 crosscompiler.
264
265 %files cbm610
266 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
267 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
268 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
269 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
270
271
272
273 ###############################################################################
274 #                               GEOS subpackage                               #
275 ###############################################################################
276
277 %package geos
278 Requires: %{name} = %{version}
279 Copyright: Freeware
280 Summary: GEOS specific libraries and headers for the cc65 compiler.
281 Group: Development/Languages
282
283 %description geos
284 This package contains the header files and libraries needed to write
285 GEOS programs for the C64/C128 using the cc65 crosscompiler.
286
287 %files geos
288 %attr(755,root,root)            /usr/bin/grc
289 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
290 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
291 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
292 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
293 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
294 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
295 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
296
297
298
299 ###############################################################################
300 #                               NES subpackage                                #
301 ###############################################################################
302
303 %package nes
304 Requires: %{name} = %{version}
305 Copyright: Freeware
306 Summary: NES specific libraries and headers for the cc65 compiler.
307 Group: Development/Languages
308
309 %description nes
310 This package contains the header files and libraries needed to write
311 programs for the Nintendo Entertainment System using the cc65
312 crosscompiler.
313
314 %files nes
315 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
316 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
317
318
319
320 ###############################################################################
321 #                               PET subpackage                                #
322 ###############################################################################
323
324 %package pet
325 Requires: %{name} = %{version}
326 Copyright: Freeware
327 Summary: PET specific libraries and headers for the cc65 compiler.
328 Group: Development/Languages
329
330 %description pet
331 This package contains the header files and libraries needed to write
332 programs for the Commodore PET family of computers using the cc65
333 crosscompiler.
334
335 %files pet
336 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
337 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
338
339
340
341 ###############################################################################
342 #                              Plus/4 subpackage                              #
343 ###############################################################################
344
345 %package plus4
346 Requires: %{name} = %{version}
347 Copyright: Freeware
348 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
349 Group: Development/Languages
350
351 %description plus4
352 This package contains the header files and libraries needed to write
353 programs for the Commodore Plus/4 and C16/116 using the cc65
354 crosscompiler.
355
356 %files plus4
357 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
358 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
359 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
360 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
361
362
363
364 ###############################################################################
365 #                           Supervision subpackage                            #
366 ###############################################################################
367
368 %package supervision
369 Requires: %{name} = %{version}
370 Copyright: Freeware
371 Summary: Supervision specific libraries and headers for the cc65 compiler.
372 Group: Development/Languages
373
374 %description supervision
375 This package contains the header files and libraries needed to write
376 programs for the Supervision Game console using the cc65 crosscompiler.
377
378 %files supervision
379 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
380 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
381
382
383
384 ###############################################################################
385 #                              VIC20 subpackage                               #
386 ###############################################################################
387
388 %package vic20
389 Requires: %{name} = %{version}
390 Copyright: Freeware
391 Summary: VIC20 specific libraries and headers for the cc65 compiler.
392 Group: Development/Languages
393
394 %description vic20
395 This package contains the header files and libraries needed to write
396 programs for the Commodore VIC20 using the cc65 crosscompiler.
397
398 %files vic20
399 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
400 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
401 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
402
403
404
405 ###############################################################################
406 #                                    Build                                    #
407 ###############################################################################
408
409
410
411 %prep
412 %setup -q
413
414
415 %build
416 # Binaries
417 make -C src -f make/gcc.mak
418 # Libraries
419 make -C libsrc -s zap all
420 # Documentation
421 make -C doc html
422
423
424 %install
425 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,ser,tgi}}
426
427 # Binaries
428 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
429 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
430 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
431 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
432 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
433 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
434 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
435 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
436 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
437 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
438 # Libraries and includes
439 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
440 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
441 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
442 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
443 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
444 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
445 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
446 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
447
448 # Drivers
449 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
450 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
451 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
452 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
453
454
455 %clean
456 rm -rf $RPM_BUILD_ROOT
457
458
459
460 %changelog
461 * Sun Nov 02 2003 Ullrich von Bassewitz <uz@cc65.org>
462 - Added missing files after upgrade to rpm 4.2
463
464 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
465 - Move documentation into a separate doc package.
466
467 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
468 - Added the Supervision subpackage.
469
470 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
471 - Better cleanup.
472
473 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
474 - Added subdirectories of include/
475
476 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
477 - The Apple ][ has a joystick driver.
478 - Added the NES subpackage.
479
480 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
481 Added a subpackage for the Oric Atmos.
482
483 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
484 Added the object file conversion utility co65.
485
486 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
487 Updated the version number.
488
489 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
490 Changed location of TGI drivers, added EM drivers.
491
492 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
493 Added the C16 subpackage.
494
495 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
496 Added TGI stuff.
497
498 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
499 Update to version 2.8.0 of the compiler package.
500
501 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
502 Update to version 2.7.1 of the compiler package.
503
504 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
505 Update to version 2.7.0 of the compiler package.
506
507 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
508 Update to version 2.6.2 of the compiler package.
509
510 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
511 Update to version 2.6.1 of the compiler package.
512
513 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
514 Update for cc65 2.6.0 and RedHat 7.x
515
516 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
517 The GEOS include files were not installed, remove headegen.sh
518
519 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
520 Update to version 2.5.0 of the compiler package.
521
522 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
523 Update to version 2.4.1 of the compiler package.
524
525 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
526 Update to version 2.4.0 of the compiler package.
527
528 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
529 Update to version 2.3.1 of the compiler package.
530
531 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
532 Update to version 2.3.0 of the compiler package.
533
534 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
535 [2.2.1-2]
536 - changed to allow build as plain user
537 - `samples' are part of documentation, not part of library
538