2 # SPEC file for the cc65 C compiler and RedHat 7.x
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
7 ###############################################################################
9 ###############################################################################
11 Summary: Crosscompiler/Crossassembler for 6502 systems
14 %define version 2.13.0
17 License: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 URL: http://www.cc65.org/
25 BuildRequires: sgml-tools
27 BuildRoot: /var/tmp/%{name}-%{version}
30 A C crosscompiler for 6502 systems, including a macroassembler that
31 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
32 other tools. To create programs for one of the supported target
33 machines, you have to install at least one of the target platform
34 packages in addition to the main package.
37 %defattr(644,root,root,755)
42 %attr(755,root,root) /usr/bin/ar65
43 %attr(755,root,root) /usr/bin/ca65
44 %attr(755,root,root) /usr/bin/ca65html
45 %attr(755,root,root) /usr/bin/cc65
46 %attr(755,root,root) /usr/bin/cl65
47 %attr(755,root,root) /usr/bin/co65
48 %attr(755,root,root) /usr/bin/da65
49 %attr(755,root,root) /usr/bin/ld65
50 %attr(755,root,root) /usr/bin/od65
51 %attr(755,root,root) %dir /usr/lib/cc65
52 %attr(755,root,root) %dir /usr/lib/cc65/cfg
53 %attr(755,root,root) %dir /usr/lib/cc65/emd
54 %attr(755,root,root) %dir /usr/lib/cc65/joy
55 %attr(755,root,root) %dir /usr/lib/cc65/lib
56 %attr(755,root,root) %dir /usr/lib/cc65/obj
57 %attr(755,root,root) %dir /usr/lib/cc65/ser
58 %attr(755,root,root) %dir /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir /usr/lib/cc65/include
60 %attr(644,root,root) /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir /usr/lib/cc65/include/em
62 %attr(644,root,root) /usr/lib/cc65/include/em/*.h
63 %attr(755,root,root) %dir /usr/lib/cc65/include/joystick
64 %attr(644,root,root) /usr/lib/cc65/include/joystick/*.h
65 %attr(755,root,root) %dir /usr/lib/cc65/include/mouse
66 %attr(644,root,root) /usr/lib/cc65/include/mouse/*.h
67 %attr(755,root,root) %dir /usr/lib/cc65/include/sys
68 %attr(644,root,root) /usr/lib/cc65/include/sys/*.h
69 %attr(755,root,root) %dir /usr/lib/cc65/include/tgi
70 %attr(644,root,root) /usr/lib/cc65/include/tgi/*.h
71 %attr(755,root,root) %dir /usr/lib/cc65/asminc
72 %attr(644,root,root) /usr/lib/cc65/asminc/*.inc
76 ###############################################################################
77 # Documentation subpackage #
78 ###############################################################################
82 Requires: %{name} = %{version}
84 Summary: Documentation for the cc65 C compiler
85 Group: Development/Languages
88 This package contains the documentation for the cc65 C compiler, mostly
89 in HTML format. Other formats can be generated from the sources.
100 ###############################################################################
101 # Apple ][ subpackage #
102 ###############################################################################
105 Requires: %{name} = %{version}
107 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
108 Group: Development/Languages
111 This package contains the header files and libraries needed to write
112 programs for the Apple ][ using the cc65 crosscompiler.
115 %attr(644,root,root) /usr/lib/cc65/lib/apple2.lib
116 %attr(644,root,root) /usr/lib/cc65/obj/apple2-*.o
117 %attr(644,root,root) /usr/lib/cc65/emd/a2.*.emd
118 %attr(644,root,root) /usr/lib/cc65/joy/a2.*.joy
119 %attr(644,root,root) /usr/lib/cc65/mou/a2.*.mou
120 %attr(644,root,root) /usr/lib/cc65/ser/a2.*.ser
121 %attr(644,root,root) /usr/lib/cc65/tgi/a2.*.tgi
122 %attr(644,root,root) /usr/lib/cc65/cfg/apple2-*.cfg
126 ###############################################################################
127 # Apple //e subpackage #
128 ###############################################################################
131 Requires: %{name} = %{version}
133 Summary: Apple //e specific libraries and headers for the cc65 compiler.
134 Group: Development/Languages
136 %description apple2enh
137 This package contains the header files and libraries needed to write
138 programs for the Apple //e using the cc65 crosscompiler.
141 %attr(644,root,root) /usr/lib/cc65/lib/apple2enh.lib
142 %attr(644,root,root) /usr/lib/cc65/obj/apple2enh-*.o
143 %attr(644,root,root) /usr/lib/cc65/emd/a2e.*.emd
144 %attr(644,root,root) /usr/lib/cc65/joy/a2e.*.joy
145 %attr(644,root,root) /usr/lib/cc65/mou/a2e.*.mou
146 %attr(644,root,root) /usr/lib/cc65/ser/a2e.*.ser
147 %attr(644,root,root) /usr/lib/cc65/tgi/a2e.*.tgi
148 %attr(644,root,root) /usr/lib/cc65/cfg/apple2enh-*.cfg
152 ###############################################################################
154 ###############################################################################
157 Requires: %{name} = %{version}
159 Summary: Atari specific libraries and headers for the cc65 compiler.
160 Group: Development/Languages
163 This package contains the header files and libraries needed to write
164 programs for the 8 bit Atari machines using the cc65 crosscompiler.
167 %attr(644,root,root) /usr/lib/cc65/lib/atari.lib
168 %attr(644,root,root) /usr/lib/cc65/joy/atari*.joy
172 ###############################################################################
173 # Oric Atmos subpackage #
174 ###############################################################################
177 Requires: %{name} = %{version}
179 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
180 Group: Development/Languages
183 This package contains the header files and libraries needed to write
184 programs for the Oric Atmos using the cc65 crosscompiler.
187 %attr(644,root,root) /usr/lib/cc65/lib/atmos.lib
188 %attr(644,root,root) /usr/lib/cc65/tgi/atmos-*.joy
189 %attr(644,root,root) /usr/lib/cc65/tgi/atmos-*.tgi
193 ###############################################################################
195 ###############################################################################
198 Requires: %{name} = %{version}
200 Summary: C128 specific libraries and headers for the cc65 compiler.
201 Group: Development/Languages
204 This package contains the header files and libraries needed to write
205 programs for the Commodore C128 using the cc65 crosscompiler.
208 %attr(644,root,root) /usr/lib/cc65/lib/c128.lib
209 %attr(644,root,root) /usr/lib/cc65/emd/c128-*.emd
210 %attr(644,root,root) /usr/lib/cc65/joy/c128-*.joy
211 %attr(644,root,root) /usr/lib/cc65/mou/c128-*.mou
212 %attr(644,root,root) /usr/lib/cc65/ser/c128-*.ser
213 %attr(644,root,root) /usr/lib/cc65/tgi/c128-*.tgi
217 ###############################################################################
219 ###############################################################################
222 Requires: %{name} = %{version}
224 Summary: C16/116 specific libraries and headers for the cc65 compiler.
225 Group: Development/Languages
228 This package contains the header files and libraries needed to write
229 programs for the Commodore C16/116 using the cc65 crosscompiler.
232 %attr(644,root,root) /usr/lib/cc65/lib/c16.lib
233 %attr(644,root,root) /usr/lib/cc65/emd/c16-*.emd
234 %attr(644,root,root) /usr/lib/cc65/joy/c16-*.joy
238 ###############################################################################
240 ###############################################################################
243 Requires: %{name} = %{version}
245 Summary: C64 specific libraries and headers for the cc65 compiler.
246 Group: Development/Languages
249 This package contains the header files and libraries needed to write
250 programs for the Commodore C64 using the cc65 crosscompiler.
253 %attr(644,root,root) /usr/lib/cc65/lib/c64.lib
254 %attr(644,root,root) /usr/lib/cc65/emd/dtv-*.emd
255 %attr(644,root,root) /usr/lib/cc65/emd/c64-*.emd
256 %attr(644,root,root) /usr/lib/cc65/joy/c64-*.joy
257 %attr(644,root,root) /usr/lib/cc65/mou/c64-*.mou
258 %attr(644,root,root) /usr/lib/cc65/ser/c64-*.ser
259 %attr(644,root,root) /usr/lib/cc65/tgi/c64-*.tgi
263 ###############################################################################
264 # CBM510 subpackage #
265 ###############################################################################
268 Requires: %{name} = %{version}
270 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
271 Group: Development/Languages
274 This package contains the header files and libraries needed to write
275 programs for the Commodore CBM 510 (aka P500) using the cc65
279 %attr(644,root,root) /usr/lib/cc65/lib/cbm510.lib
280 %attr(644,root,root) /usr/lib/cc65/emd/cbm510-*.emd
281 %attr(644,root,root) /usr/lib/cc65/joy/cbm510-*.joy
282 %attr(644,root,root) /usr/lib/cc65/ser/cbm510-*.ser
286 ###############################################################################
287 # CBM610 subpackage #
288 ###############################################################################
291 Requires: %{name} = %{version}
293 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
294 Group: Development/Languages
297 This package contains the header files and libraries needed to write
298 programs for the Commodore PET-II (CBM600/700) family of computers using
299 the cc65 crosscompiler.
302 %attr(644,root,root) /usr/lib/cc65/lib/cbm610.lib
303 %attr(644,root,root) /usr/lib/cc65/emd/cbm610-*.emd
304 %attr(644,root,root) /usr/lib/cc65/ser/cbm610-*.ser
308 ###############################################################################
310 ###############################################################################
313 Requires: %{name} = %{version}
315 Summary: GEOS specific libraries and headers for the cc65 compiler.
316 Group: Development/Languages
319 This package contains the header files and libraries needed to write
320 GEOS programs for the C64/C128 using the cc65 crosscompiler.
323 %attr(755,root,root) /usr/bin/grc
324 %attr(644,root,root) /usr/lib/cc65/lib/geos.lib
325 %attr(755,root,root) %dir /usr/lib/cc65/include/geos
326 %attr(644,root,root) /usr/lib/cc65/include/geos/*.h
327 %attr(644,root,root) /usr/lib/cc65/emd/geos-*.emd
328 %attr(644,root,root) /usr/lib/cc65/joy/geos-*.joy
329 %attr(644,root,root) /usr/lib/cc65/tgi/geos-*.tgi
333 ###############################################################################
335 ###############################################################################
338 Requires: %{name} = %{version}
340 Summary: Lynx specific libraries and headers for the cc65 compiler.
341 Group: Development/Languages
344 This package contains the header files and libraries needed to write
345 programs for the Lynx Game Console using the cc65 crosscompiler.
348 %attr(644,root,root) /usr/lib/cc65/lib/lynx.lib
349 %attr(644,root,root) /usr/lib/cc65/joy/lynx-*.joy
350 %attr(644,root,root) /usr/lib/cc65/ser/lynx-*.ser
351 %attr(644,root,root) /usr/lib/cc65/tgi/lynx-*.tgi
355 ###############################################################################
357 ###############################################################################
360 Requires: %{name} = %{version}
362 Summary: NES specific libraries and headers for the cc65 compiler.
363 Group: Development/Languages
366 This package contains the header files and libraries needed to write
367 programs for the Nintendo Entertainment System using the cc65
371 %attr(644,root,root) /usr/lib/cc65/lib/nes.lib
372 %attr(644,root,root) /usr/lib/cc65/joy/nes-*.joy
376 ###############################################################################
378 ###############################################################################
381 Requires: %{name} = %{version}
383 Summary: PET specific libraries and headers for the cc65 compiler.
384 Group: Development/Languages
387 This package contains the header files and libraries needed to write
388 programs for the Commodore PET family of computers using the cc65
392 %attr(644,root,root) /usr/lib/cc65/lib/pet.lib
393 %attr(644,root,root) /usr/lib/cc65/joy/pet-*.joy
397 ###############################################################################
398 # Plus/4 subpackage #
399 ###############################################################################
402 Requires: %{name} = %{version}
404 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
405 Group: Development/Languages
408 This package contains the header files and libraries needed to write
409 programs for the Commodore Plus/4 and C16/116 using the cc65
413 %attr(644,root,root) /usr/lib/cc65/lib/plus4.lib
414 %attr(644,root,root) /usr/lib/cc65/joy/plus4-*.joy
415 %attr(644,root,root) /usr/lib/cc65/ser/plus4-*.ser
419 ###############################################################################
420 # Supervision subpackage #
421 ###############################################################################
424 Requires: %{name} = %{version}
426 Summary: Supervision specific libraries and headers for the cc65 compiler.
427 Group: Development/Languages
429 %description supervision
430 This package contains the header files and libraries needed to write
431 programs for the Supervision Game console using the cc65 crosscompiler.
434 %attr(644,root,root) /usr/lib/cc65/lib/supervision.lib
435 %attr(644,root,root) /usr/lib/cc65/cfg/supervision-*.cfg
439 ###############################################################################
441 ###############################################################################
444 Requires: %{name} = %{version}
446 Summary: VIC20 specific libraries and headers for the cc65 compiler.
447 Group: Development/Languages
450 This package contains the header files and libraries needed to write
451 programs for the Commodore VIC20 using the cc65 crosscompiler.
454 %attr(644,root,root) /usr/lib/cc65/lib/vic20.lib
455 %attr(644,root,root) /usr/lib/cc65/joy/vic20-*.joy
456 %attr(644,root,root) /usr/lib/cc65/cfg/vic20-*.cfg
460 ###############################################################################
462 ###############################################################################
472 make -C src -f make/gcc.mak
474 make -C libsrc -s zap all
480 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,cfg,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,obj,ser,tgi}}
483 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
484 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
485 install -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
492 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
494 # Libraries and includes
495 install -m 644 libsrc/*.lib $RPM_BUILD_ROOT/usr/lib/cc65/lib
496 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
497 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
498 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
499 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
500 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
501 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
502 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
503 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
506 for extra in libsrc/*-*.o; do
507 install -m 644 ${extra} $RPM_BUILD_ROOT/usr/lib/cc65/obj
510 # Additional linker configurations
511 for config in src/ld65/cfg/*-*.cfg; do
512 install -m 644 ${config} $RPM_BUILD_ROOT/usr/lib/cc65/cfg
516 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
517 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
518 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
519 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
520 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
524 rm -rf $RPM_BUILD_ROOT
529 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
530 - Changelog is now in CVS