]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Apple joystick driver rename
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/co65
52 %attr(755,root,root)            /usr/bin/da65
53 %attr(755,root,root)            /usr/bin/ld65
54 %attr(755,root,root)            /usr/bin/od65
55 %attr(755,root,root) %dir       /usr/lib/cc65
56 %attr(755,root,root) %dir       /usr/lib/cc65/emd
57 %attr(755,root,root) %dir       /usr/lib/cc65/joy
58 %attr(755,root,root) %dir       /usr/lib/cc65/lib
59 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
60 %attr(755,root,root) %dir       /usr/lib/cc65/include
61 %attr(644,root,root)            /usr/lib/cc65/include/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                             Apple ][ subpackage                             #
71 ###############################################################################
72
73 %package apple2
74 Requires: %{name} = %{version}
75 Copyright: Freeware
76 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
77 Group: Development/Languages
78
79 %description apple2
80 This package contains the header files and libraries needed to write
81 programs for the Apple ][ using the cc65 crosscompiler.
82
83 %files apple2
84 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
85 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
86 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
87 %doc src/ld65/cfg/apple2.cfg
88
89
90
91 ###############################################################################
92 #                              Atari subpackage                               #
93 ###############################################################################
94
95 %package atari
96 Requires: %{name} = %{version}
97 Copyright: Freeware
98 Summary: Atari specific libraries and headers for the cc65 compiler.
99 Group: Development/Languages
100
101 %description atari
102 This package contains the header files and libraries needed to write
103 programs for the 8 bit Atari machines using the cc65 crosscompiler.
104
105 %files atari
106 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
107 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
108 %doc src/ld65/cfg/atari.cfg
109
110
111
112 ###############################################################################
113 #                            Oric Atmos subpackage                            #
114 ###############################################################################
115
116 %package atmos
117 Requires: %{name} = %{version}
118 Copyright: Freeware
119 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
120 Group: Development/Languages
121
122 %description atmos
123 This package contains the header files and libraries needed to write
124 programs for the Oric Atmos using the cc65 crosscompiler.
125
126 %files atmos
127 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
128 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
129 %doc src/ld65/cfg/atmos.cfg
130
131
132
133 ###############################################################################
134 #                               C128 subpackage                               #
135 ###############################################################################
136
137 %package c128
138 Requires: %{name} = %{version}
139 Copyright: Freeware
140 Summary: C128 specific libraries and headers for the cc65 compiler.
141 Group: Development/Languages
142
143 %description c128
144 This package contains the header files and libraries needed to write
145 programs for the Commodore C128 using the cc65 crosscompiler.
146
147 %files c128
148 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
149 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
150 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
151 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
152 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
153 %doc src/ld65/cfg/c128.cfg
154
155
156
157 ###############################################################################
158 #                                C16 subpackage                               #
159 ###############################################################################
160
161 %package c16
162 Requires: %{name} = %{version}
163 Copyright: Freeware
164 Summary: C16/116 specific libraries and headers for the cc65 compiler.
165 Group: Development/Languages
166
167 %description c16
168 This package contains the header files and libraries needed to write
169 programs for the Commodore C16/116 using the cc65 crosscompiler.
170
171 %files c16
172 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
173 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
174 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
175 %doc src/ld65/cfg/c16.cfg
176
177
178
179 ###############################################################################
180 #                               C64 subpackage                                #
181 ###############################################################################
182
183 %package c64
184 Requires: %{name} = %{version}
185 Copyright: Freeware
186 Summary: C64 specific libraries and headers for the cc65 compiler.
187 Group: Development/Languages
188
189 %description c64
190 This package contains the header files and libraries needed to write
191 programs for the Commodore C64 using the cc65 crosscompiler.
192
193 %files c64
194 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
195 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
196 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
197 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
198 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
199 %doc src/ld65/cfg/c64.cfg
200
201
202
203 ###############################################################################
204 #                              CBM510 subpackage                              #
205 ###############################################################################
206
207 %package cbm510
208 Requires: %{name} = %{version}
209 Copyright: Freeware
210 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
211 Group: Development/Languages
212
213 %description cbm510
214 This package contains the header files and libraries needed to write
215 programs for the Commodore CBM 510 (aka P500) using the cc65
216 crosscompiler.
217
218 %files cbm510
219 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
220 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
221 %doc src/ld65/cfg/cbm510.cfg
222
223
224
225 ###############################################################################
226 #                              CBM610 subpackage                              #
227 ###############################################################################
228
229 %package cbm610
230 Requires: %{name} = %{version}
231 Copyright: Freeware
232 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
233 Group: Development/Languages
234
235 %description cbm610
236 This package contains the header files and libraries needed to write
237 programs for the Commodore PET-II (CBM600/700) family of computers using
238 the cc65 crosscompiler.
239
240 %files cbm610
241 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
242 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
243 %doc src/ld65/cfg/cbm610.cfg
244
245
246
247 ###############################################################################
248 #                               GEOS subpackage                               #
249 ###############################################################################
250
251 %package geos
252 Requires: %{name} = %{version}
253 Copyright: Freeware
254 Summary: GEOS specific libraries and headers for the cc65 compiler.
255 Group: Development/Languages
256
257 %description geos
258 This package contains the header files and libraries needed to write
259 GEOS programs for the C64/C128 using the cc65 crosscompiler.
260
261 %files geos
262 %attr(755,root,root)            /usr/bin/grc
263 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
264 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
265 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
266 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
267 %doc src/ld65/cfg/geos.cfg
268
269
270
271 ###############################################################################
272 #                               NES subpackage                                #
273 ###############################################################################
274
275 %package nes
276 Requires: %{name} = %{version}
277 Copyright: Freeware
278 Summary: NES specific libraries and headers for the cc65 compiler.
279 Group: Development/Languages
280
281 %description nes
282 This package contains the header files and libraries needed to write
283 programs for the Nintendo Entertainment System using the cc65
284 crosscompiler.
285
286 %files nes
287 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
288 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
289 %doc src/ld65/cfg/nes.cfg
290
291
292
293 ###############################################################################
294 #                               PET subpackage                                #
295 ###############################################################################
296
297 %package pet
298 Requires: %{name} = %{version}
299 Copyright: Freeware
300 Summary: PET specific libraries and headers for the cc65 compiler.
301 Group: Development/Languages
302
303 %description pet
304 This package contains the header files and libraries needed to write
305 programs for the Commodore PET family of computers using the cc65
306 crosscompiler.
307
308 %files pet
309 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
310 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
311 %doc src/ld65/cfg/pet.cfg
312
313
314
315 ###############################################################################
316 #                              Plus/4 subpackage                              #
317 ###############################################################################
318
319 %package plus4
320 Requires: %{name} = %{version}
321 Copyright: Freeware
322 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
323 Group: Development/Languages
324
325 %description plus4
326 This package contains the header files and libraries needed to write
327 programs for the Commodore Plus/4 and C16/116 using the cc65
328 crosscompiler.
329
330 %files plus4
331 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
332 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
333 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
334 %doc src/ld65/cfg/plus4.cfg
335
336
337
338 ###############################################################################
339 #                              VIC20 subpackage                               #
340 ###############################################################################
341
342 %package vic20
343 Requires: %{name} = %{version}
344 Copyright: Freeware
345 Summary: VIC20 specific libraries and headers for the cc65 compiler.
346 Group: Development/Languages
347
348 %description vic20
349 This package contains the header files and libraries needed to write
350 programs for the Commodore VIC20 using the cc65 crosscompiler.
351
352 %files vic20
353 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
354 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
355 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
356 %doc src/ld65/cfg/vic20.cfg
357
358
359
360 ###############################################################################
361 #                                    Build                                    #
362 ###############################################################################
363
364
365
366 %prep
367 %setup
368
369
370 %build
371 # Binaries
372 cd src
373 make -f make/gcc.mak
374 cd ..
375 # Libraries
376 cd libsrc
377 make -s zap all
378 cd ..
379 # Documentation
380 cd doc
381 make html
382 cd ..
383
384
385 %install
386 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{geos,tgi},joy,lib,tgi}}
387
388 # Binaries
389 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
390 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
391 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
392 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
393 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
394 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
395 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
396 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
397 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
398 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
399 # Libraries and includes
400 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
401 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
402 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
403 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
404 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
405
406 # Drivers
407 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
408 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
409 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
410
411
412
413 %changelog
414 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
415 - The Apple ][ has a joystick driver.
416 - Added the NES subpackage.
417
418 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
419 Added a subpackage for the Oric Atmos.
420
421 %changelog
422 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
423 Added the object file conversion utility co65.
424
425 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
426 Updated the version number.
427
428 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
429 Changed location of TGI drivers, added EM drivers.
430
431 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
432 Added the C16 subpackage.
433
434 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
435 Added TGI stuff.
436
437 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
438 Update to version 2.8.0 of the compiler package.
439
440 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
441 Update to version 2.7.1 of the compiler package.
442
443 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
444 Update to version 2.7.0 of the compiler package.
445
446 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
447 Update to version 2.6.2 of the compiler package.
448
449 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
450 Update to version 2.6.1 of the compiler package.
451
452 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
453 Update for cc65 2.6.0 and RedHat 7.x
454
455 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
456 The GEOS include files were not installed, remove headegen.sh
457
458 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
459 Update to version 2.5.0 of the compiler package.
460
461 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
462 Update to version 2.4.1 of the compiler package.
463
464 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
465 Update to version 2.4.0 of the compiler package.
466
467 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
468 Update to version 2.3.1 of the compiler package.
469
470 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
471 Update to version 2.3.0 of the compiler package.
472
473 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
474 [2.2.1-2]
475 - changed to allow build as plain user
476 - `samples' are part of documentation, not part of library
477