]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added dtv-*.emd
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.11.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/mouse
61 %attr(644,root,root)            /usr/lib/cc65/include/mouse/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
63 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
65 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
66 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
67 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
68
69
70
71 ###############################################################################
72 #                          Documentation subpackage                           #
73 ###############################################################################
74
75 %package doc
76
77 Requires: %{name} = %{version}
78 Copyright: Freeware
79 Summary: Documentation for the cc65 C compiler
80 Group: Development/Languages
81
82 %description doc
83 This package contains the documentation for the cc65 C compiler, mostly
84 in HTML format. Other formats can be generated from the sources.
85
86 %files doc
87 %doc doc/*.html
88 %doc doc/compile.txt
89 %doc doc/internal.txt
90 %doc doc/newvers.txt
91 %doc samples
92 %doc src/ld65/cfg/*.cfg
93
94
95
96 ###############################################################################
97 #                             Apple ][ subpackage                             #
98 ###############################################################################
99
100 %package apple2
101 Requires: %{name} = %{version}
102 Copyright: Freeware
103 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
104 Group: Development/Languages
105
106 %description apple2
107 This package contains the header files and libraries needed to write
108 programs for the Apple ][ using the cc65 crosscompiler.
109
110 %files apple2
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
112 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
113 %attr(644,root,root)            /usr/lib/cc65/emd/a2.*.emd
114 %attr(644,root,root)            /usr/lib/cc65/joy/a2.*.joy
115 %attr(644,root,root)            /usr/lib/cc65/ser/a2.*.ser
116 %attr(644,root,root)            /usr/lib/cc65/tgi/a2.*.tgi
117
118
119
120 ###############################################################################
121 #                            Apple //e subpackage                             #
122 ###############################################################################
123
124 %package apple2enh
125 Requires: %{name} = %{version}
126 Copyright: Freeware
127 Summary: Apple //e specific libraries and headers for the cc65 compiler.
128 Group: Development/Languages
129
130 %description apple2enh
131 This package contains the header files and libraries needed to write
132 programs for the Apple //e using the cc65 crosscompiler.
133
134 %files apple2enh
135 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.lib
136 %attr(644,root,root)            /usr/lib/cc65/lib/apple2enh.o
137 %attr(644,root,root)            /usr/lib/cc65/emd/a2e.*.emd
138 %attr(644,root,root)            /usr/lib/cc65/joy/a2e.*.joy
139 %attr(644,root,root)            /usr/lib/cc65/ser/a2e.*.ser
140 %attr(644,root,root)            /usr/lib/cc65/tgi/a2e.*.tgi
141
142
143
144 ###############################################################################
145 #                              Atari subpackage                               #
146 ###############################################################################
147
148 %package atari
149 Requires: %{name} = %{version}
150 Copyright: Freeware
151 Summary: Atari specific libraries and headers for the cc65 compiler.
152 Group: Development/Languages
153
154 %description atari
155 This package contains the header files and libraries needed to write
156 programs for the 8 bit Atari machines using the cc65 crosscompiler.
157
158 %files atari
159 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
160 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
161 %attr(644,root,root)            /usr/lib/cc65/joy/atari*.joy
162
163
164
165 ###############################################################################
166 #                            Oric Atmos subpackage                            #
167 ###############################################################################
168
169 %package atmos
170 Requires: %{name} = %{version}
171 Copyright: Freeware
172 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
173 Group: Development/Languages
174
175 %description atmos
176 This package contains the header files and libraries needed to write
177 programs for the Oric Atmos using the cc65 crosscompiler.
178
179 %files atmos
180 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
181 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
182 %attr(644,root,root)            /usr/lib/cc65/tgi/atmos-*.tgi
183
184
185
186 ###############################################################################
187 #                               C128 subpackage                               #
188 ###############################################################################
189
190 %package c128
191 Requires: %{name} = %{version}
192 Copyright: Freeware
193 Summary: C128 specific libraries and headers for the cc65 compiler.
194 Group: Development/Languages
195
196 %description c128
197 This package contains the header files and libraries needed to write
198 programs for the Commodore C128 using the cc65 crosscompiler.
199
200 %files c128
201 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
202 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
203 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
204 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
205 %attr(644,root,root)            /usr/lib/cc65/mou/c128-*.mou
206 %attr(644,root,root)            /usr/lib/cc65/ser/c128-*.ser
207 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
208
209
210
211 ###############################################################################
212 #                                C16 subpackage                               #
213 ###############################################################################
214
215 %package c16
216 Requires: %{name} = %{version}
217 Copyright: Freeware
218 Summary: C16/116 specific libraries and headers for the cc65 compiler.
219 Group: Development/Languages
220
221 %description c16
222 This package contains the header files and libraries needed to write
223 programs for the Commodore C16/116 using the cc65 crosscompiler.
224
225 %files c16
226 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
227 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
228 %attr(644,root,root)            /usr/lib/cc65/emd/c16-*.emd
229 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
230
231
232
233 ###############################################################################
234 #                               C64 subpackage                                #
235 ###############################################################################
236
237 %package c64
238 Requires: %{name} = %{version}
239 Copyright: Freeware
240 Summary: C64 specific libraries and headers for the cc65 compiler.
241 Group: Development/Languages
242
243 %description c64
244 This package contains the header files and libraries needed to write
245 programs for the Commodore C64 using the cc65 crosscompiler.
246
247 %files c64
248 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
249 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
250 %attr(644,root,root)            /usr/lib/cc65/emd/dtv-*.emd
251 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
252 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
253 %attr(644,root,root)            /usr/lib/cc65/mou/c64-*.mou
254 %attr(644,root,root)            /usr/lib/cc65/ser/c64-*.ser
255 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
256
257
258
259 ###############################################################################
260 #                              CBM510 subpackage                              #
261 ###############################################################################
262
263 %package cbm510
264 Requires: %{name} = %{version}
265 Copyright: Freeware
266 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
267 Group: Development/Languages
268
269 %description cbm510
270 This package contains the header files and libraries needed to write
271 programs for the Commodore CBM 510 (aka P500) using the cc65
272 crosscompiler.
273
274 %files cbm510
275 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
276 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
277 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
278 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
279 %attr(644,root,root)            /usr/lib/cc65/ser/cbm510-*.ser
280
281
282
283 ###############################################################################
284 #                              CBM610 subpackage                              #
285 ###############################################################################
286
287 %package cbm610
288 Requires: %{name} = %{version}
289 Copyright: Freeware
290 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
291 Group: Development/Languages
292
293 %description cbm610
294 This package contains the header files and libraries needed to write
295 programs for the Commodore PET-II (CBM600/700) family of computers using
296 the cc65 crosscompiler.
297
298 %files cbm610
299 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
300 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
301 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
302 %attr(644,root,root)            /usr/lib/cc65/ser/cbm610-*.ser
303
304
305
306 ###############################################################################
307 #                               GEOS subpackage                               #
308 ###############################################################################
309
310 %package geos
311 Requires: %{name} = %{version}
312 Copyright: Freeware
313 Summary: GEOS specific libraries and headers for the cc65 compiler.
314 Group: Development/Languages
315
316 %description geos
317 This package contains the header files and libraries needed to write
318 GEOS programs for the C64/C128 using the cc65 crosscompiler.
319
320 %files geos
321 %attr(755,root,root)            /usr/bin/grc
322 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
323 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
324 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
325 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
326 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
327 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
328 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
329
330
331
332 ###############################################################################
333 #                               Lynx subpackage                               #
334 ###############################################################################
335
336 %package lynx
337 Requires: %{name} = %{version}
338 Copyright: Freeware
339 Summary: Lynx specific libraries and headers for the cc65 compiler.
340 Group: Development/Languages
341
342 %description lynx
343 This package contains the header files and libraries needed to write
344 programs for the Lynx Game Console using the cc65 crosscompiler.
345
346 %files lynx
347 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.lib
348 %attr(644,root,root)            /usr/lib/cc65/lib/lynx.o
349 %attr(644,root,root)            /usr/lib/cc65/joy/lynx-*.joy
350 %attr(644,root,root)            /usr/lib/cc65/tgi/lynx-*.tgi
351
352
353
354 ###############################################################################
355 #                               NES subpackage                                #
356 ###############################################################################
357
358 %package nes
359 Requires: %{name} = %{version}
360 Copyright: Freeware
361 Summary: NES specific libraries and headers for the cc65 compiler.
362 Group: Development/Languages
363
364 %description nes
365 This package contains the header files and libraries needed to write
366 programs for the Nintendo Entertainment System using the cc65
367 crosscompiler.
368
369 %files nes
370 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
371 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
372 %attr(644,root,root)            /usr/lib/cc65/joy/nes-*.joy
373
374
375
376 ###############################################################################
377 #                               PET subpackage                                #
378 ###############################################################################
379
380 %package pet
381 Requires: %{name} = %{version}
382 Copyright: Freeware
383 Summary: PET specific libraries and headers for the cc65 compiler.
384 Group: Development/Languages
385
386 %description pet
387 This package contains the header files and libraries needed to write
388 programs for the Commodore PET family of computers using the cc65
389 crosscompiler.
390
391 %files pet
392 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
393 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
394 %attr(644,root,root)            /usr/lib/cc65/joy/pet-*.joy
395
396
397
398 ###############################################################################
399 #                              Plus/4 subpackage                              #
400 ###############################################################################
401
402 %package plus4
403 Requires: %{name} = %{version}
404 Copyright: Freeware
405 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
406 Group: Development/Languages
407
408 %description plus4
409 This package contains the header files and libraries needed to write
410 programs for the Commodore Plus/4 and C16/116 using the cc65
411 crosscompiler.
412
413 %files plus4
414 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
415 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
416 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
417 %attr(644,root,root)            /usr/lib/cc65/ser/plus4-*.ser
418
419
420
421 ###############################################################################
422 #                           Supervision subpackage                            #
423 ###############################################################################
424
425 %package supervision
426 Requires: %{name} = %{version}
427 Copyright: Freeware
428 Summary: Supervision specific libraries and headers for the cc65 compiler.
429 Group: Development/Languages
430
431 %description supervision
432 This package contains the header files and libraries needed to write
433 programs for the Supervision Game console using the cc65 crosscompiler.
434
435 %files supervision
436 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
437 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
438
439
440
441 ###############################################################################
442 #                              VIC20 subpackage                               #
443 ###############################################################################
444
445 %package vic20
446 Requires: %{name} = %{version}
447 Copyright: Freeware
448 Summary: VIC20 specific libraries and headers for the cc65 compiler.
449 Group: Development/Languages
450
451 %description vic20
452 This package contains the header files and libraries needed to write
453 programs for the Commodore VIC20 using the cc65 crosscompiler.
454
455 %files vic20
456 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
457 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
458 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
459
460
461
462 ###############################################################################
463 #                                    Build                                    #
464 ###############################################################################
465
466
467
468 %prep
469 %setup -q
470
471
472 %build
473 # Binaries
474 make -C src -f make/gcc.mak
475 # Libraries
476 make -C libsrc -s zap all
477 # Documentation
478 make -C doc html
479
480
481 %install
482 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,mouse,sys,tgi},joy,lib,mou,ser,tgi}}
483
484 # Binaries
485 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
486 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
487 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
488 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
489 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
490 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
491 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
492 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
493 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
494 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
495 # Libraries and includes
496 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
497 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
498 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
499 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
500 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
501 install -m 644 include/mouse/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/mouse
502 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
503 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
504 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
505
506 # Drivers
507 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
508 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
509 install -m 644 libsrc/*.mou $RPM_BUILD_ROOT/usr/lib/cc65/mou
510 install -m 644 libsrc/*.ser $RPM_BUILD_ROOT/usr/lib/cc65/ser
511 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
512
513
514 %clean
515 rm -rf $RPM_BUILD_ROOT
516
517
518
519 %changelog
520 * Thu Dec 23 2003 Ullrich von Bassewitz <uz@cc65.org>
521 - Changelog is now in CVS