]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added missing files after upgrade to rpm 4.2
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.5
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/readme.1st
40 %attr(755,root,root)            /usr/bin/ar65
41 %attr(755,root,root)            /usr/bin/ca65
42 %attr(755,root,root)            /usr/bin/ca65html
43 %attr(755,root,root)            /usr/bin/cc65
44 %attr(755,root,root)            /usr/bin/cl65
45 %attr(755,root,root)            /usr/bin/co65
46 %attr(755,root,root)            /usr/bin/da65
47 %attr(755,root,root)            /usr/bin/ld65
48 %attr(755,root,root)            /usr/bin/od65
49 %attr(755,root,root) %dir       /usr/lib/cc65
50 %attr(755,root,root) %dir       /usr/lib/cc65/emd
51 %attr(755,root,root) %dir       /usr/lib/cc65/joy
52 %attr(755,root,root) %dir       /usr/lib/cc65/lib
53 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
54 %attr(755,root,root) %dir       /usr/lib/cc65/include
55 %attr(644,root,root)            /usr/lib/cc65/include/*.h
56 %attr(755,root,root) %dir       /usr/lib/cc65/include/em
57 %attr(644,root,root)            /usr/lib/cc65/include/em/*.h
58 %attr(755,root,root) %dir       /usr/lib/cc65/include/joystick
59 %attr(644,root,root)            /usr/lib/cc65/include/joystick/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/sys
61 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                          Documentation subpackage                           #
71 ###############################################################################
72
73 %package doc
74
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Documentation for the cc65 C compiler
78 Group: Development/Languages
79
80 %description doc
81 This package contains the documentation for the cc65 C compiler, mostly
82 in HTML format. Other formats can be generated from the sources.
83
84 %files doc
85 %doc doc/*.html
86 %doc doc/compile.txt
87 %doc doc/grc.txt
88 %doc doc/internal.txt
89 %doc doc/newvers.txt
90 %doc samples
91 %doc src/ld65/cfg/*.cfg
92
93
94
95 ###############################################################################
96 #                             Apple ][ subpackage                             #
97 ###############################################################################
98
99 %package apple2
100 Requires: %{name} = %{version}
101 Copyright: Freeware
102 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
103 Group: Development/Languages
104
105 %description apple2
106 This package contains the header files and libraries needed to write
107 programs for the Apple ][ using the cc65 crosscompiler.
108
109 %files apple2
110 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
111 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
112 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
113
114
115
116 ###############################################################################
117 #                              Atari subpackage                               #
118 ###############################################################################
119
120 %package atari
121 Requires: %{name} = %{version}
122 Copyright: Freeware
123 Summary: Atari specific libraries and headers for the cc65 compiler.
124 Group: Development/Languages
125
126 %description atari
127 This package contains the header files and libraries needed to write
128 programs for the 8 bit Atari machines using the cc65 crosscompiler.
129
130 %files atari
131 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
132 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
133
134
135
136 ###############################################################################
137 #                            Oric Atmos subpackage                            #
138 ###############################################################################
139
140 %package atmos
141 Requires: %{name} = %{version}
142 Copyright: Freeware
143 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
144 Group: Development/Languages
145
146 %description atmos
147 This package contains the header files and libraries needed to write
148 programs for the Oric Atmos using the cc65 crosscompiler.
149
150 %files atmos
151 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
152 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
153
154
155
156 ###############################################################################
157 #                               C128 subpackage                               #
158 ###############################################################################
159
160 %package c128
161 Requires: %{name} = %{version}
162 Copyright: Freeware
163 Summary: C128 specific libraries and headers for the cc65 compiler.
164 Group: Development/Languages
165
166 %description c128
167 This package contains the header files and libraries needed to write
168 programs for the Commodore C128 using the cc65 crosscompiler.
169
170 %files c128
171 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
172 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
173 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
174 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
175 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
176
177
178
179 ###############################################################################
180 #                                C16 subpackage                               #
181 ###############################################################################
182
183 %package c16
184 Requires: %{name} = %{version}
185 Copyright: Freeware
186 Summary: C16/116 specific libraries and headers for the cc65 compiler.
187 Group: Development/Languages
188
189 %description c16
190 This package contains the header files and libraries needed to write
191 programs for the Commodore C16/116 using the cc65 crosscompiler.
192
193 %files c16
194 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
195 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
196 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
197
198
199
200 ###############################################################################
201 #                               C64 subpackage                                #
202 ###############################################################################
203
204 %package c64
205 Requires: %{name} = %{version}
206 Copyright: Freeware
207 Summary: C64 specific libraries and headers for the cc65 compiler.
208 Group: Development/Languages
209
210 %description c64
211 This package contains the header files and libraries needed to write
212 programs for the Commodore C64 using the cc65 crosscompiler.
213
214 %files c64
215 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
216 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
217 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
218 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
219 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
220
221
222
223 ###############################################################################
224 #                              CBM510 subpackage                              #
225 ###############################################################################
226
227 %package cbm510
228 Requires: %{name} = %{version}
229 Copyright: Freeware
230 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
231 Group: Development/Languages
232
233 %description cbm510
234 This package contains the header files and libraries needed to write
235 programs for the Commodore CBM 510 (aka P500) using the cc65
236 crosscompiler.
237
238 %files cbm510
239 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
240 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
241 %attr(644,root,root)            /usr/lib/cc65/emd/cbm510-*.emd
242 %attr(644,root,root)            /usr/lib/cc65/joy/cbm510-*.joy
243
244
245
246 ###############################################################################
247 #                              CBM610 subpackage                              #
248 ###############################################################################
249
250 %package cbm610
251 Requires: %{name} = %{version}
252 Copyright: Freeware
253 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
254 Group: Development/Languages
255
256 %description cbm610
257 This package contains the header files and libraries needed to write
258 programs for the Commodore PET-II (CBM600/700) family of computers using
259 the cc65 crosscompiler.
260
261 %files cbm610
262 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
263 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
264 %attr(644,root,root)            /usr/lib/cc65/emd/cbm610-*.emd
265
266
267
268 ###############################################################################
269 #                               GEOS subpackage                               #
270 ###############################################################################
271
272 %package geos
273 Requires: %{name} = %{version}
274 Copyright: Freeware
275 Summary: GEOS specific libraries and headers for the cc65 compiler.
276 Group: Development/Languages
277
278 %description geos
279 This package contains the header files and libraries needed to write
280 GEOS programs for the C64/C128 using the cc65 crosscompiler.
281
282 %files geos
283 %attr(755,root,root)            /usr/bin/grc
284 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
285 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
286 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
287 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
288 %attr(644,root,root)            /usr/lib/cc65/emd/geos-*.emd
289 %attr(644,root,root)            /usr/lib/cc65/joy/geos-*.joy
290 %attr(644,root,root)            /usr/lib/cc65/tgi/geos-*.tgi
291                                                       
292
293
294 ###############################################################################
295 #                               NES subpackage                                #
296 ###############################################################################
297
298 %package nes
299 Requires: %{name} = %{version}
300 Copyright: Freeware
301 Summary: NES specific libraries and headers for the cc65 compiler.
302 Group: Development/Languages
303
304 %description nes
305 This package contains the header files and libraries needed to write
306 programs for the Nintendo Entertainment System using the cc65
307 crosscompiler.
308
309 %files nes
310 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
311 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
312
313
314
315 ###############################################################################
316 #                               PET subpackage                                #
317 ###############################################################################
318
319 %package pet
320 Requires: %{name} = %{version}
321 Copyright: Freeware
322 Summary: PET specific libraries and headers for the cc65 compiler.
323 Group: Development/Languages
324
325 %description pet
326 This package contains the header files and libraries needed to write
327 programs for the Commodore PET family of computers using the cc65
328 crosscompiler.
329
330 %files pet
331 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
332 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
333
334
335
336 ###############################################################################
337 #                              Plus/4 subpackage                              #
338 ###############################################################################
339
340 %package plus4
341 Requires: %{name} = %{version}
342 Copyright: Freeware
343 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
344 Group: Development/Languages
345
346 %description plus4
347 This package contains the header files and libraries needed to write
348 programs for the Commodore Plus/4 and C16/116 using the cc65
349 crosscompiler.
350
351 %files plus4
352 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
353 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
354 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
355
356
357
358 ###############################################################################
359 #                           Supervision subpackage                            #
360 ###############################################################################
361
362 %package supervision
363 Requires: %{name} = %{version}
364 Copyright: Freeware
365 Summary: Supervision specific libraries and headers for the cc65 compiler.
366 Group: Development/Languages
367
368 %description supervision
369 This package contains the header files and libraries needed to write
370 programs for the Supervision Game console using the cc65 crosscompiler.
371
372 %files supervision
373 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
374 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
375
376
377
378 ###############################################################################
379 #                              VIC20 subpackage                               #
380 ###############################################################################
381
382 %package vic20
383 Requires: %{name} = %{version}
384 Copyright: Freeware
385 Summary: VIC20 specific libraries and headers for the cc65 compiler.
386 Group: Development/Languages
387
388 %description vic20
389 This package contains the header files and libraries needed to write
390 programs for the Commodore VIC20 using the cc65 crosscompiler.
391
392 %files vic20
393 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
394 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
395 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
396
397
398
399 ###############################################################################
400 #                                    Build                                    #
401 ###############################################################################
402
403
404
405 %prep
406 %setup -q
407
408
409 %build
410 # Binaries
411 make -C src -f make/gcc.mak
412 # Libraries
413 make -C libsrc -s zap all
414 # Documentation
415 make -C doc html
416
417
418 %install
419 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,tgi}}
420
421 # Binaries
422 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
423 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
424 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
425 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
426 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
427 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
428 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
429 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
430 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
431 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
432 # Libraries and includes
433 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
434 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
435 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
436 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
437 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
438 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
439 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
440 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
441
442 # Drivers
443 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
444 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
445 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
446
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451
452
453 %changelog
454 * Sun Nov 02 2003 Ullrich von Bassewitz <uz@cc65.org>
455 - Added missing files after upgrade to rpm 4.2
456
457 * Sun Oct 19 2003 Ullrich von Bassewitz <uz@cc65.org>
458 - Move documentation into a separate doc package.
459
460 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
461 - Added the Supervision subpackage.
462
463 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
464 - Better cleanup.
465
466 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
467 - Added subdirectories of include/
468
469 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
470 - The Apple ][ has a joystick driver.
471 - Added the NES subpackage.
472
473 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
474 Added a subpackage for the Oric Atmos.
475
476 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
477 Added the object file conversion utility co65.
478
479 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
480 Updated the version number.
481
482 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
483 Changed location of TGI drivers, added EM drivers.
484
485 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
486 Added the C16 subpackage.
487
488 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
489 Added TGI stuff.
490
491 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
492 Update to version 2.8.0 of the compiler package.
493
494 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
495 Update to version 2.7.1 of the compiler package.
496
497 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
498 Update to version 2.7.0 of the compiler package.
499
500 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
501 Update to version 2.6.2 of the compiler package.
502
503 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
504 Update to version 2.6.1 of the compiler package.
505
506 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
507 Update for cc65 2.6.0 and RedHat 7.x
508
509 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
510 The GEOS include files were not installed, remove headegen.sh
511
512 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
513 Update to version 2.5.0 of the compiler package.
514
515 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
516 Update to version 2.4.1 of the compiler package.
517
518 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
519 Update to version 2.4.0 of the compiler package.
520
521 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
522 Update to version 2.3.1 of the compiler package.
523
524 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
525 Update to version 2.3.0 of the compiler package.
526
527 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
528 [2.2.1-2]
529 - changed to allow build as plain user
530 - `samples' are part of documentation, not part of library
531