]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added the supervision subpackage
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/co65
52 %attr(755,root,root)            /usr/bin/da65
53 %attr(755,root,root)            /usr/bin/ld65
54 %attr(755,root,root)            /usr/bin/od65
55 %attr(755,root,root) %dir       /usr/lib/cc65
56 %attr(755,root,root) %dir       /usr/lib/cc65/emd
57 %attr(755,root,root) %dir       /usr/lib/cc65/joy
58 %attr(755,root,root) %dir       /usr/lib/cc65/lib
59 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
60 %attr(755,root,root) %dir       /usr/lib/cc65/include
61 %attr(644,root,root)            /usr/lib/cc65/include/*.h
62 %attr(644,root,root)            /usr/lib/cc65/include/sys/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
64 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
65 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
66 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
67
68
69
70 ###############################################################################
71 #                             Apple ][ subpackage                             #
72 ###############################################################################
73
74 %package apple2
75 Requires: %{name} = %{version}
76 Copyright: Freeware
77 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
78 Group: Development/Languages
79
80 %description apple2
81 This package contains the header files and libraries needed to write
82 programs for the Apple ][ using the cc65 crosscompiler.
83
84 %files apple2
85 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
86 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
87 %attr(644,root,root)            /usr/lib/cc65/joy/a2-*.joy
88 %doc src/ld65/cfg/apple2.cfg
89
90
91
92 ###############################################################################
93 #                              Atari subpackage                               #
94 ###############################################################################
95
96 %package atari
97 Requires: %{name} = %{version}
98 Copyright: Freeware
99 Summary: Atari specific libraries and headers for the cc65 compiler.
100 Group: Development/Languages
101
102 %description atari
103 This package contains the header files and libraries needed to write
104 programs for the 8 bit Atari machines using the cc65 crosscompiler.
105
106 %files atari
107 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
108 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
109 %doc src/ld65/cfg/atari.cfg
110
111
112
113 ###############################################################################
114 #                            Oric Atmos subpackage                            #
115 ###############################################################################
116
117 %package atmos
118 Requires: %{name} = %{version}
119 Copyright: Freeware
120 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
121 Group: Development/Languages
122
123 %description atmos
124 This package contains the header files and libraries needed to write
125 programs for the Oric Atmos using the cc65 crosscompiler.
126
127 %files atmos
128 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
129 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
130 %doc src/ld65/cfg/atmos.cfg
131
132
133
134 ###############################################################################
135 #                               C128 subpackage                               #
136 ###############################################################################
137
138 %package c128
139 Requires: %{name} = %{version}
140 Copyright: Freeware
141 Summary: C128 specific libraries and headers for the cc65 compiler.
142 Group: Development/Languages
143
144 %description c128
145 This package contains the header files and libraries needed to write
146 programs for the Commodore C128 using the cc65 crosscompiler.
147
148 %files c128
149 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
150 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
151 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
152 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
153 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
154 %doc src/ld65/cfg/c128.cfg
155
156
157
158 ###############################################################################
159 #                                C16 subpackage                               #
160 ###############################################################################
161
162 %package c16
163 Requires: %{name} = %{version}
164 Copyright: Freeware
165 Summary: C16/116 specific libraries and headers for the cc65 compiler.
166 Group: Development/Languages
167
168 %description c16
169 This package contains the header files and libraries needed to write
170 programs for the Commodore C16/116 using the cc65 crosscompiler.
171
172 %files c16
173 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
174 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
175 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
176 %doc src/ld65/cfg/c16.cfg
177
178
179
180 ###############################################################################
181 #                               C64 subpackage                                #
182 ###############################################################################
183
184 %package c64
185 Requires: %{name} = %{version}
186 Copyright: Freeware
187 Summary: C64 specific libraries and headers for the cc65 compiler.
188 Group: Development/Languages
189
190 %description c64
191 This package contains the header files and libraries needed to write
192 programs for the Commodore C64 using the cc65 crosscompiler.
193
194 %files c64
195 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
196 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
197 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
198 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
199 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
200 %doc src/ld65/cfg/c64.cfg
201
202
203
204 ###############################################################################
205 #                              CBM510 subpackage                              #
206 ###############################################################################
207
208 %package cbm510
209 Requires: %{name} = %{version}
210 Copyright: Freeware
211 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
212 Group: Development/Languages
213
214 %description cbm510
215 This package contains the header files and libraries needed to write
216 programs for the Commodore CBM 510 (aka P500) using the cc65
217 crosscompiler.
218
219 %files cbm510
220 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
221 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
222 %doc src/ld65/cfg/cbm510.cfg
223
224
225
226 ###############################################################################
227 #                              CBM610 subpackage                              #
228 ###############################################################################
229
230 %package cbm610
231 Requires: %{name} = %{version}
232 Copyright: Freeware
233 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
234 Group: Development/Languages
235
236 %description cbm610
237 This package contains the header files and libraries needed to write
238 programs for the Commodore PET-II (CBM600/700) family of computers using
239 the cc65 crosscompiler.
240
241 %files cbm610
242 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
243 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
244 %doc src/ld65/cfg/cbm610.cfg
245
246
247
248 ###############################################################################
249 #                               GEOS subpackage                               #
250 ###############################################################################
251
252 %package geos
253 Requires: %{name} = %{version}
254 Copyright: Freeware
255 Summary: GEOS specific libraries and headers for the cc65 compiler.
256 Group: Development/Languages
257
258 %description geos
259 This package contains the header files and libraries needed to write
260 GEOS programs for the C64/C128 using the cc65 crosscompiler.
261
262 %files geos
263 %attr(755,root,root)            /usr/bin/grc
264 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
265 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
266 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
267 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
268 %doc src/ld65/cfg/geos.cfg
269
270
271
272 ###############################################################################
273 #                               NES subpackage                                #
274 ###############################################################################
275
276 %package nes
277 Requires: %{name} = %{version}
278 Copyright: Freeware
279 Summary: NES specific libraries and headers for the cc65 compiler.
280 Group: Development/Languages
281
282 %description nes
283 This package contains the header files and libraries needed to write
284 programs for the Nintendo Entertainment System using the cc65
285 crosscompiler.
286
287 %files nes
288 %attr(644,root,root)            /usr/lib/cc65/lib/nes.lib
289 %attr(644,root,root)            /usr/lib/cc65/lib/nes.o
290 %doc src/ld65/cfg/nes.cfg
291
292
293
294 ###############################################################################
295 #                               PET subpackage                                #
296 ###############################################################################
297
298 %package pet
299 Requires: %{name} = %{version}
300 Copyright: Freeware
301 Summary: PET specific libraries and headers for the cc65 compiler.
302 Group: Development/Languages
303
304 %description pet
305 This package contains the header files and libraries needed to write
306 programs for the Commodore PET family of computers using the cc65
307 crosscompiler.
308
309 %files pet
310 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
311 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
312 %doc src/ld65/cfg/pet.cfg
313
314
315
316 ###############################################################################
317 #                              Plus/4 subpackage                              #
318 ###############################################################################
319
320 %package plus4
321 Requires: %{name} = %{version}
322 Copyright: Freeware
323 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
324 Group: Development/Languages
325
326 %description plus4
327 This package contains the header files and libraries needed to write
328 programs for the Commodore Plus/4 and C16/116 using the cc65
329 crosscompiler.
330
331 %files plus4
332 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
333 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
334 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
335 %doc src/ld65/cfg/plus4.cfg
336
337
338
339 ###############################################################################
340 #                           Supervision subpackage                            #
341 ###############################################################################
342
343 %package supervision
344 Requires: %{name} = %{version}
345 Copyright: Freeware
346 Summary: Supervision specific libraries and headers for the cc65 compiler.
347 Group: Development/Languages
348
349 %description supervision
350 This package contains the header files and libraries needed to write
351 programs for the Supervision Game console using the cc65 crosscompiler.
352
353 %files supervision
354 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.lib
355 %attr(644,root,root)            /usr/lib/cc65/lib/supervision.o
356 %doc src/ld65/cfg/supervision.cfg
357
358
359
360 ###############################################################################
361 #                              VIC20 subpackage                               #
362 ###############################################################################
363
364 %package vic20
365 Requires: %{name} = %{version}
366 Copyright: Freeware
367 Summary: VIC20 specific libraries and headers for the cc65 compiler.
368 Group: Development/Languages
369
370 %description vic20
371 This package contains the header files and libraries needed to write
372 programs for the Commodore VIC20 using the cc65 crosscompiler.
373
374 %files vic20
375 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
376 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
377 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
378 %doc src/ld65/cfg/vic20.cfg
379
380
381
382 ###############################################################################
383 #                                    Build                                    #
384 ###############################################################################
385
386
387
388 %prep
389 %setup -q
390
391
392 %build
393 # Binaries
394 cd src; make -f make/gcc.mak; cd ..
395 # Libraries
396 cd libsrc; make -s zap all; cd ..
397 # Documentation
398 cd doc; make html; cd ..
399
400
401 %install
402 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{em,geos,joystick,sys,tgi},joy,lib,tgi}}
403
404 # Binaries
405 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
406 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
407 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
408 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
409 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
410 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
411 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
412 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
413 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
414 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
415 # Libraries and includes
416 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
417 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
418 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
419 install -m 644 include/em/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/em
420 install -m 644 include/joystick/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/joystick
421 install -m 644 include/sys/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/sys
422 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
423 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
424
425 # Drivers
426 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
427 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
428 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
429
430
431 %clean
432 rm -rf $RPM_BUILD_ROOT
433
434
435
436 %changelog
437 * Fri Oct 10 2003 Ullrich von Bassewitz <uz@cc65.org>
438 - Added the Supervision subpackage.
439
440 * Thu Oct 02 2003 Ullrich von Bassewitz <uz@cc65.org>
441 - Better cleanup.
442
443 * Thu Jun 12 2003 Ullrich von Bassewitz <uz@cc65.org>
444 - Added subdirectories of include/
445
446 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
447 - The Apple ][ has a joystick driver.
448 - Added the NES subpackage.
449
450 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
451 Added a subpackage for the Oric Atmos.
452
453 %changelog
454 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
455 Added the object file conversion utility co65.
456
457 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
458 Updated the version number.
459
460 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
461 Changed location of TGI drivers, added EM drivers.
462
463 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
464 Added the C16 subpackage.
465
466 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
467 Added TGI stuff.
468
469 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
470 Update to version 2.8.0 of the compiler package.
471
472 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
473 Update to version 2.7.1 of the compiler package.
474
475 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
476 Update to version 2.7.0 of the compiler package.
477
478 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
479 Update to version 2.6.2 of the compiler package.
480
481 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
482 Update to version 2.6.1 of the compiler package.
483
484 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
485 Update for cc65 2.6.0 and RedHat 7.x
486
487 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
488 The GEOS include files were not installed, remove headegen.sh
489
490 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
491 Update to version 2.5.0 of the compiler package.
492
493 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
494 Update to version 2.4.1 of the compiler package.
495
496 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
497 Update to version 2.4.0 of the compiler package.
498
499 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
500 Update to version 2.3.1 of the compiler package.
501
502 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
503 Update to version 2.3.0 of the compiler package.
504
505 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
506 [2.2.1-2]
507 - changed to allow build as plain user
508 - `samples' are part of documentation, not part of library
509