]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Working on the auto build
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.8.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/da65
52 %attr(755,root,root)            /usr/bin/ld65
53 %attr(755,root,root)            /usr/bin/od65
54 %attr(755,root,root) %dir       /usr/lib/cc65
55 %attr(755,root,root) %dir       /usr/lib/cc65/lib
56 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
57 %attr(755,root,root) %dir       /usr/lib/cc65/include
58 %attr(644,root,root)            /usr/lib/cc65/include/*.h
59 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
60 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
62 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
63
64
65
66 ###############################################################################
67 #                              VIC20 subpackage                               #
68 ###############################################################################
69
70 %package vic20
71 Requires: cc65 = %{version}
72 Copyright: Freeware
73 Summary: VIC20 specific libraries and headers for the cc65 compiler.
74 Group: Development/Languages
75
76 %description vic20
77 This package contains the header files and libraries needed to write
78 programs for the Commodore VIC20 using the cc65 crosscompiler.
79
80 %files vic20
81 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
82 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
83 %doc src/ld65/cfg/vic20.cfg
84
85
86
87 ###############################################################################
88 #                               C64 subpackage                                #
89 ###############################################################################
90
91 %package c64
92 Requires: cc65 = %{version}
93 Copyright: Freeware
94 Summary: C64 specific libraries and headers for the cc65 compiler.
95 Group: Development/Languages
96
97 %description c64
98 This package contains the header files and libraries needed to write
99 programs for the Commodore C64 using the cc65 crosscompiler.
100
101 %files c64
102 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
103 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
104 %attr(755,root,root) %dir       /usr/lib/cc65/tgi/c64
105 %attr(644,root,root)            /usr/lib/cc65/tgi/c64/c64-*.tgi
106 %doc src/ld65/cfg/c64.cfg
107
108
109
110 ###############################################################################
111 #                               C128 subpackage                               #
112 ###############################################################################
113
114 %package c128
115 Requires: cc65 = %{version}
116 Copyright: Freeware
117 Summary: C128 specific libraries and headers for the cc65 compiler.
118 Group: Development/Languages
119
120 %description c128
121 This package contains the header files and libraries needed to write
122 programs for the Commodore C128 using the cc65 crosscompiler.
123
124 %files c128
125 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
126 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
127 %doc src/ld65/cfg/c128.cfg
128
129
130
131 ###############################################################################
132 #                              Atari subpackage                               #
133 ###############################################################################
134
135 %package atari
136 Requires: cc65 = %{version}
137 Copyright: Freeware
138 Summary: Atari specific libraries and headers for the cc65 compiler.
139 Group: Development/Languages
140
141 %description atari
142 This package contains the header files and libraries needed to write
143 programs for the 8 bit Atari machines using the cc65 crosscompiler.
144
145 %files atari
146 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
147 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
148 %doc src/ld65/cfg/atari.cfg
149
150
151
152 ###############################################################################
153 #                              Plus/4 subpackage                              #
154 ###############################################################################
155
156 %package plus4
157 Requires: cc65 = %{version}
158 Copyright: Freeware
159 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
160 Group: Development/Languages
161
162 %description plus4
163 This package contains the header files and libraries needed to write
164 programs for the Commodore Plus/4 and C16/116 using the cc65
165 crosscompiler.
166
167 %files plus4
168 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
169 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
170 %doc src/ld65/cfg/plus4.cfg
171
172
173
174 ###############################################################################
175 #                               PET subpackage                                #
176 ###############################################################################
177
178 %package pet
179 Requires: cc65 = %{version}
180 Copyright: Freeware
181 Summary: PET specific libraries and headers for the cc65 compiler.
182 Group: Development/Languages
183
184 %description pet
185 This package contains the header files and libraries needed to write
186 programs for the Commodore PET family of computers using the cc65
187 crosscompiler.
188
189 %files pet
190 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
191 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
192 %doc src/ld65/cfg/pet.cfg
193
194
195
196 ###############################################################################
197 #                              CBM510 subpackage                              #
198 ###############################################################################
199
200 %package cbm510
201 Requires: cc65 = %{version}
202 Copyright: Freeware
203 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
204 Group: Development/Languages
205
206 %description cbm510
207 This package contains the header files and libraries needed to write
208 programs for the Commodore CBM 510 (aka P500) using the cc65
209 crosscompiler.
210
211 %files cbm510
212 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
213 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
214 %doc src/ld65/cfg/cbm510.cfg
215
216
217
218 ###############################################################################
219 #                              CBM610 subpackage                              #
220 ###############################################################################
221
222 %package cbm610
223 Requires: cc65 = %{version}
224 Copyright: Freeware
225 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
226 Group: Development/Languages
227
228 %description cbm610
229 This package contains the header files and libraries needed to write
230 programs for the Commodore PET-II (CBM600/700) family of computers using
231 the cc65 crosscompiler.
232
233 %files cbm610
234 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
235 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
236 %doc src/ld65/cfg/cbm610.cfg
237
238
239
240 ###############################################################################
241 #                             Apple ][ subpackage                             #
242 ###############################################################################
243
244 %package apple2
245 Requires: cc65 = %{version}
246 Copyright: Freeware
247 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
248 Group: Development/Languages
249
250 %description apple2
251 This package contains the header files and libraries needed to write
252 programs for the Apple ][ using the cc65 crosscompiler.
253
254 %files apple2
255 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
256 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
257 %doc src/ld65/cfg/apple2.cfg
258
259
260
261 ###############################################################################
262 #                               GEOS subpackage                               #
263 ###############################################################################
264
265 %package geos
266 Requires: cc65 = %{version}
267 Copyright: Freeware
268 Summary: GEOS specific libraries and headers for the cc65 compiler.
269 Group: Development/Languages
270
271 %description geos
272 This package contains the header files and libraries needed to write
273 GEOS programs for the C64/C128 using the cc65 crosscompiler.
274
275 %files geos
276 %attr(755,root,root)            /usr/bin/grc
277 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
278 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
279 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
280 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
281 %doc src/ld65/cfg/geos.cfg
282
283
284
285 ###############################################################################
286 #                                    Build                                    #
287 ###############################################################################
288
289
290
291 %prep
292 %setup
293
294
295 %build
296 # Binaries
297 cd src
298 make -f make/gcc.mak
299 cd ..
300 # Libraries
301 cd libsrc
302 make -s zap all
303 cd ..
304 # Documentation
305 cd doc
306 make html
307 cd ..
308
309
310 %install
311 mkdir -p
312 $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{tgi/{c64},lib,include/{geos,tgi},asminc}}
313
314 # Binaries
315 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
316 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
317 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
318 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
319 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
320 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
321 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
322 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
323 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
324 # Libraries and includes
325 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
326 install -m 644 libsrc/c64-*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi/c64
327 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
328 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
329 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
330 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
331
332
333 %changelog
334 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
335 Added TGI stuff.
336
337 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
338 Update to version 2.8.0 of the compiler package.
339
340 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
341 Update to version 2.7.1 of the compiler package.
342
343 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
344 Update to version 2.7.0 of the compiler package.
345
346 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
347 Update to version 2.6.2 of the compiler package.
348
349 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
350 Update to version 2.6.1 of the compiler package.
351
352 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
353 Update for cc65 2.6.0 and RedHat 7.x
354
355 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
356 The GEOS include files were not installed, remove headegen.sh
357
358 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
359 Update to version 2.5.0 of the compiler package.
360
361 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
362 Update to version 2.4.1 of the compiler package.
363
364 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
365 Update to version 2.4.0 of the compiler package.
366
367 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
368 Update to version 2.3.1 of the compiler package.
369
370 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
371 Update to version 2.3.0 of the compiler package.
372
373 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
374 [2.2.1-2]
375 - changed to allow build as plain user
376 - `samples' are part of documentation, not part of library
377