]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added joystick driver for Apple ][
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/co65
52 %attr(755,root,root)            /usr/bin/da65
53 %attr(755,root,root)            /usr/bin/ld65
54 %attr(755,root,root)            /usr/bin/od65
55 %attr(755,root,root) %dir       /usr/lib/cc65
56 %attr(755,root,root) %dir       /usr/lib/cc65/emd
57 %attr(755,root,root) %dir       /usr/lib/cc65/joy
58 %attr(755,root,root) %dir       /usr/lib/cc65/lib
59 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
60 %attr(755,root,root) %dir       /usr/lib/cc65/include
61 %attr(644,root,root)            /usr/lib/cc65/include/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
63 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
64 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
65 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
66
67
68
69 ###############################################################################
70 #                              VIC20 subpackage                               #
71 ###############################################################################
72
73 %package vic20
74 Requires: %{name} = %{version}
75 Copyright: Freeware
76 Summary: VIC20 specific libraries and headers for the cc65 compiler.
77 Group: Development/Languages
78
79 %description vic20
80 This package contains the header files and libraries needed to write
81 programs for the Commodore VIC20 using the cc65 crosscompiler.
82
83 %files vic20
84 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
85 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
86 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
87 %doc src/ld65/cfg/vic20.cfg
88
89
90
91 ###############################################################################
92 #                                C16 subpackage                               #
93 ###############################################################################
94
95 %package c16
96 Requires: %{name} = %{version}
97 Copyright: Freeware
98 Summary: C16/116 specific libraries and headers for the cc65 compiler.
99 Group: Development/Languages
100
101 %description c16
102 This package contains the header files and libraries needed to write
103 programs for the Commodore C16/116 using the cc65 crosscompiler.
104
105 %files c16
106 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
107 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
108 %attr(644,root,root)            /usr/lib/cc65/joy/c16-*.joy
109 %doc src/ld65/cfg/c16.cfg
110
111
112
113 ###############################################################################
114 #                               C64 subpackage                                #
115 ###############################################################################
116
117 %package c64
118 Requires: %{name} = %{version}
119 Copyright: Freeware
120 Summary: C64 specific libraries and headers for the cc65 compiler.
121 Group: Development/Languages
122
123 %description c64
124 This package contains the header files and libraries needed to write
125 programs for the Commodore C64 using the cc65 crosscompiler.
126
127 %files c64
128 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
129 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
130 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
131 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
132 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
133 %doc src/ld65/cfg/c64.cfg
134
135
136
137 ###############################################################################
138 #                               C128 subpackage                               #
139 ###############################################################################
140
141 %package c128
142 Requires: %{name} = %{version}
143 Copyright: Freeware
144 Summary: C128 specific libraries and headers for the cc65 compiler.
145 Group: Development/Languages
146
147 %description c128
148 This package contains the header files and libraries needed to write
149 programs for the Commodore C128 using the cc65 crosscompiler.
150
151 %files c128
152 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
153 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
154 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
155 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
156 %attr(644,root,root)            /usr/lib/cc65/tgi/c128-*.tgi
157 %doc src/ld65/cfg/c128.cfg
158
159
160
161 ###############################################################################
162 #                              Atari subpackage                               #
163 ###############################################################################
164
165 %package atari
166 Requires: %{name} = %{version}
167 Copyright: Freeware
168 Summary: Atari specific libraries and headers for the cc65 compiler.
169 Group: Development/Languages
170
171 %description atari
172 This package contains the header files and libraries needed to write
173 programs for the 8 bit Atari machines using the cc65 crosscompiler.
174
175 %files atari
176 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
177 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
178 %doc src/ld65/cfg/atari.cfg
179
180
181
182 ###############################################################################
183 #                              Plus/4 subpackage                              #
184 ###############################################################################
185
186 %package plus4
187 Requires: %{name} = %{version}
188 Copyright: Freeware
189 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
190 Group: Development/Languages
191
192 %description plus4
193 This package contains the header files and libraries needed to write
194 programs for the Commodore Plus/4 and C16/116 using the cc65
195 crosscompiler.
196
197 %files plus4
198 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
199 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
200 %attr(644,root,root)            /usr/lib/cc65/joy/plus4-*.joy
201 %doc src/ld65/cfg/plus4.cfg
202
203
204
205 ###############################################################################
206 #                               PET subpackage                                #
207 ###############################################################################
208
209 %package pet
210 Requires: %{name} = %{version}
211 Copyright: Freeware
212 Summary: PET specific libraries and headers for the cc65 compiler.
213 Group: Development/Languages
214
215 %description pet
216 This package contains the header files and libraries needed to write
217 programs for the Commodore PET family of computers using the cc65
218 crosscompiler.
219
220 %files pet
221 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
222 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
223 %doc src/ld65/cfg/pet.cfg
224
225
226
227 ###############################################################################
228 #                              CBM510 subpackage                              #
229 ###############################################################################
230
231 %package cbm510
232 Requires: %{name} = %{version}
233 Copyright: Freeware
234 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
235 Group: Development/Languages
236
237 %description cbm510
238 This package contains the header files and libraries needed to write
239 programs for the Commodore CBM 510 (aka P500) using the cc65
240 crosscompiler.
241
242 %files cbm510
243 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
244 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
245 %doc src/ld65/cfg/cbm510.cfg
246
247
248
249 ###############################################################################
250 #                              CBM610 subpackage                              #
251 ###############################################################################
252
253 %package cbm610
254 Requires: %{name} = %{version}
255 Copyright: Freeware
256 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
257 Group: Development/Languages
258
259 %description cbm610
260 This package contains the header files and libraries needed to write
261 programs for the Commodore PET-II (CBM600/700) family of computers using
262 the cc65 crosscompiler.
263
264 %files cbm610
265 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
266 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
267 %doc src/ld65/cfg/cbm610.cfg
268
269
270
271 ###############################################################################
272 #                             Apple ][ subpackage                             #
273 ###############################################################################
274
275 %package apple2
276 Requires: %{name} = %{version}
277 Copyright: Freeware
278 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
279 Group: Development/Languages
280
281 %description apple2
282 This package contains the header files and libraries needed to write
283 programs for the Apple ][ using the cc65 crosscompiler.
284
285 %files apple2
286 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
287 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
288 %attr(644,root,root)            /usr/lib/cc65/joy/apple2-*.joy
289 %doc src/ld65/cfg/apple2.cfg
290
291
292
293 ###############################################################################
294 #                            Oric Atmos subpackage                            #
295 ###############################################################################
296
297 %package atmos
298 Requires: %{name} = %{version}
299 Copyright: Freeware
300 Summary: Oric Atmos specific libraries and headers for the cc65 compiler.
301 Group: Development/Languages
302
303 %description atmos
304 This package contains the header files and libraries needed to write
305 programs for the Oric Atmos using the cc65 crosscompiler.
306
307 %files atmos
308 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.lib
309 %attr(644,root,root)            /usr/lib/cc65/lib/atmos.o
310 %doc src/ld65/cfg/atmos.cfg
311
312
313
314 ###############################################################################
315 #                               GEOS subpackage                               #
316 ###############################################################################
317
318 %package geos
319 Requires: %{name} = %{version}
320 Copyright: Freeware
321 Summary: GEOS specific libraries and headers for the cc65 compiler.
322 Group: Development/Languages
323
324 %description geos
325 This package contains the header files and libraries needed to write
326 GEOS programs for the C64/C128 using the cc65 crosscompiler.
327
328 %files geos
329 %attr(755,root,root)            /usr/bin/grc
330 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
331 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
332 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
333 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
334 %doc src/ld65/cfg/geos.cfg
335
336
337
338 ###############################################################################
339 #                                    Build                                    #
340 ###############################################################################
341
342
343
344 %prep
345 %setup
346
347
348 %build
349 # Binaries
350 cd src
351 make -f make/gcc.mak
352 cd ..
353 # Libraries
354 cd libsrc
355 make -s zap all
356 cd ..
357 # Documentation
358 cd doc
359 make html
360 cd ..
361
362
363 %install
364 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{geos,tgi},joy,lib,tgi}}
365
366 # Binaries
367 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
368 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
369 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
370 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
371 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
372 install -s -m 755 src/co65/co65 $RPM_BUILD_ROOT/usr/bin
373 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
374 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
375 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
376 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
377 # Libraries and includes
378 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
379 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
380 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
381 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
382 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
383
384 # Drivers
385 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
386 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
387 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
388
389
390
391 %changelog
392 * Fri May 02 2003 Ullrich von Bassewitz <uz@cc65.org>
393 The Apple ][ has a joystick driver.
394
395 * Mon Apr 14 2003 Ullrich von Bassewitz <uz@cc65.org>
396 Added a subpackage for the Oric Atmos.
397
398 %changelog
399 * Mon Feb 10 2003 Ullrich von Bassewitz <uz@cc65.org>
400 Added the object file conversion utility co65.
401
402 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
403 Updated the version number.
404
405 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
406 Changed location of TGI drivers, added EM drivers.
407
408 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
409 Added the C16 subpackage.
410
411 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
412 Added TGI stuff.
413
414 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
415 Update to version 2.8.0 of the compiler package.
416
417 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
418 Update to version 2.7.1 of the compiler package.
419
420 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
421 Update to version 2.7.0 of the compiler package.
422
423 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
424 Update to version 2.6.2 of the compiler package.
425
426 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
427 Update to version 2.6.1 of the compiler package.
428
429 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
430 Update for cc65 2.6.0 and RedHat 7.x
431
432 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
433 The GEOS include files were not installed, remove headegen.sh
434
435 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
436 Update to version 2.5.0 of the compiler package.
437
438 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
439 Update to version 2.4.1 of the compiler package.
440
441 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
442 Update to version 2.4.0 of the compiler package.
443
444 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
445 Update to version 2.3.1 of the compiler package.
446
447 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
448 Update to version 2.3.0 of the compiler package.
449
450 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
451 [2.2.1-2]
452 - changed to allow build as plain user
453 - `samples' are part of documentation, not part of library
454