]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Added joystick drivers
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/da65
52 %attr(755,root,root)            /usr/bin/ld65
53 %attr(755,root,root)            /usr/bin/od65
54 %attr(755,root,root) %dir       /usr/lib/cc65
55 %attr(755,root,root) %dir       /usr/lib/cc65/emd
56 %attr(755,root,root) %dir       /usr/lib/cc65/joy
57 %attr(755,root,root) %dir       /usr/lib/cc65/lib
58 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
59 %attr(755,root,root) %dir       /usr/lib/cc65/include
60 %attr(644,root,root)            /usr/lib/cc65/include/*.h
61 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
62 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
63 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
64 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
65
66
67
68 ###############################################################################
69 #                              VIC20 subpackage                               #
70 ###############################################################################
71
72 %package vic20
73 Requires: %{name} = %{version}
74 Copyright: Freeware
75 Summary: VIC20 specific libraries and headers for the cc65 compiler.
76 Group: Development/Languages
77
78 %description vic20
79 This package contains the header files and libraries needed to write
80 programs for the Commodore VIC20 using the cc65 crosscompiler.
81
82 %files vic20
83 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
84 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
85 %attr(644,root,root)            /usr/lib/cc65/joy/vic20-*.joy
86 %doc src/ld65/cfg/vic20.cfg
87
88
89
90 ###############################################################################
91 #                                C16 subpackage                               #
92 ###############################################################################
93
94 %package c16
95 Requires: %{name} = %{version}
96 Copyright: Freeware
97 Summary: C16/116 specific libraries and headers for the cc65 compiler.
98 Group: Development/Languages
99
100 %description c16
101 This package contains the header files and libraries needed to write
102 programs for the Commodore C16/116 using the cc65 crosscompiler.
103
104 %files c16
105 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
106 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
107 %doc src/ld65/cfg/c16.cfg
108
109
110
111 ###############################################################################
112 #                               C64 subpackage                                #
113 ###############################################################################
114
115 %package c64
116 Requires: %{name} = %{version}
117 Copyright: Freeware
118 Summary: C64 specific libraries and headers for the cc65 compiler.
119 Group: Development/Languages
120
121 %description c64
122 This package contains the header files and libraries needed to write
123 programs for the Commodore C64 using the cc65 crosscompiler.
124
125 %files c64
126 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
127 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
128 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
129 %attr(644,root,root)            /usr/lib/cc65/joy/c64-*.joy
130 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
131 %doc src/ld65/cfg/c64.cfg
132
133
134
135 ###############################################################################
136 #                               C128 subpackage                               #
137 ###############################################################################
138
139 %package c128
140 Requires: %{name} = %{version}
141 Copyright: Freeware
142 Summary: C128 specific libraries and headers for the cc65 compiler.
143 Group: Development/Languages
144
145 %description c128
146 This package contains the header files and libraries needed to write
147 programs for the Commodore C128 using the cc65 crosscompiler.
148
149 %files c128
150 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
151 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
152 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
153 %attr(644,root,root)            /usr/lib/cc65/joy/c128-*.joy
154 %doc src/ld65/cfg/c128.cfg
155
156
157
158 ###############################################################################
159 #                              Atari subpackage                               #
160 ###############################################################################
161
162 %package atari
163 Requires: %{name} = %{version}
164 Copyright: Freeware
165 Summary: Atari specific libraries and headers for the cc65 compiler.
166 Group: Development/Languages
167
168 %description atari
169 This package contains the header files and libraries needed to write
170 programs for the 8 bit Atari machines using the cc65 crosscompiler.
171
172 %files atari
173 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
174 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
175 %doc src/ld65/cfg/atari.cfg
176
177
178
179 ###############################################################################
180 #                              Plus/4 subpackage                              #
181 ###############################################################################
182
183 %package plus4
184 Requires: %{name} = %{version}
185 Copyright: Freeware
186 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
187 Group: Development/Languages
188
189 %description plus4
190 This package contains the header files and libraries needed to write
191 programs for the Commodore Plus/4 and C16/116 using the cc65
192 crosscompiler.
193
194 %files plus4
195 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
196 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
197 %doc src/ld65/cfg/plus4.cfg
198
199
200
201 ###############################################################################
202 #                               PET subpackage                                #
203 ###############################################################################
204
205 %package pet
206 Requires: %{name} = %{version}
207 Copyright: Freeware
208 Summary: PET specific libraries and headers for the cc65 compiler.
209 Group: Development/Languages
210
211 %description pet
212 This package contains the header files and libraries needed to write
213 programs for the Commodore PET family of computers using the cc65
214 crosscompiler.
215
216 %files pet
217 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
218 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
219 %doc src/ld65/cfg/pet.cfg
220
221
222
223 ###############################################################################
224 #                              CBM510 subpackage                              #
225 ###############################################################################
226
227 %package cbm510
228 Requires: %{name} = %{version}
229 Copyright: Freeware
230 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
231 Group: Development/Languages
232
233 %description cbm510
234 This package contains the header files and libraries needed to write
235 programs for the Commodore CBM 510 (aka P500) using the cc65
236 crosscompiler.
237
238 %files cbm510
239 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
240 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
241 %doc src/ld65/cfg/cbm510.cfg
242
243
244
245 ###############################################################################
246 #                              CBM610 subpackage                              #
247 ###############################################################################
248
249 %package cbm610
250 Requires: %{name} = %{version}
251 Copyright: Freeware
252 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
253 Group: Development/Languages
254
255 %description cbm610
256 This package contains the header files and libraries needed to write
257 programs for the Commodore PET-II (CBM600/700) family of computers using
258 the cc65 crosscompiler.
259
260 %files cbm610
261 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
262 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
263 %doc src/ld65/cfg/cbm610.cfg
264
265
266
267 ###############################################################################
268 #                             Apple ][ subpackage                             #
269 ###############################################################################
270
271 %package apple2
272 Requires: %{name} = %{version}
273 Copyright: Freeware
274 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
275 Group: Development/Languages
276
277 %description apple2
278 This package contains the header files and libraries needed to write
279 programs for the Apple ][ using the cc65 crosscompiler.
280
281 %files apple2
282 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
283 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
284 %doc src/ld65/cfg/apple2.cfg
285
286
287
288 ###############################################################################
289 #                               GEOS subpackage                               #
290 ###############################################################################
291
292 %package geos
293 Requires: %{name} = %{version}
294 Copyright: Freeware
295 Summary: GEOS specific libraries and headers for the cc65 compiler.
296 Group: Development/Languages
297
298 %description geos
299 This package contains the header files and libraries needed to write
300 GEOS programs for the C64/C128 using the cc65 crosscompiler.
301
302 %files geos
303 %attr(755,root,root)            /usr/bin/grc
304 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
305 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
306 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
307 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
308 %doc src/ld65/cfg/geos.cfg
309
310
311
312 ###############################################################################
313 #                                    Build                                    #
314 ###############################################################################
315
316
317
318 %prep
319 %setup
320
321
322 %build
323 # Binaries
324 cd src
325 make -f make/gcc.mak
326 cd ..
327 # Libraries
328 cd libsrc
329 make -s zap all
330 cd ..
331 # Documentation
332 cd doc
333 make html
334 cd ..
335
336
337 %install
338 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{geos,tgi},joy,lib,tgi}}
339
340 # Binaries
341 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
342 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
343 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
344 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
345 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
346 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
347 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
348 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
349 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
350 # Libraries and includes
351 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
352 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
353 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
354 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
355 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
356
357 # Drivers
358 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
359 install -m 644 libsrc/*.joy $RPM_BUILD_ROOT/usr/lib/cc65/joy
360 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
361
362
363
364 %changelog
365 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
366 Updated the version number.
367
368 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
369 Changed location of TGI drivers, added EM drivers.
370
371 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
372 Added the C16 subpackage.
373
374 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
375 Added TGI stuff.
376
377 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
378 Update to version 2.8.0 of the compiler package.
379
380 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
381 Update to version 2.7.1 of the compiler package.
382
383 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
384 Update to version 2.7.0 of the compiler package.
385
386 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
387 Update to version 2.6.2 of the compiler package.
388
389 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
390 Update to version 2.6.1 of the compiler package.
391
392 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
393 Update for cc65 2.6.0 and RedHat 7.x
394
395 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
396 The GEOS include files were not installed, remove headegen.sh
397
398 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
399 Update to version 2.5.0 of the compiler package.
400
401 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
402 Update to version 2.4.1 of the compiler package.
403
404 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
405 Update to version 2.4.0 of the compiler package.
406
407 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
408 Update to version 2.3.1 of the compiler package.
409
410 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
411 Update to version 2.3.0 of the compiler package.
412
413 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
414 [2.2.1-2]
415 - changed to allow build as plain user
416 - `samples' are part of documentation, not part of library
417