]> git.sur5r.net Git - cc65/blob - packages/rpm/redhat/cc65.spec
Bumped the version number
[cc65] / packages / rpm / redhat / cc65.spec
1 #
2 # SPEC file for the cc65 C compiler and RedHat 7.x
3 #
4 # 03/08/2001, Ullrich von Bassewitz (uz@cc65.org)
5 #
6
7 ###############################################################################
8 #                                Main package                                 #
9 ###############################################################################
10
11 Summary: Crosscompiler/Crossassembler for 6502 systems
12 %define name cc65
13 Name: %{name}
14 %define version 2.9.0
15 Version: %{version}
16 Release: 1
17 Copyright: Freeware with exceptions - see docs
18 Group: Development/Languages
19 Source: ftp://ftp.musoftware.de/uz/cc65/%{name}-sources-%{version}.tar.bz2
20 Vendor: MU Softwareentwicklung
21 Packager: Ullrich von Bassewitz <uz@musoftware.de>
22 %ifos linux
23 BuildRequires: perl
24 BuildRequires: sgml-tools
25 %endif
26 BuildRoot: /var/tmp/%{name}-%{version}
27
28 %description
29 A C crosscompiler for 6502 systems, including a macroassembler that
30 supports 6502, 65SC02 and 65816 CPUs, a linker, an archiver and some
31 other tools. To create programs for one of the supported target
32 machines, you have to install at least one of the library packages.
33
34 %files
35 %defattr(644,root,root,755)
36 %doc announce.txt
37 %doc doc/BUGS
38 %doc doc/CREDITS
39 %doc doc/*.html
40 %doc doc/compile.txt
41 %doc doc/grc.txt
42 %doc doc/internal.txt
43 %doc doc/newvers.txt
44 %doc doc/readme.1st
45 %doc samples
46 %attr(755,root,root)            /usr/bin/ar65
47 %attr(755,root,root)            /usr/bin/ca65
48 %attr(755,root,root)            /usr/bin/ca65html
49 %attr(755,root,root)            /usr/bin/cc65
50 %attr(755,root,root)            /usr/bin/cl65
51 %attr(755,root,root)            /usr/bin/da65
52 %attr(755,root,root)            /usr/bin/ld65
53 %attr(755,root,root)            /usr/bin/od65
54 %attr(755,root,root) %dir       /usr/lib/cc65
55 %attr(755,root,root) %dir       /usr/lib/cc65/emd
56 %attr(755,root,root) %dir       /usr/lib/cc65/lib
57 %attr(755,root,root) %dir       /usr/lib/cc65/tgi
58 %attr(755,root,root) %dir       /usr/lib/cc65/include
59 %attr(644,root,root)            /usr/lib/cc65/include/*.h
60 %attr(755,root,root) %dir       /usr/lib/cc65/include/tgi
61 %attr(644,root,root)            /usr/lib/cc65/include/tgi/*.h
62 %attr(755,root,root) %dir       /usr/lib/cc65/asminc
63 %attr(644,root,root)            /usr/lib/cc65/asminc/*.inc
64
65
66
67 ###############################################################################
68 #                              VIC20 subpackage                               #
69 ###############################################################################
70
71 %package vic20
72 Requires: %{name} = %{version}
73 Copyright: Freeware
74 Summary: VIC20 specific libraries and headers for the cc65 compiler.
75 Group: Development/Languages
76
77 %description vic20
78 This package contains the header files and libraries needed to write
79 programs for the Commodore VIC20 using the cc65 crosscompiler.
80
81 %files vic20
82 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.lib
83 %attr(644,root,root)            /usr/lib/cc65/lib/vic20.o
84 %doc src/ld65/cfg/vic20.cfg
85
86
87
88 ###############################################################################
89 #                                C16 subpackage                               #
90 ###############################################################################
91
92 %package c16
93 Requires: %{name} = %{version}
94 Copyright: Freeware
95 Summary: C16/116 specific libraries and headers for the cc65 compiler.
96 Group: Development/Languages
97
98 %description c16
99 This package contains the header files and libraries needed to write
100 programs for the Commodore C16/116 using the cc65 crosscompiler.
101
102 %files c16
103 %attr(644,root,root)            /usr/lib/cc65/lib/c16.lib
104 %attr(644,root,root)            /usr/lib/cc65/lib/c16.o
105 %doc src/ld65/cfg/c16.cfg
106
107
108
109 ###############################################################################
110 #                               C64 subpackage                                #
111 ###############################################################################
112
113 %package c64
114 Requires: %{name} = %{version}
115 Copyright: Freeware
116 Summary: C64 specific libraries and headers for the cc65 compiler.
117 Group: Development/Languages
118
119 %description c64
120 This package contains the header files and libraries needed to write
121 programs for the Commodore C64 using the cc65 crosscompiler.
122
123 %files c64
124 %attr(644,root,root)            /usr/lib/cc65/lib/c64.lib
125 %attr(644,root,root)            /usr/lib/cc65/lib/c64.o
126 %attr(644,root,root)            /usr/lib/cc65/emd/c64-*.emd
127 %attr(644,root,root)            /usr/lib/cc65/tgi/c64-*.tgi
128 %doc src/ld65/cfg/c64.cfg
129
130
131
132 ###############################################################################
133 #                               C128 subpackage                               #
134 ###############################################################################
135
136 %package c128
137 Requires: %{name} = %{version}
138 Copyright: Freeware
139 Summary: C128 specific libraries and headers for the cc65 compiler.
140 Group: Development/Languages
141
142 %description c128
143 This package contains the header files and libraries needed to write
144 programs for the Commodore C128 using the cc65 crosscompiler.
145
146 %files c128
147 %attr(644,root,root)            /usr/lib/cc65/lib/c128.lib
148 %attr(644,root,root)            /usr/lib/cc65/lib/c128.o
149 %attr(644,root,root)            /usr/lib/cc65/emd/c128-*.emd
150 %doc src/ld65/cfg/c128.cfg
151
152
153
154 ###############################################################################
155 #                              Atari subpackage                               #
156 ###############################################################################
157
158 %package atari
159 Requires: %{name} = %{version}
160 Copyright: Freeware
161 Summary: Atari specific libraries and headers for the cc65 compiler.
162 Group: Development/Languages
163
164 %description atari
165 This package contains the header files and libraries needed to write
166 programs for the 8 bit Atari machines using the cc65 crosscompiler.
167
168 %files atari
169 %attr(644,root,root)            /usr/lib/cc65/lib/atari.lib
170 %attr(644,root,root)            /usr/lib/cc65/lib/atari.o
171 %doc src/ld65/cfg/atari.cfg
172
173
174
175 ###############################################################################
176 #                              Plus/4 subpackage                              #
177 ###############################################################################
178
179 %package plus4
180 Requires: %{name} = %{version}
181 Copyright: Freeware
182 Summary: Plus/4 specific libraries and headers for the cc65 compiler.
183 Group: Development/Languages
184
185 %description plus4
186 This package contains the header files and libraries needed to write
187 programs for the Commodore Plus/4 and C16/116 using the cc65
188 crosscompiler.
189
190 %files plus4
191 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.lib
192 %attr(644,root,root)            /usr/lib/cc65/lib/plus4.o
193 %doc src/ld65/cfg/plus4.cfg
194
195
196
197 ###############################################################################
198 #                               PET subpackage                                #
199 ###############################################################################
200
201 %package pet
202 Requires: %{name} = %{version}
203 Copyright: Freeware
204 Summary: PET specific libraries and headers for the cc65 compiler.
205 Group: Development/Languages
206
207 %description pet
208 This package contains the header files and libraries needed to write
209 programs for the Commodore PET family of computers using the cc65
210 crosscompiler.
211
212 %files pet
213 %attr(644,root,root)            /usr/lib/cc65/lib/pet.lib
214 %attr(644,root,root)            /usr/lib/cc65/lib/pet.o
215 %doc src/ld65/cfg/pet.cfg
216
217
218
219 ###############################################################################
220 #                              CBM510 subpackage                              #
221 ###############################################################################
222
223 %package cbm510
224 Requires: %{name} = %{version}
225 Copyright: Freeware
226 Summary: CBM 510 specific libraries and headers for the cc65 compiler.
227 Group: Development/Languages
228
229 %description cbm510
230 This package contains the header files and libraries needed to write
231 programs for the Commodore CBM 510 (aka P500) using the cc65
232 crosscompiler.
233
234 %files cbm510
235 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.lib
236 %attr(644,root,root)            /usr/lib/cc65/lib/cbm510.o
237 %doc src/ld65/cfg/cbm510.cfg
238
239
240
241 ###############################################################################
242 #                              CBM610 subpackage                              #
243 ###############################################################################
244
245 %package cbm610
246 Requires: %{name} = %{version}
247 Copyright: Freeware
248 Summary: CBM 610 specific libraries and headers for the cc65 compiler.
249 Group: Development/Languages
250
251 %description cbm610
252 This package contains the header files and libraries needed to write
253 programs for the Commodore PET-II (CBM600/700) family of computers using
254 the cc65 crosscompiler.
255
256 %files cbm610
257 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.lib
258 %attr(644,root,root)            /usr/lib/cc65/lib/cbm610.o
259 %doc src/ld65/cfg/cbm610.cfg
260
261
262
263 ###############################################################################
264 #                             Apple ][ subpackage                             #
265 ###############################################################################
266
267 %package apple2
268 Requires: %{name} = %{version}
269 Copyright: Freeware
270 Summary: Apple ][ specific libraries and headers for the cc65 compiler.
271 Group: Development/Languages
272
273 %description apple2
274 This package contains the header files and libraries needed to write
275 programs for the Apple ][ using the cc65 crosscompiler.
276
277 %files apple2
278 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.lib
279 %attr(644,root,root)            /usr/lib/cc65/lib/apple2.o
280 %doc src/ld65/cfg/apple2.cfg
281
282
283
284 ###############################################################################
285 #                               GEOS subpackage                               #
286 ###############################################################################
287
288 %package geos
289 Requires: %{name} = %{version}
290 Copyright: Freeware
291 Summary: GEOS specific libraries and headers for the cc65 compiler.
292 Group: Development/Languages
293
294 %description geos
295 This package contains the header files and libraries needed to write
296 GEOS programs for the C64/C128 using the cc65 crosscompiler.
297
298 %files geos
299 %attr(755,root,root)            /usr/bin/grc
300 %attr(644,root,root)            /usr/lib/cc65/lib/geos.lib
301 %attr(644,root,root)            /usr/lib/cc65/lib/geos.o
302 %attr(755,root,root) %dir       /usr/lib/cc65/include/geos
303 %attr(644,root,root)            /usr/lib/cc65/include/geos/*.h
304 %doc src/ld65/cfg/geos.cfg
305
306
307
308 ###############################################################################
309 #                                    Build                                    #
310 ###############################################################################
311
312
313
314 %prep
315 %setup
316
317
318 %build
319 # Binaries
320 cd src
321 make -f make/gcc.mak
322 cd ..
323 # Libraries
324 cd libsrc
325 make -s zap all
326 cd ..
327 # Documentation
328 cd doc
329 make html
330 cd ..
331
332
333 %install
334 mkdir -p $RPM_BUILD_ROOT/usr/{bin,lib/cc65/{asminc,emd,include/{geos,tgi},lib,tgi}}
335
336 # Binaries
337 install -s -m 755 src/ar65/ar65 $RPM_BUILD_ROOT/usr/bin
338 install -s -m 755 src/ca65/ca65 $RPM_BUILD_ROOT/usr/bin
339 install -s -m 755 src/ca65html/ca65html $RPM_BUILD_ROOT/usr/bin
340 install -s -m 755 src/cc65/cc65 $RPM_BUILD_ROOT/usr/bin
341 install -s -m 755 src/cl65/cl65 $RPM_BUILD_ROOT/usr/bin
342 install -s -m 755 src/da65/da65 $RPM_BUILD_ROOT/usr/bin
343 install -s -m 755 src/grc/grc $RPM_BUILD_ROOT/usr/bin
344 install -s -m 755 src/ld65/ld65 $RPM_BUILD_ROOT/usr/bin
345 install -s -m 755 src/od65/od65 $RPM_BUILD_ROOT/usr/bin
346 # Libraries and includes
347 install -m 644 libsrc/*.lib libsrc/*.o $RPM_BUILD_ROOT/usr/lib/cc65/lib
348 install -m 644 include/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include
349 install -m 644 include/geos/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/geos
350 install -m 644 include/tgi/*.h $RPM_BUILD_ROOT/usr/lib/cc65/include/tgi
351 install -m 644 asminc/*.inc $RPM_BUILD_ROOT/usr/lib/cc65/asminc
352
353 # TGI and EM drivers
354 install -m 644 libsrc/*.emd $RPM_BUILD_ROOT/usr/lib/cc65/emd
355 install -m 644 libsrc/*.tgi $RPM_BUILD_ROOT/usr/lib/cc65/tgi
356
357
358
359 %changelog
360 * Fri Dec 13 2002 Ullrich von Bassewitz <uz@cc65.org>
361 Updated the version number.
362
363 * Mon Dec 2 2002 Ullrich von Bassewitz <uz@cc65.org>
364 Changed location of TGI drivers, added EM drivers.
365
366 * Fri Nov 22 2002 Ullrich von Bassewitz <uz@cc65.org>
367 Added the C16 subpackage.
368
369 * Wed Nov 20 2002 Ullrich von Bassewitz <uz@cc65.org>
370 Added TGI stuff.
371
372 * Mon Apr 08 2002 Ullrich von Bassewitz <uz@cc65.org>
373 Update to version 2.8.0 of the compiler package.
374
375 * Wed Nov 07 2001 Ullrich von Bassewitz <uz@cc65.org>
376 Update to version 2.7.1 of the compiler package.
377
378 * Tue Oct 02 2001 Ullrich von Bassewitz <uz@cc65.org>
379 Update to version 2.7.0 of the compiler package.
380
381 * Thu Jul 23 2001 Ullrich von Bassewitz <uz@cc65.org>
382 Update to version 2.6.2 of the compiler package.
383
384 * Thu Mar 8 2001 Ullrich von Bassewitz <uz@cc65.org>
385 Update to version 2.6.1 of the compiler package.
386
387 * Sat Dec 6 2000 Ullrich von Bassewitz <uz@cc65.org>
388 Update for cc65 2.6.0 and RedHat 7.x
389
390 * Sun Jul 30 2000 Ullrich von Bassewitz <uz@musoftware.de>
391 The GEOS include files were not installed, remove headegen.sh
392
393 * Tue Jul 18 2000 Ullrich von Bassewitz <uz@musoftware.de>
394 Update to version 2.5.0 of the compiler package.
395
396 * Sat May 06 2000 Ullrich von Bassewitz <uz@musoftware.de>
397 Update to version 2.4.1 of the compiler package.
398
399 * Tue Jan 16 2000 Ullrich von Bassewitz <uz@musoftware.de>
400 Update to version 2.4.0 of the compiler package.
401
402 * Tue Jan 6 2000 Ullrich von Bassewitz <uz@musoftware.de>
403 Update to version 2.3.1 of the compiler package.
404
405 * Tue Jan 4 2000 Ullrich von Bassewitz <uz@musoftware.de>
406 Update to version 2.3.0 of the compiler package.
407
408 * Sat Sep 25 1999 Robert R. Wal <rrw@reptile.eu.org>
409 [2.2.1-2]
410 - changed to allow build as plain user
411 - `samples' are part of documentation, not part of library
412